Joomladay francophone 2018 à Paris 18 et 19 mai

Installation de VM 1.1.3

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Installation de VM 1.1.3

    Bonjour à tous,

    je suis nouveau et débutant dans la communauté Joomla ainsi que dans la création de site web, après avoir installé mon site, non sans mal, j' essaye d'installer et d'administrer de nouveau modules/plugins.

    Après avoir lu les différents tuto, notament ( http://forum.joomla.fr/showthread.php?t=89922 )
    J'ai tenté d'installer automatiquemant VirtueMart 1.1.3-COMPLETE_PACKAGE.j15 sur mon site (étant novice c'était la solution la plus adaptée pour moi), mais sans succés.

    Lors de l'installe via la gestion d'extensions de mon site, J'ai ces message d'erreur :

    Attention ! - Le fichier n'a pas pu être déplacé

    Impossible de trouver un pack d'installation.
    Quelqu'un pourrait-il me donner une soluce ou un lien me permettant de régler ce petit soucis ? Car de mon côté je n'ai rien trouvé en passant par la case "recherche"

    Bien évidemment je reste à votre entière disposition, si vous désirez de plus amples informations.

    Merci par avance.

    Cordialement

    Pour info :
    Version de PHP: 4.4.9
    Serveur Web: Apache/2.2.X (OVH)
    Du serveur Web à l'interface PHP: cgi
    Version de Joomla!: Joomla! 1.5.14 Stable
    Mode de sécurité (safe mode): Désactivé
    Zlib activé: Oui

    Marcool
    Dernière édition par Marcool à 13/08/2009, 19h43

  • #2
    bonsoir,

    c'est parce que les fichiers à l'intérieur du dossier compressé sont eux également zippés.

    Passes en installation manuelle, voici le lien de téléchargement:
    https://dev.virtuemart.net/cb/displa...gz?doc_id=2874

    Ensuite, transfert l'ensemble des répertoires contenu dans l'archive directement depuis ton client FTP.

    A+

    Commentaire


    • #3
      Il n'est pas besoin de faire une installation manuelle. Il faut dézipper le "complete package" pour installer individuellement le composant et ses compléments.
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Merci pour vos réponses, je vais retester tout cela et vous tiendrais informé de l'évolution des choses.

        A RobertG : J'ai bien décompressé l'archive "complete package" et j'obtiens un dossier "modules", un dossier "plugins" et un dossier zippé "com_virtuemart_1.1.3-.15.zip" c'est ce dernier que je lance depuis la gestion d'extensions de mon site, mais c'est lors de l'exécution de celui-ci que j'ai le message cité dans mon premier post.

        Comme le souligne skymid, j'ai effectivement d'autres fichiers zippé à l'intérieur des dossiers "modules", "plugins" et "com_virtuemart_1.1.3-.15.zip" est-ce normal ou dois je les décompresser également ?

        Amicalement

        Commentaire


        • #5
          Salut Marcool,

          As-tu vu ce post ? http://forum.joomla.fr/showthread.php?t=99719

          A+

          Commentaire


          • #6
            Non, tu les laisses zippé.
            Et par la suite, va dans Extensions=>Installer/Désinstaller, parcourir, puis prends ton fichier zip "com_virtuemart_1.1.3-.15.zip" et patiente...

            et par la suite tu feras la même chose pour les modules ou composants de ton choix.

            Si problème, fait appel.

            Salutation
            Pas beaucoup d'interventions, mais le Forum est mon livre de chevet.
            Mon dernier site :
            http://www.artisans-commercants-la-planche.fr/
            http://http://www.meubledeco.coccimarket-laplanche.fr

            Commentaire


            • #7
              Marcool, ce sont des problèmes de droits sur les fichiers/répertoires (au moins le répertoire "tmp") qui provoquent l'erreur que tu cites.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire


              • #8
                Merci à tous pour vos réponses.
                J'ai finalement installé VM de façon manuelle, mais j'ai eu un autre soucis c'est que à l'ouverture de certaines pages de VM j'ai une erreur venant de IE qui me me signale qu'internet explorer à abandonné l'ouveture de la page. J'ai donc décidé de désinstaller complétement VM de mon site afin de refaire une installation propre.

                Envoyé par RobertG
                Marcool, ce sont des problèmes de droits sur les fichiers/répertoires (au moins le répertoire "tmp") qui provoquent l'erreur que tu cites.
                Je vois effectivement via l'administration de Joomla dans les infos systéme que j'ai 2 dossiers qui sont en lecture seule alors que tous les autres sont "modifiable".

                Dossier des journaux ($log_path) / Lecture seule
                Dossier temporaire ($tmp_path) / Lecture seule
                Est-ce normal ?
                Dans le cas ou ce serait ces 2 dossiers qui m'empécheraient d'installer automatiquement VM, pouvez vous me dire et comment je peux modifier les droits de ces fichiers ?

                Merci par avance

                Cordialement

                Commentaire


                • #9
                  Envoyé par Marcool Voir le message
                  Merci à tous pour vos réponses.
                  J'ai finalement installé VM de façon manuelle, mais j'ai eu un autre soucis c'est que à l'ouverture de certaines pages de VM j'ai une erreur venant de IE qui me me signale qu'internet explorer à abandonné l'ouveture de la page. J'ai donc décidé de désinstaller complétement VM de mon site afin de refaire une installation propre.
                  Pour cette erreur, le post #9 de cette page ne la corrige pas ?
                  http://forum.joomla.fr/showthread.php?t=89922


                  Je vois effectivement via l'administration de Joomla dans les infos systéme que j'ai 2 dossiers qui sont en lecture seule alors que tous les autres sont "modifiable".


                  Est-ce normal ?
                  Dans le cas ou ce serait ces 2 dossiers qui m'empécheraient d'installer automatiquement VM, pouvez vous me dire et comment je peux modifier les droits de ces fichiers ?

                  Merci par avance

                  Cordialement
                  pour les permissions de fichiers, toujours avec le meme lien, consulte le post #26

                  a plus
                  sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                  http://virtuemart.fr

                  Commentaire


                  • #10
                    Pour tes permissions de répertoires, vérifie que les chemins dans le fichier configuration.php sont corrects et/ou que tes deux répertoires en questions sont en 755 (voire 777).
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Bonjour,

                      Pour ce qui est du chemin de mes 2 dossiers, dans le fichier configuration.php, j'ai ceci
                      var $log_path = '';
                      var $tmp_path = '';
                      Mais je ne sais pas qu'elle adresse je dois leurs attribuer ? Ni a quel dossier ils correspondent réellement?

                      Correspondent ils aux dossiers www/logs et www/tmp ?

                      Amicalement

                      Commentaire


                      • #12
                        Désolé pour la réponse tardive, mais c'était bien un problème de droits sur les dossiers logs et tmp, le problème est belle et bien résolu.

                        Encore un grand merci à toutes les personnes qui m'on aidé à résoudre le problème.

                        Cela fait plaisir a voir, un forum ou on aide les novices !

                        Cordialement

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X