Pb kit cybermut cmcic3.0

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Pb kit cybermut cmcic3.0

    Bonjour,

    je rencontre un petit pb lors de la config du kit de paiement cybermut cmcic v3.0 (sur une boutique joomla 1.5.14 - virtuemart 1.1.3 - hébergement Nuxit) - en fait l'essentiel fonctionne correctement, par contre dans la page de config du module, je ne retrouve pas les mêmes infos que celle décrites par Alatac dans son tuto sur la config de ce module, il manque en particulier, la ligne :
    - Serveur de paiement automatique: sélectionnez Oui si vous voulez que l'internaute soit redirigé vers le serveur de paiement.



    (ce qui oblige le client à cliquez sur le logo banque pour être redirigé vers le serveur de paiement, alors que la page lui affiche que sa commande est déjà validéée...)

    autre bug mineur, les variables "debug" et "logo" affiche le nom de la variable avec une balise php, au lieu du texte prévu : _('PS_CMCIC_DEBUG') ?> et _('PS_CMCIC_LOGO')."---".CMCIC_LOGO ?>

    Une idée serait la bienvenue, car je ne comprends pas d'où vient ce pb dans la mesure ou j'ai bien suivi le tuto de Alatak et installé le module cmcic_V30_J15_VM11_v2.0.

    cdlt
    Olivier
    Dernière édition par otuff à 14/08/2009, 09h40

  • #2
    Quelqu'un pourrait il me dire (ou afficher ou mettre en lien) ce qu'il a dans son fichier ps_cmcic.php, notamment entre les lignes 185 et 201, car le mien ne contient aucune ligne faisant référence à l'option manquante ( Serveur de paiement automatique: sélectionnez Oui si ...), donc normal que rien ne s'affiche pour cette option...

    extrait de mon ps_cmcic.php ligne 185 à 201

    Code:
              <tr class="row0">
                <td><strong><? echo $CMCIC_LANG->_('PS_CMCIC_DEBUG') ?></strong></td>
                <td>
    			 	<select name="CMCIC_DEBUG" class="inputbox" >
                    <option <?php if (CMCIC_DEBUG == 'yes') echo "selected=\"selected\""; ?> value="<?php echo 'yes' ?>"><?php echo  $VM_LANG->_('PHPSHOP_ADMIN_CFG_YES') ?></option>
                    <option <?php if (CMCIC_DEBUG == 'no') echo "selected=\"selected\""; ?> value="<?php echo 'no' ?>"><?php echo $VM_LANG->_('PHPSHOP_ADMIN_CFG_NO') ?></option>
                    </select>
                </td>
                <td><? echo $CMCIC_LANG->_('PS_CMCIC_DEBUG_INFO') ?></td>
            </tr>
             <tr class="row0">
                <td>&nbsp;</td>
                  <td>&nbsp;</td>
                     <td>&nbsp;</td>
            </tr>
              <tr class="row0">
                <td valign="top"><strong><? echo $CMCIC_LANG->_('PS_CMCIC_LOGO')."---".CMCIC_LOGO ?></strong></td>
    Bien qu'ayant télécharger le kit sur le site de alatak, j'ai un petit doute sur l'intégrité de ce fichier qui ne correspond pas à la description du tutoriel d'install.

    merci pour vos réponses.

    Olivier

    Commentaire


    • #3
      up - Pb kit cybermut cmcic3.0

      up

      personne n'utilise cmcic ?

      Commentaire


      • #4
        Soucis identique

        Bonjour,

        Je mets depuis hier en oeuvre CyberMut 3.0. Même config, mêmes fichiers dans les mêmes versions.... et, bien entendu, je rencontre très exactement les mêmes soucis !

        Please help!

        Merci,
        Eric.

        Commentaire


        • #5
          Bonjour,

          pas d'inquiétude à avoir.

          C'était une phrase en trop dans le tutoriel. Merci de me l'avoir signalée, je l'ai supprimée.

          Il y avais une petite erreur dans la sélection du logo. Je viens de faire la mise à jour: la nouvelle version s'appelle:

          cmcic_V30_J15_VM11_v2.1.zip
          alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

          Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

          Commentaire


          • #6
            Merci Alatak mais j'ai un petit soucis. Je viens de metre à jour les fichiers avec le nouveau kit et lorsque je rentre dans la configuration du moyen de paiement la page ne s'affiche pas correctement et j'obtiens l'erreur suivante :

            /home/teletrav/sd/catalogue/www/administrator/components/com_virtuemart/classes/payment/ps_cmcic.cfg.php :: Modifiable
            Direct Access to this location is not allowed.

            Une idée ?

            J'ai procédé à la mise à jour par un simple téléchargement du nouveau kit. J'espère n'avoir pas fait de bétise et que c'est bien ainsi ?...

            Par avance merci,
            Eric.

            Commentaire


            • #7
              Va dans le fichier home/teletrav/sd/catalogue/www/administrator/components/com_virtuemart/classes/payment/ps_cmcic.cfg.php

              et efface l'ensemble du contenu.

              Je corrige cela tout de suite.
              alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

              Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

              Commentaire


              • #8
                Merci.

                Entre temps, j'ai simplement supprimé la méthode de paiement puis l'ai recréé dans la foulée. Cà fonctionne ...

                ... mais je crois comprendre que tu vas faire une mise à jour di kit. J'attends donc cela.

                Merci encore,
                Eric.

                Commentaire


                • #9
                  j'en reviens au sujet initial de ce post,
                  suite à la réponse de Alatak, on peut donc en déduire que le module config ne propose pas d'option pour que l'internaute soit redirigé automatiquement vers le serveur de paiement, et que ce dernier doit donc cliquer sur le logo pour effectuer son paiement ; c'est bien cela ?

                  dommage, pourquoi cette option n'est + disponible dans cette version du kit ?

                  merci
                  a+
                  olivier

                  Commentaire


                  • #10
                    Bonjour,

                    Cette option n'existait pas avant.

                    La phrase était dans le tutoriel, car c'est une option que j'aurais aimé mettre en place, mais je n'ai pas eu le temps de tester.

                    Je n'ai pas de site pour tester en ce moment.
                    Je te joins le fichier ou je fais automatiquement le basculement vers la banque.

                    Dans la configuration du paiement, dans Information de paiement supplémentaire: met

                    Code PHP:
                    <?php require_once(PAGEPATH."checkout.cmcic_cc_form_test.php" ); ?>
                    Dis moi si ca marche.
                    Fichiers joints
                    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                    Commentaire


                    • #11
                      test redirection serveur paiement

                      Bonjour,

                      j'ai tester avec le fichier joint, que j'ai upload dans /com_virtuemart/html (coté admin), et le rajout de code dans Information de paiement supplémentaire, mais ce ne fonctionne pas :
                      aucun message d'erreur, mais aucune redirection vers le serveur, j'obtiens le message de confirmation de commande, mais sans aucun liens, ni style css du site (voir jpeg ci joint) ;



                      tout semble ok au niveau de la commande, bien enregistrée sur le site, panier vidé, mais niet coté paiement...

                      je peut faire d'autres tests, ou te faire suivre d'autres infos si besoin ;

                      merci
                      a+
                      Olivier

                      Commentaire


                      • #12
                        Bonjour,

                        Merci du retour, je vais regarder.
                        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                        Commentaire


                        • #13
                          alors ?

                          Juste une question alatak, j'ai une boutique en attente depuis 1 semaine de l'interfaçage bancaire, j'ai le même problème qu'otuff.
                          Est-ce que tu pense résoudre ce problème et sous quel délai ?

                          Excuse-moi, ce n'est pas pour te brusquer, juste pour que j'informe mon client.

                          Si je peux aider, n'hésite pas à me le dire.

                          a+

                          Commentaire


                          • #14
                            Bonjour,
                            Je suis aussi très intéressé pour la mise en oeuvre de la redirection.
                            Le cas échéant, je suis aussi disponible pour apporter une assistance, tests ou autre...
                            Cdlt,
                            Eric.

                            Commentaire


                            • #15
                              UP ? du neuf ? je rencontre les mêmes problemes...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X