Joomladay francophone 2018 à Paris 18 et 19 mai

bug d'affichage

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • bug d'affichage

    Je repost un message sur des bugs d'affichage du module virtuemart, si qq'un a les mêmes et/ou une solution

    Lorsque je suis sur mon panier, par moment j'ai les commandes "continuer achats" et "commander" (lorsque je fais une première commande. Si je retourne sur une autre page et que je retourne ensuite ds mon panier, seule la commande "commander" reste (pas très propre)

    DE plus lorsque je clique sur "continuer achat", je retourne sur mon article mais la mise a page a changé et est degueulasse...

    Enfin, lorsque je vide mon panier avec l'icône poubelle, j'ai bien l'affichage de "mon panier est vide" ds le corps du texte, mais mon menu repasse sur le menu accueil au lieu de rester sur boutique (mes menus sont surlignés pour expliquer a l'utilisateur ou il se trouve) donc c'est pas très logique pour l'utilisateur

    Merci d'avance

  • #2
    Bon, le plus simple je pense pour moi, c'est de virer le "continuer achats", mais je ne sais pas trop ou se trouve le fichier php adequat. Qu' un sait?

    Commentaire


    • #3
      tu trouveras cela ici

      tonsite\administrator\components\com_virtuemart\la nguages\shop\french

      variable : PHPSHOP_CONTINUE_SHOPPING
      sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
      http://virtuemart.fr

      Commentaire


      • #4
        super, merci

        Commentaire


        • #5
          de nada!

          a plus
          sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
          http://virtuemart.fr

          Commentaire


          • #6
            j'essaye aussi de virer l'image back.png. J'ai supprimé le lien ds le fichier theme.css de virtuemart (balise .continue_link) mais ca m'affiche tjs l'icone...
            J'avoue que le mieux serait de le virer du code php je pense

            Commentaire


            • #7
              ou tu renommes ton image back.png par back1.png, par exemple. vide ton cache aussi
              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
              http://virtuemart.fr

              Commentaire


              • #8
                ok, c'etait un pb de cache malgré mes ctrl F5. Merci

                J'ai encore un soucis Tu sais ou se trouve le code qui affiche "Info: Le produit a été ajouté à votre panier." lorsque qu'on ajoute un article et qu'on a desactivé l'ajax?

                Commentaire


                • #9
                  administrator\components\com_virtuemart\languages\ common\french.php

                  et trouve : VM_CART_PRODUCT_ADDED
                  sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                  http://virtuemart.fr

                  Commentaire


                  • #10
                    oui, ca je l'ai trouvé, mais c'est le terme Info que je ne trouve pas. De plus, il y a ds le theme.css une mise en page communue pour different type de message (tip, warning, error etc...) ligne 238. Je pensais a la rigueur virer tout ca, mais je me dis que des messages pour le debuggage ou d'erreur pour un client lors d'un remplissage de formulaire par exemple pourrait tomber a la trappe si je fais ca. J'aimerais plutot trouver ou la condition ds le bon fichier php qui engendre le message lorsqu'on ajoute un article.. t'en pense quoi?

                    Commentaire


                    • #11
                      tu peux peut etre ne virer que shop_info
                      sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                      http://virtuemart.fr

                      Commentaire


                      • #12
                        salut

                        Je reviens vers toi, tu semble etre la bible de virtuemart
                        A l'etape commander, j'ai un autre bug d'affichage: les etapes et les images de caddie se chevauchent, ca fait pas tres propre. ca te dis qq chose un post sur ce sujet?

                        Commentaire


                        • #13
                          Envoyé par xxavvfr Voir le message
                          Je reviens vers toi, tu semble etre la bible de virtuemart
                          On ne me l'avait jamais faite celle-la...
                          je suis surtout un scribe, avant tout!

                          A l'etape commander, j'ai un autre bug d'affichage: les etapes et les images de caddie se chevauchent, ca fait pas tres propre. ca te dis qq chose un post sur ce sujet?
                          est-ce que ce serait du style l'image1 et l'image 2 s'affichent en meme temps (donc tu as 2 caddies rouges) ? quand tu dis qu'elles se chevauchent, utilises-tu la recriture d'url ? as-tu cumule des etapes du caddy (2 en 1) ?

                          un petit snapshot serait bien venu.

                          ou un lien...

                          a plus
                          sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                          http://virtuemart.fr

                          Commentaire


                          • #14
                            alors, je reprend

                            il n'y a qu'une image qui change a chaque etape: checkout4_1.png ds le repertoire theme/default/images/checkout.
                            En fait le texte qui est au dessus chevauche l'image:
                            voir impression ecran en piece jointe

                            1) ma premiere idée serait de refaire les images sous toshop en moins haute, mais je suis pas une star de toshop pour ca

                            2) 2eme idee: modifier le code source, mais j'ai peur d'avoir de incompatibilités avec les divers navigateurs si je m'y prend mal...

                            J'ai regardé sur les post, je suis etonné que personne ai ce pb, mais ca doit surement venir de mon template qui gere mal l'affichage
                            Fichiers joints

                            Commentaire


                            • #15
                              Envoyé par xxavvfr Voir le message
                              2) 2eme idee: modifier le code source, mais j'ai peur d'avoir de incompatibilités avec les divers navigateurs si je m'y prend mal...
                              a ce sujet, cela se presente-t'il pour tous les navigateurs ?
                              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                              http://virtuemart.fr

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X