CyberMut payetest CGI2 : NOT OK

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] CyberMut payetest CGI2 : NOT OK

    Bonjour,
    j'ai un soucis avec cybermut, l'installation c'est bien passé,
    mais lorsque je passe sur mon site en mode test, j'ai un retour cgi2 : not ok
    et voila se qu'affiche le debug :

    <form action="https://paiement.creditmutuel.fr/test/paiement.cgi" method="post" id="PaymentRequest">
    <input type="hidden" name="version" value="3.0" />
    <input type="hidden" name="TPE" value="0833589" />
    <input type="hidden" name="date" value="15/09/2009:14:14:53" />
    <input type="hidden" name="montant" value="7.62EUR" />
    <input type="hidden" name="reference" value="36" />
    <input type="hidden" name="MAC" value="ca180970ac5f4638c606a74723cb80759b6f5835" />
    <input type="hidden" name="url_retour" value="http://monsite.fr/index.php?page=checkout.cmcic_response&option=com_ virtuemart&retour=ko" />
    <input type="hidden" name="url_retour_ok" value="http://monsite.fr/index.php?page=checkout.cmcic_response&option=com_ virtuemart&retour=ok" />
    <input type="hidden" name="url_retour_err" value="http://monsite.fr/index.php?page=checkout.cmcic_response&option=com_ virtuemart&retour=ko" />
    <input type="hidden" name="lgue" value="FR" />
    <input type="hidden" name="societe" value="alm" />
    <input type="hidden" name="texte-libre" value="" />
    <input type="hidden" name="mail" value="monsite@hotmail.com" />
    <input type="submit" name="bouton" value="Connexion au serveur de paiement" />
    </form>


    Chaîne utilisée pour le calcul du sceau HMAC
    Numéro de TPE*date*montant*référence*texte libre*version*code langue*code société*email*nombre échéance*date échéance1*montant échéance1*date échéance2*montant échéance2*date échéance3*montant échéance3*date échéance4*montant échéance4*options

    0833589*15/09/2009:14:14:53*7.62EUR*36**3.0*FR*alm*monsite@hotma il.com**********
    je suis sous vm 1.1.3 et joomla 1.5.14
    et quand je vais a cette adresse :
    www.monsite.fr/cmcic_cgi2.php
    voila se que j'y trouve
    version=2 cdr=1 0833589*****3.0***************

    d'autre part j'ai testé egalement en version normal et non debugé et
    le serveur me laisse payer, tout se passe correctement, sauf que l'argent n'arrive pas sur le compte
    et que je reçois dans un 2ieme temps un mail du credit mutuel me disant qu'il y a une erreur
    mais ils ne prescient pas laquelle

    Si quelqu'un peu m'aider !!Merci beaucoup!

  • #2
    Bonjour,

    as tu donné l'URL CGI2 a la banque???

    Si tu ne l'as pas fait, alors le problème est là.
    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

    Commentaire


    • #3
      oui ca a deja ete fait.
      Par contre se que j'ai oublié de préciser c'est que le tpe est déjà utilisé
      sur un autre site géré par clicboutique et non joomla, et sur celui ci il fonctionne tres bien.
      Lors de cette 2ieme installation j'ai précisé à la banque que c'etait un 2ieme site.
      Voila je sais pas si ca peu avoir un lien ..

      Merci

      Commentaire


      • #4
        Bonjour,

        Lors de cette 2ieme installation j'ai précisé à la banque que c'etait un 2ieme site.
        Je ne crois pas que cela soit possible. A ma connaissance il n'y a que 1 adresse CGI. Si ce n'est pas le cas, tiens nous au courant.

        Tu devrais quand même verifier que l'adresse a bien ete configure de leur coté. Parfois cela prend quelques jours.
        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

        Commentaire


        • #5
          J'ai renvoyé un mail au credit mutuel pour etre sur que l'adresse CGI2 été enregistrer chez eux.
          Pour eux tout est ok, voila leur reponse :

          Bonjour,

          Effectivement le retour CGI2 sur l'adresse : http://www.almboutique.com/cmcic_response.php semble poser problème.

          Il vous faut vérifier les paramètres de cette page. Nous faisons que la renseigner de notre côté et ne pouvons agir dessus.
          almboutique étant l'autre site sur lequel le tpe a ete installé en 1er.

          Alatak pour répondre a ta question on peut effectivement utiliser un TPE sur plusieurs site
          mais a 1er vue sa pose quelque problème
          si vous avez une idée moi je patauge complet...

          Commentaire


          • #6
            bonjour

            Dans le tutoriel je parle de cette URL:

            http://www.votresite.com/cmcic_cgi2.php.
            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

            Commentaire


            • #7
              Bonjour,
              Pour toi effectuer le test avec ta banque pour une seconde boutique c'est tout a fait faisable.
              Il suffit a ta banque qu'il te donner l'URL de test qu ils ont pour la preprod.
              Tu ne peux pas utiliser le TPE en production de ta boutique N°1 pour faire les tests de la boutique N°2

              Voila si cela peut aider.
              Hébergeur 720plan OVH - Joomla 1.15.15 virtuemat 1.1.4 stable

              Commentaire


              • #8
                oki merci beaucoup.
                je vais leur demander ca de suite

                Commentaire


                • #9
                  Voir aussi chez ton hébergeur

                  Salut,

                  Certains hébergeurs donnent des conditions particulières pour l'exécution de CGI.

                  Dans la majorité des cas, il suffit de mettre le fichier à la racine du site, comme le font 90% des utilisateurs, mais certains exigent que le fichier soit placé dans un répertoire CGI-BIN à la racine du FTP.

                  Alatak en parle dans ses différents tutos et dans son excellent livre.

                  Tu devrais donc te renseigner auprès du support technique de ton hébergeur. Si c'est ton cas, tu devras transmettre le nouveau chemin à ta banque.

                  Quand tu dis que le paiement n'est pas crédité sur ton compte, as-tu vérifié que la transaction n'est pas présente dans l'interface de gestion des paiement de la Cybermut et que tu dois simplement valider manuellement le paiement? Ce arrive parfois, mais en général, tu reçois un message qui te dis que ton serveur n'a pas répondu favorablement à la requête, mais que cela n'a aucune incidence sur le paiement de la transaction (il faut quand même aller la valider manuellement). A la CIC, bien que tout fonctionne parfaitement pour ma boutique, il arrive parfois que je sois obligé de valider manuellement un paiement. Je pense que la latence fuctuante du retour de mon hébergeur en est la cause. Dans ce cas là, j'attends quelques jours pour voir si la somme est réellement créditée sur mon compte, avant d'envoyer la commande.
                  L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

                  Ne réponds pas aux MPs. Exposez votre problème sur le forum !

                  Commentaire


                  • #10
                    Bonjour,
                    en effet je n'avais pas pensé a regarder sur le l'interface de gestion
                    et mes paiements y ete bien, il faut donc que je les valide manuellement.
                    Par contre j'ai se message sur certaine commande :

                    Le paiement a été effectué.La confirmation du paiement a été envoyée à votre serveur. Cependant votre serveur n'a pas renvoyé d'accusé de réception valide.

                    cela peut il venir de l'emplacement du fichier CGI2 qui se trouve actuellement en effet dans la racine de mon site ?
                    Par contre en effet j'ai un dossier cgi-bin à la racine de mon ftp, cela veut il dire que je doit changer l'emplacement du fichier cgi2 ? ou vaut il mieux que je demande en 1er lieu a mon hébergeur, qui est OVH ?

                    Encore merci pour votre aide !!! Vous m'enlevez une énorme aiguille du pied

                    Commentaire


                    • #11
                      Demande au support technique

                      Le mieux est de demander au support technique car chez Celeonet, par exemple, il y a aussi un répertoire CGI-BIN à la racine, mais j'ai pu faire marcher le CMCIC3.0 v2.1, sans rien déplacer.

                      Si tu déplaces le CGI2, tu devras en informer ta banque pour qu'elle procède aux modifications du lien et si ce n'est pas la cause de ton problème, tu seras de nouveau bloquée.

                      Car souvent, le serveur de la banque considère que la réponse de retour n'est pas parvenue, alors que c'est seulement un délais jugé trop long dans la chaine de transmission de la réponse. Ce peut être permanent, comme chez certains de mes clients (qui doivent systématiquement valider manuellement chaque commande), et ponctuel pour d'autres (en fonction du trafic sur le site ou une latence intempestive du serveur), tout dépend de l'hébergement.

                      Cette validation manuelle peut paraitre insignifiante, pour certains, mais juridiquement le vendeur devient "responsable" de la transaction. En cas de litige, la responsabilité du vendeur peut être engagée.

                      Cordialement.
                      Dernière édition par cybergaby à 17/09/2009, 11h58 Raison: faute de frappe
                      L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

                      Ne réponds pas aux MPs. Exposez votre problème sur le forum !

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X