Joomladay francophone 2018 à Paris 18 et 19 mai

mod_virtuemart_login

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • mod_virtuemart_login

    Bonjour a tous ,

    Voila j ai un souci , j ai un text connexion quand on klick dessus j ai une petite fenetre qui s'ouvre. La j ai mis le mod_virtuemart_login mais rien ne s'affiche , j ai rajouté donc le mod_login et la les deux login sont present. Âpres plusieurs manip différente rien a faire l un ne va pas sans l autre dans cette fenêtre.
    Avez vous une idée ???

    Une autre idée m est venu pourquoi ne pas modifier les parametres de mod_login pour les renvoyer vers mod_virtuemart_login .

    Créer un compte renvoie vers index.php?option=com_user&task=register
    et mettre a la place index.php?option=com_virtuemart&page=shop.registra tion&Itemid=1
    est ce possible ???? Si oui dans qu elle fichier.
    Car le fichier php mod_login est écrit d'une façon bizard

    En editant le plugin de compatibilité entre les versions si je reprend l ancien mod_login qui m a l aire plus simple a manipuler cela va marcher?

    Info:je suis en local Joomla :Version 1.5.14 / VirtueMart 1.1.3 stable
    Dernière édition par bozo à 02/11/2009, 10h39

  • #2
    En editant le plugin de compatibilité entre les versions si je reprend l ancien mod_login qui m a l aire plus simple a manipuler cela va marcher?
    Bonjour

    C'est se compliquer la donne de faire cela.
    Le module login de virtuemart est lié a celui de joomla pour les inscriptions mais il a plus de fonction dans virtuemart...que joomla ne gérera pas!

    Voila j ai un souci , j ai un text connexion quand on klick dessus j ai une petite fenetre qui s'ouvre. La j ai mis le mod_virtuemart_login mais rien ne s'affiche , j ai rajouté donc le mod_login et la les deux login sont present
    Je ne comprend pas bien ton souci tu peux développer s'il te plait...mais une chose est sur c'est que si tu utilises virtuemart il ne faut pas utiliser le module login de joomla, celui de virtuemart prend en quelque sorte le relais avec sa gestion user pour ta boutique.

    @+
    SVP pas de MP pour de l'aide, le forum est l’outil idéal

    Commentaire


    • #3
      Voila j ai un emplacement hidden2 cree uniquement pour le login.J ai essayé de mettre le mod_login_virt mais rien ne s affiche quand je click sur le bouton( voir photo) , je met maintenant uniquement le mod_login et la j ai bien ma fenêtre qui apparait.Je refait un test en désactivant le mod_login plus rien. Je mets les deux modules a la position hidden2 et la tout ok sauf que je me retrouve avec 2 login.


      http://www.casimages.com/img.php?i=0...2534767731.jpg
      Dernière édition par bozo à 02/11/2009, 11h11

      Commentaire


      • #4
        S il vous plait de l aide ou si vous avez besoin d'autre information

        Commentaire


        • #5
          Voila j ai un emplacement hidden2
          Bonjour

          Donc cet emplacement est propre a ton template.
          Je pense plutôt qui te faut voir au niveau de ton css comment faire afficher ce hidden avec le "mod_virtuemart_login"

          Ce qui implique une modif hors virtuemart c'est complexe mais faisable!

          @+
          SVP pas de MP pour de l'aide, le forum est l’outil idéal

          Commentaire


          • #6
            Je vais mettre ca de coté pour le moment. Car je suis pas du tout programmeur juste un débutant qui patauge un peu.

            En tout cas merci de ton aide lionel123 si jamais tu as un peu de temps voila le nom du template e-shop de Gavick.

            Commentaire


            • #7
              Mais rassures moi...quand tu édites le module login dans un user par exemple il est bien visible en front du site?

              @+
              SVP pas de MP pour de l'aide, le forum est l’outil idéal

              Commentaire


              • #8
                Envoyé par lionel123 Voir le message
                Mais rassures moi...quand tu édites le module login dans un user par exemple il est bien visible en front du site?

                @+
                Si tu parle du module login virt oui il s affiche partout sauf la ou je veux.

                Voila je pense le code concerné trouvé dans index.php

                <?php if($this->params->get("show_login", 1) == 1) : ?>
                <a href="" id="login_btn" class="first"><?php echo ($userID == 0) ? JText::_('LOGIN') : JText::_('LOGOUT'); ?></a>
                <?php endif; ?>

                Commentaire


                • #9
                  Si tu parle du module login virt oui il s affiche partout sauf la ou je veux.
                  Donc c'est bien un souci de template!

                  Personnellement avec les outils de développement soit sur IE ou Firefox...je ciblerais ou modifier cela dans le template pour le faire apparaître.

                  Maintenant il te faut mettre les mains dans le cambouis cela demande un peu de connaissance mais c'est pas compliqué.

                  @+
                  SVP pas de MP pour de l'aide, le forum est l’outil idéal

                  Commentaire


                  • #10
                    Voila je pense le code concerné trouvé dans index.php
                    Non

                    C'est dans le dossier Template qui faut voir!

                    @+
                    SVP pas de MP pour de l'aide, le forum est l’outil idéal

                    Commentaire


                    • #11
                      J utilise effectivement firebug qui m aide beaucoup.

                      Comme tu as pu le voir sur l image de mon premier post j ai un onglet connexion et un onglet register.
                      Pour l'onglet register j ai pu modifier le lien et l envoyer vers celui de virt.
                      Enfaite le plus simple serai de me servir du module mod_login et de modifier le lien creer un compte et le renvoyer vers le formulaire virt cela resoudrai l ensemble de mes problemes car comme ca:

                      le clt peut ce s'enregistrer via le formulaire de virt et ce ce loguer via mod_login.

                      le lien generé par creer un compte est:
                      <a href="/index.php?option=com_user&amp;task=register">
                      Créer un compte</a>

                      Je ne le trouve pas dans index car doit etre généré par du php.

                      Et le remplacer par :
                      <a href="/index.php?option=com_virtuemart&amp;page=shop.regi stration&amp;Itemid=1">
                      Créer un compte</a>
                      Ou faire cette manip.

                      Voir image il s agit du mod_login
                      http://www.casimages.com/img.php?i=0...2534776931.jpg
                      Dernière édition par bozo à 03/11/2009, 14h35

                      Commentaire


                      • #12
                        Voici je pense le fichier a modifier. J ai deja changé quelque lien ; maintenant quand je suis loggé il me manque plus qu a faire apparaitre "votre compte".
                        Fichiers joints

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X