Bug VM 1.1.4 Attributs personnalisés

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Bug VM 1.1.4 Attributs personnalisés

    Pour info, petit bug dans VM 1.1.4, mais qui a déjà été détecté par l'équipe VM :
    les attributs personnalisés ne prennent plus les valeurs entrées !

    Pour régler ce petit bug :
    Fichier administrator\components\com_virtuemart\classes\ps _product_attribute.php
    Ligne 1016 remplacer
    Code PHP:
    $pagevar $field;
    $pagevar .= $d['prod_id'] ;
    $pagevar $encodefunc$pagevar ) ;
                
    if( 
    is_null($d[$pagevar]) || $d[$pagevar] == '' ) {
        
    $custom_attribute_given true ;

    par
    Code PHP:
    $pagevar str_replace" ""_"$field ) ;
    $pagevar .= $d['prod_id'] ;
    $pagevar $encodefunc$pagevar ) ;
                
    if( ! empty( 
    $d[$pagevar] ) ) {
       
    $custom_attribute_given true ;

    Plus d'infos sur http://dev.virtuemart.net/cb/issue/2750
    --
    Sylvain
    cadeau anniversaire - Idées cadeaux

  • #2
    Thk's D.J.

    a plus
    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
    http://virtuemart.fr

    Commentaire


    • #3
      Le pb pour moi venait plutôt de ce que les attributs n'étaient pas correctement chargés. N'ayant pas eu le temps de trouver la solution idéale j'ai trouvé la solution suivante qui fonctionne (l'ancien code est mis en commentaire):
      /*TC_rc - 18/1/2010 pour bug attribute list
      if( $custom_attribute_list ) {
      $fields = explode( ";", $custom_attribute_list ) ;

      $description = $d["description"] ;

      foreach( $fields as $field ) {
      $pagevar = str_replace( " ", "_", $field ) ;
      $pagevar .= $d['prod_id'] ;
      $pagevar = $encodefunc( $pagevar ) ;

      if( ! empty( $d[$pagevar] ) ) {
      $custom_attribute_given = true ;
      }
      if( $description != '' ) {
      $description .= "; " ;
      }
      $description .= $field . ":" ;
      $description .= (is_null($d[$pagevar]) || $d[$pagevar] == '') ? '' : $decodefunc( $d[$pagevar] ) ;

      }
      rtrim( $description ) ;
      $d["description"] = $description ;
      // END add for custom fields by denie van kleef


      }
      */

      if( $_POST['custom_attribute_fields'] ) {
      $fields = $_POST['custom_attribute_fields'];

      $description = $d["description"] ;

      foreach( $fields as $field ) {
      $pagevar = $encodefunc( $field ) ;
      $field = str_replace( $d['prod_id'], "", $field ) ;

      if( ! empty( $d[$pagevar] ) ) {
      $custom_attribute_given = true ;
      }
      if( $description != '' ) {
      $description .= "; " ;
      }
      $description .= $field . ":" ;
      $description .= (is_null($d[$pagevar]) || $d[$pagevar] == '') ? '' : $decodefunc( $d[$pagevar] ) ;

      }
      rtrim( $description ) ;
      $d["description"] = $description ;

      // END add for custom fields by denie van kleef
      }
      Thierry CHEN
      http://www.webologix.com création site internet
      http://www.php-web-service.net Développeur WEB
      http://www.joomla-development.eu Développement d'extensions Joomla

      Commentaire


      • #4
        Hello !

        J'ai pas tout compris, que veux-tu dire par "pas proprement chargés" ?

        ++
        --
        Sylvain
        cadeau anniversaire - Idées cadeaux

        Commentaire


        • #5
          Pardon j'aurais du dire "pas chargée" . La fontion:

          $advanced_attribute_list = $db->f( "attribute" ) ;//ligne 962 chez moi

          ne renvoit rien du tout, ce qui fait que $fields dans la boucle est vide.
          Thierry CHEN
          http://www.webologix.com création site internet
          http://www.php-web-service.net Développeur WEB
          http://www.joomla-development.eu Développement d'extensions Joomla

          Commentaire


          • #6
            J'ai mis ce correctif, il corrige bien la prise valeur, mais pas la verification des champs...
            Exemple:
            J'ai deux attributs personnalisées, le probléme est que quand un des deux attributs (champs) est rempli par le client l'autre n'est plus obligatoire, c'est à dire que si le client n'en rempli qu'un, il peut passer à l'étape suivante... ce qui me pose réellement probléme.

            Edit: j'ai créé un sujet ici: http://forum.joomla.fr/showthread.php?t=113286
            Dernière édition par darakk à 27/01/2010, 13h02
            Sobi =>

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X