Symbole EURO dans les commandes

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Symbole EURO dans les commandes

    Suite à une mise à jour de Virtuemart en 1.1.4 j'ai quelques bugs comme celui çi :
    Dans "Liste de commande " mais aussi dans le bon de commande le symbole euro est devenu " € " (ex : 26.10 €)
    Voir l'image jointe.

    Dans la boutique, en frontend, l'euro apparait normalement !

    Quelqu'un a une idée !???
    Fichiers joints
    JoomGroupe de Bordeaux
    ----------------------------------------------------

  • #2
    Même problème

    Si quelqu'un à une idée car j'ai le même problème...

    Commentaire


    • #3
      Je pense que le problème vient de la version de Joomla 1.015
      Puisque avec les sites avec J 1.5x a priori ça marche.

      Ce signe " € " - au lieu " € "dans le bon de commande
      d'où ça peut provenir ?

      Avez-vous une piste ?
      JoomGroupe de Bordeaux
      ----------------------------------------------------

      Commentaire


      • #4
        bonjour

        un probleme de codage de fichier...

        et tu n'as cela que dans le recap des commandes ?

        a plus
        sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
        http://virtuemart.fr

        Commentaire


        • #5
          Bonjour PAT,

          Oui effectivement, c'est dans le récap des bons de commande et bon de commande.
          Voir l'image dans mon 1er message çi-dessus.
          En frontend ça marche.
          Oui sûrement un problème de codage de fichier mais lequel...
          Dernière édition par celinem à 05/11/2009, 12h33
          JoomGroupe de Bordeaux
          ----------------------------------------------------

          Commentaire


          • #7
            Ah... je vais regarder ça de + près
            Merci
            JoomGroupe de Bordeaux
            ----------------------------------------------------

            Commentaire


            • #8
              le mode debug ne te donne pas d'infos ?
              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
              http://virtuemart.fr

              Commentaire


              • #9
                Le site est en production.
                En fait j'aimerai trouver le fichier dans Virtuemart correspondant au bon de commande qui me permettrait de corriger cet encodage...

                Le problème n'est pas au niveau Frontend mais dans l'administration de la boutique.
                Dernière édition par celinem à 05/11/2009, 12h54
                JoomGroupe de Bordeaux
                ----------------------------------------------------

                Commentaire


                • #10
                  Signe EURO dans le bon de commande

                  Effectivement c'est bien un problème d'encodage.
                  Mais dans le recap du bon de commande - uniquement dans l'administration de la boutique - quel est le fichier qui gère les symboles ?

                  Je le répète, le symbole € apparait bien en frontend de la boutique !
                  Fichiers joints
                  JoomGroupe de Bordeaux
                  ----------------------------------------------------

                  Commentaire


                  • #11
                    Un élément de réponse

                    Bonjour,

                    J'ai un élément de réponse après si quelqu'un de plus compétent peut résoudre ce problème.

                    J'ai isolé les deux fichiers qui pose le problème pour passer sa commande juste après le login (impossible de continuer, l'identification ne se fait pas) et celui qui bug l'affichage de l'euro (€) en back end pour la liste des commandes et l'impression des facturettes.

                    Ceci est valable pour les personnes qui ont :

                    Joomla 1.0.15, qui avait virtuemart 1.1.2 et qui utilise le patch 1.1.2 vers 1.1.4 du site officiel de virtuemart.

                    Patch-VirtueMart-1.1.2-1.1.4\administrator\components\com_virtuemart\clas ses\currency\class_currency_display.php
                    Patch-VirtueMart-1.1.2-1.1.4\components\com_virtuemart\themes\default\tem plates\common\login_form.tpl.php

                    Si on ne copie pas ces fichiers les site fonctionne parfaitement bien, pas de bug ni de problème de login.

                    Commentaire


                    • #12
                      Signe EURO dans le bon de commande

                      C'est SUPER !!!!!

                      En fait j'ai remplacé les fichiers concernés par ceux de la version de virtuemart 1.1.2... et ça marche

                      Merci PlanetsLeds
                      JoomGroupe de Bordeaux
                      ----------------------------------------------------

                      Commentaire


                      • #13
                        Bonjour,

                        Je rencontre également ce problème, mais j'ajoute que le symbole euro est remplacé par " € " également dans le récapitulatif de la commande que peut visualiser le client.

                        Est-ce que tu as pu régler le problème Celinem ?

                        Edit : quel abruti, je n'avais pas vu la seconde page du sujet... Donc je vais aussi voir dans ce sens. Merci.

                        Commentaire


                        • #14
                          Bonjour Ialdabaoth

                          Dans Virtuemart / Boutique/ Editer la boutique/
                          Symbole monétaire (mettre) € (plutôt que le symbole €)

                          A+
                          JoomGroupe de Bordeaux
                          ----------------------------------------------------

                          Commentaire


                          • #15
                            Envoyé par celinem Voir le message
                            Bonjour Ialdabaoth

                            Dans Virtuemart / Boutique/ Editer la boutique/
                            Symbole monétaire (mettre) € (plutôt que le symbole €)

                            A+
                            C'est déjà le cas, mais rien n'y fait. Pourtant j'ai regardé dans le fichier class_currency_display.php, et il présente les corrections censées régler ce bug, d'après le portail des développeurs de Virtuemart. État du bug : Fixed in Version: VirtueMart 1.1.4 .
                            J'ai bien cette version, mais toujours le bug...

                            Merci quand même .

                            Edit : j'ai trouvé !
                            à la ligne 132 du fichier incriminé, j'ai remplacé la ligne 132 :
                            Code:
                            case 'EUR': $this->symbol='€';break;
                            par
                            Code:
                            case 'EUR': $this->symbol='& #128;';break;
                            sans espace entre "&" et "#" et maintenant j'ai bien le symbole € partout .
                            Dernière édition par Ialdabaoth à 11/02/2010, 16h43

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X