Joomladay francophone 2018 à Paris 18 et 19 mai

Images Produits VirtueMart

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Images Produits VirtueMart

    Bonjour,

    Je travaille actuellement un site marchand en Local avec Joomla 1.5.15 et VirtueMArt 1.1.3

    Voila le problème, sans aucunes modifications spéciales les photos du scroller VirtueMart et du module "Latest Product" se s'affichent plus (j'ai testé sur Firefox et Explorer). Par contre les images des catégories s'affichent et lorsque que je vais sur une fiche produit l'image miniature s'affiche également et idem lorsque je clique sur "agrandir l'image".

    J'ai consulté pas mal de sujet en ligne à propos de ce problème mais je ne trouve pas de solution

    Une personne parlait de modifier le fichier ps_main.php
    se trouvant: joomla\administrator\components\com_virtuemart\cla sses

    Mais le code ne correspondait pas avec ce qu'il disait de modifier...

    J'éspère que quelqu'un pourra me venir en aide surtout que comme je vous l'ai signalé le problème est apparu du jour au lendemain !

    Merci d'avance

  • #2
    j'ai le même problème ... message posté vendredi dernier ...
    Le site que je suis en train de construire :

    www.aluberlu.com

    Joomla 1.5 / Virtuemart 1.1.4

    Commentaire


    • #3
      Voila l'aide que j'avais trouver mais que je ne peux utiliser je ne trouve pas les ligne dont l'utilisateur parle...

      Bonsoir,

      J'ai trouvé la solution a mon problème !

      éditer le fichier ci-dessous:
      /administrator /components /com_virtuemart /classes/PS_MAIN.PHP

      rechercher :

      $d["image_commands"][] = "\$ret = @move_uploaded_file(\"".addslashes(realpath($temp_ file))."\", \"".$path.$to_file."\");
      if( \$ret === false ) {
      \$ret = copy(\"".addslashes(realpath($temp_file))."\", \"".$path.$to_file."\");
      }";

      et remplacer par :

      $d["image_commands"][] = "\$ret = @move_uploaded_file(\"".addslashes(realpath($temp_ file))."\", \"".$path.$to_file."\");
      if( \$ret === false ) {
      \$ret = copy(\"".addslashes(realpath($temp_file))."\", \"".$path.$to_file."\");
      }
      chmod(\"".$path.$to_file."\",0644)
      ";


      Cette modif permet d'insérer le CHMOD pour la permission !

      Cordialement.

      j'ai trouver sa ici http://forum.joomla.fr/showthread.ph...ighlight=chmod

      Commentaire


      • #4
        message deplace dans le bon forum : questions generales --- e-commerce
        sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
        http://virtuemart.fr

        Commentaire


        • #5
          Bonsoir,
          j'ai le problème aussi. Les images des catégories s'affichent bien, par contre les vignettes produit non.C'est la même chose dans le scroller...pas de vignette. Si l'on clique sur la fiche produit plus de soucis les images apparaissent bien...et on peut également les agrandir.

          Quelqu'un aurait il une petite solution à me proposer ?
          merci d'avance...
          nicolas

          Commentaire


          • #6
            allez on est trois sur le problème ... PATSXM971 s'iiiiiiiiiiiiiiiiiiiiiiiiil te plait aide nous je t'ai vu répondre dans tellement de message
            Le site que je suis en train de construire :

            www.aluberlu.com

            Joomla 1.5 / Virtuemart 1.1.4

            Commentaire


            • #7
              problème résolu....
              Bizarrement je me suis aperçu qu'en mettant le site hors ligne dans Virtuemart et non pas en configuration générale Joomla puis en le réactivant les images sont apparues ... comme par enchantement ....suis donc enchanté...Si ça peut vous aider....
              nicolas

              Commentaire


              • #8
                Bonsoir

                Bizarrement je me suis aperçu qu'en mettant le site hors ligne dans Virtuemart
                Ah oui comme ça simplement!?!?!?

                Franchement des fois VM nous réserve bien des surprises.

                De même pour moi le même souci, mais j'avais pas le tps de m'en occuper.

                Merci pour le retour d'info.

                @+
                SVP pas de MP pour de l'aide, le forum est l’outil idéal

                Commentaire


                • #9
                  Cela ne change rien pour moi sa me désespère !!
                  Tu parles bien de cette option dans VirtueMart:

                  "Boutique Hors Service? Si la case est cochée, la boutique affiche le message hors service."

                  Commentaire


                  • #10
                    oui c'est bien celà.
                    Verifie le chemin d'accès aux fichiers images qui doivent bien se trouver dans le dossier stories car on ne peut pas modifier ces parametres sous virtuemart...

                    Commentaire


                    • #11
                      Envoyé par nicolas80 Voir le message
                      oui c'est bien celà.
                      Verifie le chemin d'accès aux fichiers images qui doivent bien se trouver dans le dossier stories car on ne peut pas modifier ces parametres sous virtuemart...
                      Ou est ce que je vérifie sa ??

                      Comme je l'ai dis le problème est vraiment apparu du jour au lendemain sans modification des paramètres et avant que ce problème arrive je sélectionnais également la photo miniature, celle-ci n'était pas générée automatiquement.

                      Commentaire


                      • #12
                        est vraiment apparu du jour au lendemain sans modification des paramètres et avant que ce problème arrive je sélectionnais également la photo miniature
                        Alors peut être une mise à jour serveur qui a fait coincer la mécanique de ton site.

                        Regardes du côté des droits d'attributions pour voir.

                        C'est juste une piste.

                        @+
                        SVP pas de MP pour de l'aide, le forum est l’outil idéal

                        Commentaire


                        • #13
                          Je travail en local

                          Commentaire


                          • #14
                            Je travail en local
                            OK et avec un redemarrage de ton serveur local?
                            Ou bien faire un essai avec un autre serveur local.

                            @+
                            SVP pas de MP pour de l'aide, le forum est l’outil idéal

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X