attributs personnalisés ne se retrouve pas dans le panier:

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • attributs personnalisés ne se retrouve pas dans le panier:

    Arghhhhh !!! j'en ai marrrrre..

    je revien a l'attaque, je n'arrive toujour pas a comprendre pourquoi lorsque je veus disposer d'attribue personnalisés, ceux ci ne veulent pas etre transmis au panier... tous le reste fonctionne, mais pas ca. ou bien aleatoirement..

    quelqu'un pourrait il me donner une piste???

    il n'y a pas de reecriture d'url, et les produit sont bien ajoutés au panier, l'attibue aussi, mais pas ce qui est ajouté dans le formulaire..
    Dernière édition par strouve à 25/02/2010, 20h04

  • #2
    Bonsoir

    cdw7 nous a trouvé une astuce sur ce problème la semaine dernière l'as tu vu?

    @+
    SVP pas de MP pour de l'aide, le forum est l’outil idéal

    Commentaire


    • #3
      bah non, j'ai chercher dans les astcuces, mais pas trouvé... y aurait il un lien???

      Commentaire


      • #4
        En faite j'y repense cdw7 avait trouvé ou modifier le fichier mais il devait nous donner l'astuce car il était a la boure sur son projet.

        Voici le lien de son topic
        http://forum.joomla.fr/showthread.php?t=115028&page=2

        @+
        SVP pas de MP pour de l'aide, le forum est l’outil idéal

        Commentaire


        • #5
          C'est pas ça la solution ?

          http://dev.virtuemart.net/cb/issue/2750

          J'ai eu le même PB et c'est résolu
          Faites du bruit, JOOMLA is the best ...
          Quel pieds ce truc, j'en découvre tous les jours ...

          Commentaire


          • #6
            Bonjour

            Sympa il semble que oui c'est une bonne info merci.

            @+
            SVP pas de MP pour de l'aide, le forum est l’outil idéal

            Commentaire


            • #7
              Ah!!!!!!!! oh!!!

              je teste cela immediatement,,, pour plus de certitude, il suffit de prendre les modif dans la premiere partie...

              le reste etant des commentaire n'est ce pas??

              Commentaire


              • #8
                file ps_product_attribute.php, lines 1002 - 1007(cherches quand même si ce sont les bons numéros de ligne)

                Tu met ça :
                Code:
                $pagevar = str_replace( " ", "_", $field ) ;
                $pagevar .= $d['prod_id'] ;
                $pagevar = $encodefunc( $pagevar ) ;
                            
                if( ! empty( $d[$pagevar] ) ) {
                   $custom_attribute_given = true ;
                }
                à la place de ça :
                Code:
                $pagevar = $field;
                $pagevar .= $d['prod_id'] ;
                $pagevar = $encodefunc( $pagevar ) ;
                            
                if( is_null($d[$pagevar]) || $d[$pagevar] == '' ) {
                    $custom_attribute_given = true ;
                }
                Faites du bruit, JOOMLA is the best ...
                Quel pieds ce truc, j'en découvre tous les jours ...

                Commentaire


                • #9
                  Haie !!!

                  désolé, ca ne marche pas.

                  j'ai essayé la petite modif, mais pour le coup c'est encore pire puisque le produit n'est pas ajouté du tout.
                  je suis allé sur le lien et j'ai essayé la modif de kmchen du 18 1 2010, la c'est une catastrophe, la boutique est completement en vrac.

                  Retour aux origines. mon produit dispose de plusieurs attribut standart et de deux attributs personnalisé, le premier ou il faut remplir l'info et le deuxieme qui n'est la que pour que ca fonctionne.

                  et ca marche!!! mais pas idéal... et je ne peus pas ajouter plusieurs attribut personnalisés..

                  si quelqu'un trouve une solution....

                  un jour peut etre ou faut il attendre la version 1.1.5 de virtuemart..

                  Commentaire


                  • #10
                    Je travaille sur un boutique 1.1.4 et ça marche, donc c'est étonnant ...
                    Ta boutique est monolingue ?
                    Faites du bruit, JOOMLA is the best ...
                    Quel pieds ce truc, j'en découvre tous les jours ...

                    Commentaire


                    • #11
                      effectivement, je suis sous joomla 1.5 et virtuemart 1.1.4 sans multilingue mais avec un systeme affilition et gw coupon installé mais qui marche pas...

                      c'est peut etre cela!!!!

                      Commentaire


                      • #12
                        Je ne pense pas que cela influence les attributs.

                        Mais par contre je ne comprends pas trop, cela a été immédiat pour mon site ...
                        Faites du bruit, JOOMLA is the best ...
                        Quel pieds ce truc, j'en découvre tous les jours ...

                        Commentaire


                        • #13
                          la lalalallalalalal !!!!

                          milles merci, ca fonctionne bien, je me suis planté sur le fichier ps ttribute, il a dut y avoir des modifs auparavant sur ce fichier, je l'ai rechopper sur une version propre de virtuemart puis effectuer les modifs a la ligne 1016 à 1022.. les attributs sont bien conserver dans le panier et ca roule...

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X