impossible d'avoir la boutique autrement qu'en régistered...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • impossible d'avoir la boutique autrement qu'en régistered...

    J'ai un autre problème maintenant : impossible d'entrer dans la boutique sans se loguer...

    ça franchement je ne comprends pas comment c'est possible ?
    (tout le temps que j'y ai travaillé, j'avais mis en "spécial" et maintenant que je veux ouvrir... impossible d'accéder en simple visiteur... Il faut se loguer obligatoirement... ce n'est plus "spécial", c'est "régistered"... mais ça ne fait pas du tout mon affaire...)

    côté menu en tout cas, c'est bon... Alors, ça non plus, je ne comprends pas...

    merci de m'aider encore...
    Phil

  • #2
    Bonjour,

    nouveau probleme, nouveau topic

    il y a aussi l'option "public" ; ca devrait decoincer... n'est-elle pas accessible ?

    bonne continuation
    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
    http://virtuemart.fr

    Commentaire


    • #3
      c'est juste, j'aurais du y penser...
      Eh bien en fait tous les menus et modules en rapport sont sur public
      alors la configuration de virtuemart, je vois bien ceci :

      Mode inscription utilisateur
      Afficher la case à cocher "se souvenir de moi?"
      Joomla!: Inscription des utilisateurs autorisée ? Oui [Mettre à jour]
      Joomla!: Utiliser l'activation des comptes? Oui [Mettre à jour]

      dans "mode inscription utilisateur", il y a 4 possibilités, j'ai essayé les 4 mais ça change rien.

      et dans "produits", "catégorie de produits" etc, je ne vois pas non plus de possibilité...

      c'est vrai que c'est un nouveau mystère, ça pour moi !

      Commentaire


      • #4
        il vaut mieux mettre utiliser l'activation des comptes sur : non, a moins que tel est votre desir...
        sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
        http://virtuemart.fr

        Commentaire


        • #5
          merci
          mais ça ne règle pas le problème, malheureusement...

          Commentaire


          • #6
            non, et ce n'etait pas cense le faire... non plus. C'etait juste une precision supplementaire

            avez-vous consulte dans les astuces, a propos du login et des utilisateurs, et autres sur les boutiques privees (voir les sommaires) ?
            http://forum.joomla.fr/showthread.ph...-de-l-instal-a

            peut-etre des pistes....
            sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
            http://virtuemart.fr

            Commentaire


            • #7
              et vous n'avez pas non plus touche aux modules d'autorisation... ?
              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
              http://virtuemart.fr

              Commentaire


              • #8
                Si justement !
                Allez, je vais vous faire rire ! Voici comment j'ai réglé le problème :
                J'ai réinstallé un site vierge avec une nouvelle boutique... Je suis allé dans les modules là... et j'ai remis chez moi comme c'était par défaut sur le nouveau site et comme ça ça marche ! (cela dit, c'était quand même le moyen le plus rapide... au fond, ça ne m'a pris qu'une demi-heure...)

                (ah j'espère que si un jour vous faites un hit parade des techniciens les plus nuls qui soit... vous penserez à moi pour la palme toute catégorie !)

                merci pour tous vos bons conseils en tout cas !

                Commentaire


                • #9
                  Cela dit, je constate deux choses :
                  1. sur la nouvelle boutique, donc par défaut, il y a un module supplémentaire que je n'ai pas sur la mienne : "Affilate" si je clique dessus, il est écrit dans la description "administrate the affiliates on your store."... j'ai pas ça, moi... Je ne sais pas si c'est grave ou pas...
                  2. en cliquant sur "liste des fonctions" en rapport à "product", je vois "insertDownloadsForProduct" qui est décoché en "store admin"... Ce ne serait pas là qu'il faut régler l'autre problème que j'ai à savoir que ça n'envoie pas le code de téléchargement (de la version jpg) lorsque le client achète la version papier (expédiable) ?

                  (Parce que je ne vous ai pas dit le plus drôle : je ne sais pas tester ma boutique ! si je veux payer avec mon compte paypal, j'ai un message qui dit que le client veut se connecter avec le compte du vendeur (évidemment, c'est moi !) mais même si je veux utiliser la carte de crédit de ma mère (qui est lié à mon compte paypal) j'ai un message similaire... bref, je fais mes tests par rapport au téléchargement, en allant dans les commandes et en changeant manuellement de pending en confirmed manuellement je coche "envoyer un mail au client", etc... Mais j'attends le premier achat pour vérifier que cela se fait bien automatiquement comme ça devrait... oui, oui je sais : la palme !)

                  Commentaire


                  • #10
                    Bonjour,

                    content que vous ayez pallie a votre probleme.

                    bonne continuation
                    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                    http://virtuemart.fr

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X