SIPS et Virtuemart 1.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • SIPS et Virtuemart 1.5

    Bonjour,

    J'ai suivi le tuto pour installer ATOS sur Virtuemart.

    Lorsque je créé une nouvelle méthode de paiement comme indiqué, je choisis ps_sips et Formulaire HTML, et à l'enregistrement, j'ai le message d'erreur suivant :

    "Erreur: La classe de paiement sélectionnée ne peut être instanciée car elle n'existe pas."

    Et donc, la méthode de paiement ne s'enregistre pas, ce qui fait que je suis bloqué à cette étape.

    Please... I need some help !
    Stéphane

  • #2
    Je précise que il s'agit de Virtuemart 1.5 et que le tuto parle de virtuemart 1.1.... peut etre y a t'il quelque chose à changer dans le tuto pour que cela fonctionne avec VM1.5 ?
    Stéphane

    Commentaire


    • #3
      Bonjour

      VirtueMart 1.5 est en version alpha. Et je n'ai pas encore réecrit les plugins de paiement.
      Es tu sur qu'il ss'agit de la version 1.5 de virtuemart.
      alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

      Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

      Commentaire


      • #4
        Bonjour,

        Oups.... Effectivement, faut que j'ouvre les yeux, c'est VM 1.1.5

        Toujours est-il que le problème reste le même, mais du coup les causes doivent être autres.

        Pour aller un peu plus loin, la boutique en ligne qui est en train d'être mise en place sous Joomla1.5+VM1.1.5 est un refonte.
        J'avais à la base développée le site en ASP et PHP, le tout sur un server Windows 2008.

        Là, le site est donc refait avec Joomla et VM, et l'install est faite sur le même server et tourne pour le moment sous un sous-domaine avant la mise en ligne finale.
        Le paiement en ligne Sogenactif tourne très bien sur l'ancien site, mais donc ce problème sur celui sur Joomla.

        Des idées ?
        Stéphane

        Commentaire


        • #5
          Alors.... Un peu de nouveau....

          En fait, ayant suivi le tuto, j'ai remarqué que les fichiers copiés dans com_virtuemart/classes/payment.... etc étaient affichés en vert sur windows 2008, j'ai donc fait propriété dessus et décoché "chiffrer le fichier...". Ils sont donc maintenant affichés en noir comme tous les autres fichiers.

          Du coup, quand j'essaye de créer le nouveau mode de paiement, je n'ai plus :
          "Erreur: La classe de paiement sélectionnée ne peut être instanciée car elle n'existe pas."

          Par contre, je clique sur enregistrer, le formulaire semble envoyé, mais je n'ai qu'une page blanche. Quand je reviens en arrière, la methode de paiement n'a pas été créée....
          Stéphane

          Commentaire


          • #6
            Bonjour,

            C'est la première fois que j'entends parler de cette erreur.
            Tu trouves "ps_sips" dans la liste déroulante, puis quand tu sauvegardes, il affiche le message d'erreur? C'est ca qui se passe?
            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

            Commentaire


            • #7
              Ben en fait j'ai réussi à régler le problème.

              Cela était dû à l'option "chiffrer le contenu" dans les propriétés des différents fichiers à copier dans Joomla, j'ai donc retiré cela sur l'ensemble des fichiers, et ça fonctionne.

              Seul chose, maintenant dans la suite du tuto, il me dit qu'il n'arrive pas à écrire dans pathfile.... alors que le répertoire dans lequel il se trouve est bien configuré au niveau des droits....

              Ensuite, sur la partie site, voila le message obtenu lors de l'appel du paiement :
              Probléme de configuration de la méthode de paiement.
              Le fichier éxecutable nommé 'request' n'a pas été trouvé.
              - Vérifier que le chemin spécifié lors de la configuration de la méthode de paiement est correcte.
              - Vérifier que vous avez copié le fichier 'request' dans le bon répertoire.
              - Vérifier les droit d'accés du fichier 'request'.
              Chemin que vous avez configuré pour l'éxecutable: /CGI-BIN/
              Fichier executable appelé: Le fichier n'existe pas
              Accès de 0

              Pourtant le répertoire est bon et le fichier bien dedans... Des idées ?

              Je creuse encore...
              Dernière édition par figou à 01/10/2010, 10h56
              Stéphane

              Commentaire


              • #8
                Bonjour,

                Fichier executable appelé: Le fichier n'existe pas
                Accès de 0
                Il faut vérifier les chemins que tu as mis. Notamment que ceux sont bien des chemins ABSOLU.
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  C'est fait, avec un chemin absolu (tu veux bien dire un chemin de type c:\elysnet.... ?), j'ai l'erreur suivante :

                  Erreur lors de l'appel de l'éxecutable 'request'.
                  Message d'erreur: Invalid Keyword in parameter (elysnet)

                  le keyword elysnet étant une partie du path indiqué (c:\elysnet....).

                  Any idea ?
                  Stéphane

                  Commentaire


                  • #10
                    Bon on arrive vers des erreurs déjà plus courantes

                    Dans la configuration de la méthode de paiement il y a une paramètre "debug", tu peux le mettre à on. Fais moi un copier / coller des infos qui vont s'afficher (utilise le certificat de test)
                    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                    Commentaire


                    • #11
                      Bon alors.... Je crois que j'ai avancé un peu, maintenant il semble bien trouvé request mais il me donne le message d'erreur suivant :

                      Erreur lors de l'appel de l'éxecutable 'request'.
                      Message d'erreur: Invalid Keyword in parameter (page=checkout.sips_response)

                      ...?
                      Stéphane

                      Commentaire


                      • #12
                        Bonjour,

                        en fait tu es sur du windows qui est très franchement pratiquement pas utilisé. Est ce que tu peux me mettre les infos de debug pour que je comprenne mieux ce qui est envoyé au cryptage.
                        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                        Commentaire


                        • #13
                          Voila, c'est fait, voici le message d'erreur :

                          merchant_id=014295303911111 merchant_country=fr amount=16645 currency_code=978 pathfile=sips-param/pathfile transaction_id=260896 normal_return_url=http://url-du-site/index.php?page=checkout.sips_response&ItemId=1&opt ion=com_virtuemart cancel_return_url=http://url-du-site/index.php?page=checkout.sips_response&ItemId=1&opt ion=com_virtuemart automatic_response_url=http://url-du-site/administrator/components/com_virtuemart/html/checkout.sips_autoresponse.php language=fr merchant_language=fr payment_means=CB,1,VISA,1,MASTERCARD,1 header_flag=yes capture_day=0 capture_mode=AUTHOR_CAPTURE block_align=left block_order= customer_id=63 customer_email=stephane_h92@live.fr customer_ip_address=90.35.108.188 return_context=1 order_id=16Erreur lors de l'appel de l'éxecutable 'request'.
                          Message d'erreur: Invalid Keyword in parameter (page=checkout.sips_response)

                          J'ai pris la liberté de changer l'adresse de site par "url-du-site" dans ce copier/coller par soucis de confidentialité mais c'est bien l'url du site (le sous domaine en fait) qui apparaissait dans le message d'erreur.
                          Stéphane

                          Commentaire


                          • #14
                            No idea ?
                            Stéphane

                            Commentaire


                            • #15
                              Bonjour,

                              Essaye de remplacer les 3 lignes suivantes
                              Code PHP:
                              $parm.=" normal_return_url="SECUREURL."index.php?page=checkout.sips_response&ItemId=".$Itemid."&option=".$option;
                              $parm.=" cancel_return_url=".SECUREURL."index.php?page=checkout.sips_response&ItemId=".$Itemid."&option=".$option;
                              $parm.=" automatic_response_url=".SECUREURL."administrator/components/com_virtuemart/html/checkout.sips_autoresponse.php"
                              par
                              Code PHP:
                              $parm.=" normal_return_url=".$sips->os_info['quote']. SECUREURL."index.php?page=checkout.sips_response&ItemId=".$Itemid."&option=".$option.$sips->os_info['quote'];
                              $parm.=" cancel_return_url=".$sips->os_info['quote']. SECUREURL."index.php?page=checkout.sips_response&ItemId=".$Itemid."&option=".$option.$sips->os_info['quote'];
                              $parm.=" automatic_response_url=".$sips->os_info['quote'].SECUREURL."administrator/components/com_virtuemart/html/checkout.sips_autoresponse.php".$sips->os_info['quote']; 

                              Comme je n'ai pas de serveur windows, je ne sais pas du tout si c'est ca le problème, mais essaye.
                              alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                              Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X