Problème CMCIC Virtuemart Alatak pas de bouton

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème CMCIC Virtuemart Alatak pas de bouton

    Bonjour,
    Site sous Joomla 1.5.15, Virtuemart 1.4, patch de paiement CMCIC (cmcic_V30_J15_VM11_v2.3) téléchargé sur le site d'Alatak.

    Tout d'abord merci à Alatak pour son tutoriel.
    J'ai suivi à la lettre le tutoriel Alatak

    J'ai pourtant plusieurs problèmes :
    1. Lorsque j'effectue une commande et que j'arrive à la fin, au lieu du bouton CMCIC pour payer j'ai simplement en dessous de merci de votre commande le texte : https://ssl.paiement.cic-banques.fr/test/paiement.cgi sans aucun lien et pas de bouton. Pourtant quand je vais dans la commande en elle même j'ai bien le bouton CMCIC qui me redirige sur le serveur pour payer. j'ai bien mis le codes suivant :
    <?php require_once(PAGEPATH."checkout.cmcic_cc_form.php" ); ?>
    dans Informations de paiement supplémentaire.

    2. Une fois donc que je vais sur le serveur test de CIC pour payer ma commande, là tout marche bien. je choisis une carte test, le test passe ok (voir piece jointe) et je retourne sur mon site ma commande n'est pas mise à jour (toujours en cours) et j'ai toujours le lien pour payer !

    3. Je ne reçois pas de mail ni du coté admin ni du coté client de la part du CIC, dans les informations de debug voir piece jointe, le champs mail est d'ailleurs vide (voir piece jointe).

    Merci de votre aide
    Fichiers joints

  • #2
    Bon en fait le problème 1 s'est réglé tout seul, j'avais modifié le fichier checkout.thankyou.tpl.php j'ai remis l'original et ça marche bien, dès la commande finalisée je suis bien redirigé sur le serveur de test de CMCIC.
    Le problème 3 aussi je reçois bien les mails de confirmation de la banque

    Par contre problème 2 toujours d'actualité, le statut de commande n'est pas changé et j'ai toujours le lien pour payer dans les détails de la commande. au retour de la banque j'ai un message succès mais je ne suis pas redirigé sur ma commande

    Commentaire


    • #3
      bonjour,

      [QUOTEPar contre problème 2 toujours d'actualité, le statut de commande n'est pas changé et j'ai toujours le lien pour payer dans les détails de la commande. au retour de la banque j'ai un message succès mais je ne suis pas redirigé sur ma commandeQUOTE]

      Il faut que l'url de retour soit configurée chez le CIC.
      http://tonsite.com/cmcic_cgi2.php
      alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

      Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

      Commentaire


      • #4
        Bonjour alatak,
        Tout d'abord merci de ta réponse, je sais que d'autres posts du même genre ont été postés. Pourtant le CIC me dit bien par mail que ma demande a été prise en compte, le problème est toujours présent. comment vérifier qu'ils ont bien pris en compte l'url cgi2 ?
        merci encre pour tout le travail d'alatak

        PS : pour info les problèmes 1 et 3 arrivent lorsque l'option debug est cochée (pas de mail de confirmation de cic et pas de lien direct)

        Commentaire


        • #5
          Une fois le paiement effectué si je regarde le lien quand on clique sur "Retour sur le site de la société XXXX" j'ai http://www.monsite.com/index.php?pag...mart&retour=ok est ce que c'est normal ? est ce que ça devrait être le CGI2 à la place ?
          Merci de ton aide

          Commentaire


          • #6
            Bonjour,

            Non, le lien CGI2, est un appel de serveur à serveur. Tu ne le vois pas, mais c'est cet appel qui met à jour l'état de la commande.
            Pour savoir si CIC a bien configuré cette URL, va dans tes logs, et suite à un paiement, vérifie si l'appel est fait ou non.
            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

            Commentaire


            • #7
              Bonjour Alatak,
              Merci de prendre le temps de me répondre.
              1. il faut croire que ça leur prend du temps de mettre à jour l'adresse URL CGI2
              2. Qu'est ce que le mail de surveillance quand le message de CIC dis "email de surveillance non renseigné" ?
              3. Tu me dis de regarder dans les logs si l'appel a été fait, tu veux dire les logs de joomla car dans ce cas il n'y a rien à part un index.html ???
              4. de retour du CIC sur mon site j'ai un message me disant que le paiement est un succès et un lien "cliquez ici pour les détails de votre commande" sauf que le lien dirige sur la liste de toutes mes commandes et pas sur celle que je viens d'effectuer. une idée ???
              Encore merci de ton aide
              Matthieu

              Commentaire


              • #8
                Bonjour
                1. il faut croire que ça leur prend du temps de mettre à jour l'adresse URL CGI2
                Normalement c'est instantanné, mais il m'est arrivé que cela prenne plusieurs jours, malgre un mail qui me disait ue c'etait fait.

                2. Qu'est ce que le mail de surveillance quand le message de CIC dis "email de surveillance non renseigné" ?
                àh ben celui la je ne le connais pas.

                3. Tu me dis de regarder dans les logs si l'appel a été fait, tu veux dire les logs de joomla car dans ce cas il n'y a rien à part un index.html ???
                Les logs apache. dedans tu vois toutes les appels à ton site. et donc celui du CIC etant un appel de serveur à serveur, tu peux verifier si le CGI2 est appelé. Si il n'est pas apelé alors le CGi2 n'a pas ete configuré chez eux.

                Attention, si tu as un fichier htpassword, il bloque le CGI2.

                4. de retour du CIC sur mon site j'ai un message me disant que le paiement est un succès et un lien "cliquez ici pour les détails de votre commande" sauf que le lien dirige sur la liste de toutes mes commandes et pas sur celle que je viens d'effectuer. une idée ???
                Je vais regarder.
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  Bonjour Alatak,
                  3. Je ne sais pas où regarder les logs apache, je suis sous ovh.
                  4. voici le lien affiché pour "cliquez ici pour voir les détails de votre commande" "http://www.monsite.com?page=account.order_details&order_i d=" le order_id est vide ???

                  Autre remarque lorsque je tape dans mon navigateur www.monsite.com/cmcic_cgi2.php soiit l'URL que je leur ai donné j'ai le texte ci dessous, est ce normal ?
                  Warning: Cannot modify header information - headers already sent by (output started at /homez.318/tikipam/www/administrator/components/com_virtuemart/classes/mainframe.class.php:945) in /homez.318/tikipam/www/administrator/components/com_virtuemart/classes/ps_session.php on line 68
                  version=2 cdr=1 0838286*****3.0***************

                  message au moment du paiement
                  Cliquez sur l'image pour l'afficher en taille normale

Nom : paiementcic3.jpg 
Affichages : 1 
Taille : 32,8 Ko 
ID : 1795133

                  Merci encore de ton aide
                  Dernière édition par matthieueyenet à 05/10/2010, 14h26

                  Commentaire


                  • #10
                    Bonjour Alatak,
                    Cooooool, Le problème venait du CIC ils m'avaient fourni le code société de la VPC et non celui de la VAD, là ça marche nickel, le statut de commande est bien changé.

                    Le seul pb reste dans le retour avec le lien affiché pour "cliquez ici pour voir les détails de votre commande" "http://www.monsite.com?page=account.order_details&order_i d=" le order_id est vide ???

                    Merci de ton aide

                    Commentaire


                    • #11
                      Bonjour

                      Coool, bonne nouvelle

                      e seul pb reste dans le retour avec le lien affiché pour "cliquez ici pour voir les détails de votre commande" "http://www.monsite.com?page=account.order_details&order_i d=" le order_id est vide ???
                      pas eu le temps de regarder. je le fais plus tard
                      alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                      Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                      Commentaire


                      • #12
                        Et encore une petite question si je puis me permettre
                        - Au moment de la commande l'acheteur reçoit un mail de Virtuemart comme quoi sa commande est en cours
                        - Il paye, il reçoit un mail de la banque comme quoi il a payé
                        - la commande est mise à jour au statut payé dans virtuemart mais pourtant l'acheteur ne reçoit pas de mail comme quoi le statut de sa commande a changé ? que faut il faire pour que ce soit automatique ?
                        merci encore

                        Commentaire


                        • #13
                          petit bump

                          Commentaire


                          • #14
                            Bonjour,

                            dans le fichier administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php

                            cherce es lignes avec
                            Code PHP:
                              $d['notify_customer'] = "N"
                              
                            $d['include_comment'] = "Y"
                            change par

                            Code PHP:
                              $d['notify_customer'] = "Y"
                               
                            $d['include_comment'] = "Y"
                            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                            Commentaire


                            • #15
                              Bonjour ALATAK,

                              merci pour le tuto CMCIC trés bien fait. Malheureusement j'ai quand même un problème, lorsque je clic sur le bouton "confirmer la commande" après avoir choisi "carte de crédit" comme méthode de paiement, j'arrive sur la page qui me confirme que ma commande à été enregistré et au milieu de cette page j'ai : "https://paiement.creditmutuel.fr/test/paiement.cgipaiement.cgi".
                              Aucune trace dans les logs du serveur de paiement du Crédit Mutuel.

                              Une petite idée ?

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X