Problème encodage sur VirtueMart

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème encodage sur VirtueMart

    Bonjour,

    Je fait suite au message laissé par LeMalouin posté le 20/11/2009 à 11h20, à la page 37.

    n'ayant pas trouvé de solution depuis hier et commençant à perdre patience, je vous explique mon problème.

    Sous Joomla 1.5 et VirtueMart 1.1 je me retrouve; seulement dans la partie VirtueMart(que ce soit en admin ou sur le site à proprement parlé)avec des problèmes d'encodage : par exemple "Catégorie de produit" est écrit(sur admin ou site) "catégorie de produit".

    Je travaille en local sous Wamp.

    Le problème est identique à tous les navigateurs et je ne rencontre pas ce problème dans la partie Joomla.

    Ma base de Données est pour l'interclassement en utf8_general_ci.

    Je n'arrive pas à définir la source de la difficulté.

    J'espère avoir été assez clair dans mes explications et espère que vous pourrez m'aider.

    Je vous souhaite une bonne continuation.

    Amicalement.
    Dernière édition par ludodev à 26/10/2010, 16h42

  • #2
    Bonjour,

    pourtant le probleme a ete evoque et resolu plusieurs fois...

    pour simplifier les choses, les fichiers corriges, normalement, de ces problemes d'encodage sont telechargeables ici :
    http://joomlacode.org/gf/project/fr_virtuemart/frs/

    le lien est egalement donne dans le premier post du topic astuces
    http://forum.joomla.fr/showthread.ph...nstal-a-...%29

    bonne continuation
    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
    http://virtuemart.fr

    Commentaire


    • #3
      Merci PATSXM971,

      Je n'ai pas su résoudre ce problème avec les posts que j'ai lu traitant de ce sujet, je n'ai pas su m'en dépatouiller, l'avantage c'est qu'en mettant les mains dans le moteur ça nous apprend et c'est ça qui est bon.

      Je vais télécharger ce fichier en espérant que ça résolve le problème, je te remercie pour ta réponse.

      Cordialement.

      Commentaire


      • #4
        Le correctif a effectivement corrigé ce problème rémanent avec VirtueMart, une mixture selon les fichiers entre de l'utf-8 et le iso-8859-1
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          J'ai subitement un doute :

          Je suis subitement empreint d'un doute : je débute comme vous avez du surement le remarquer. "La question qui tue" :

          Je dois installer le fichier languages.zip par le biais de l'administration Joomla(installer et désinstaller dans la rubrique "Extension") ou dois je le décompresser et remplacer dans un répertoire?

          Quand on ne sait pas il vaut mieux demander non?

          Décliquement.

          Commentaire


          • #6
            il faut le désarchiver en local et envoyer par FTP en /administrator/components/com_virtuemart/languages en écrasant les fichiers existants.
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Envoyé par ludodev Voir le message
              Quand on ne sait pas il vaut mieux demander non?

              Décliquement.
              tout a fait!

              dans la precipitation de mettre un fichier, corrige, rapidement sur le svn, j'en ai oublie d'inclure le readmefirst file qui explique cela ;

              jisse03 a indique la facon de proceder.

              bien que nous desirions que ces soucis ne se produisent pas, cela peut arriver parfois, car les activites sont nombreuses...
              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
              http://virtuemart.fr

              Commentaire


              • #8
                Bonjour à vous,

                Je vous remercie de toutes vos réponses, vous me sortez une sacré épine d'un pied et je comprend très bien que vous avez un volume de travail énorme(faut dire qu'il y a de plus en plus d'utilisateurs et c'est tant mieux) et j'espère, quand j'aurais un peu plus d’expérience, pouvoir participer de manière plus active au forum et pouvoir donc vous filer la main.

                Merci pour votre patience.

                Des clics et des clics encore et encore.

                Une bonne journée.

                Commentaire


                • #9
                  Re Bonjour,

                  Je vous confirme que le problème est résolu, l'encodage fonctionne parfaitement, vous m'avais permis de régler ce soucis en moins de deux!!!!!!

                  Encore un grand merci.

                  Commentaire


                  • #10
                    Merci de ton retour

                    bonne continuation
                    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                    http://virtuemart.fr

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X