Problèmes avec les produits spéciaux

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problèmes avec les produits spéciaux

    Bonjour,

    je viens de créer une boutique avec joomla et virtuemart et je rencontre actuellement un problème avec des produits spéciaux qui sont placés sur la page d'accueil, lorsque l'on clic dessus il devrait s'afficher la page détaillé sur le produit, seulement il ne se passe absolument rien, comme si ils donnaient lien à la page d'accueil elle même.

    J'ai beau chercher partout et retourner le problème dans tous les sens, je ne trouve pas la solution.

    Merci de m'éclairer si certains ont déjà rencontrés ce problème.

  • #2
    Re : Problèmes avec les produits spéciaux

    Bonjour,

    Ton problème vient très certainement de ta définition de ces produits "SPÉCIAUX", Spéciaux en quoi, et comment sont-ils référencés dans ton site ?
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Problèmes avec les produits spéciaux

      j'ai mis ces produits là dans le menu composants/virtuemart/produits/produits spéciaux, tout cela pour qu'ils apparraissent justement sur la page d'accueil mais à part être dans la catégorie "produits spéciaux" du menu "produits" de virtuemart, ils n'ont rien de vraiment spéciaux.
      Ils sont référencés exactement comme les autres produits, dans la liste des produits et avec leur propre catégorie.

      J'avoue que c'est mon premier site avec virtuemart.... Merci de m'éclairer SVP

      Commentaire


      • #4
        Re : Problèmes avec les produits spéciaux

        le module qui semble afficher ces produits est le module "VirtueMart Featured Products", seulement j'ai bien vérifié les paramètres sont identiques que sur le site préalablement réalisé sur serveur local et cela ne marche que sur le site en local.
        sur le site en ligne, les vignettes ne mènent nul part...

        Commentaire


        • #5
          Re : Problèmes avec les produits spéciaux

          je viens d'essayer de mettre directement le lien dans l'emplacement URL du produit seulement un problème se pose:
          le lien que je rentre est http://www.bloodngold.com/index.php?...emart&Itemid=29

          et le lien qui sort quand on clic est http://www.bloodngold.com/index.php?...emart&Itemid=28

          le seul truc qui change est que je rentre le lien avec "29" à la fin et qu'il s'obstine à sortir en "28"
          comment cela est il possible?
          J'ai assez peu de compétence à ce niveau là... aidez moi SVP

          Commentaire


          • #6
            Re : Problèmes avec les produits spéciaux

            en fait quoi que je rentre comme URL, il n'y à que ce second qui apparaisse..

            Commentaire


            • #7
              Re : Problèmes avec les produits spéciaux

              Tu dois avoir quelque part un doublon de menu ou un truc du même genre.
              Pas de demande de support par MP.
              S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

              Commentaire


              • #8
                Re : Problèmes avec les produits spéciaux

                qu'est que vous appelez un "doublon de menu" exactement?
                comment puis-je remédier à tout cela svp?

                Commentaire


                • #9
                  Re : Problèmes avec les produits spéciaux

                  le problème persiste toujours...
                  Quelqu'un peut il m'aider svp?

                  Commentaire


                  • #10
                    Re : Problèmes avec les produits spéciaux

                    bonjour,
                    je reviens poster ici car le problème est toujours là.
                    Si vous voulez voir ce qu'il en est allez à l'adresse : http://www.bloodngold.com/
                    Ce sont donc les vignettes de la page d'accueil qui persistent à ne mener nul part...
                    Je crois avoir tout ésayé, je bloques complètement. Aidez moi SVP

                    Commentaire


                    • #11
                      Re : Problèmes avec les produits spéciaux

                      Quand on passe vie le menu, l'item ID de ton virtuemart est le 29. Dans ton module tu pointes sur un itemid=28, qui doit mener à un menu dépublié ou un gag du même genre.
                      Pas de demande de support par MP.
                      S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                      Commentaire


                      • #12
                        Re : Problèmes avec les produits spéciaux

                        bonjour,
                        merci pour votre réponse.
                        Je cherches du côté des menus mais ne trouve rien.
                        comment puis-je changer ce 28 en 29??

                        merci

                        Commentaire


                        • #13
                          Re : Problèmes avec les produits spéciaux

                          Bonjour,
                          Je cherche du côté des menus mais ne trouve rien.
                          mais encore ? Tu as trouvé l'élément de menu avec l"ID 29 ? Et avec l'ID 28 ?
                          Schtroumpfe toi le Schtroumpf t'aidera.
                          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                          Commentaire


                          • #14
                            Re : Problèmes avec les produits spéciaux

                            l'ID 29 est sur le menu "plus d'infos" et l'ID 28 est sur la page d'accueil.

                            Commentaire


                            • #15
                              Re : Problèmes avec les produits spéciaux

                              Re,
                              je soupçonne que le router utilisé a du mal avec l'url que tu lui donnes, et que du coup il garde l'Itemid de la page courante.
                              "http://www.bloodngold.com/index.php?page=shop.product_details&category_id=1& flypage=flypage.tpl&product_id=4&option=com_virtue mart" c'est peut être un peu trop tordu ; tu pourrais commmencer par mettre les choses dansle bon ordre :
                              http://www.bloodngold.com/index.php?...l&product_id=4
                              Si ça ne change rien, donne la référence exacte de ton module (url où on peut le récupérer) histoire de voir ce qu'il a dans le ventre.
                              Schtroumpfe toi le Schtroumpf t'aidera.
                              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X