Problème avec mes fins de pages Virtuemart

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème avec mes fins de pages Virtuemart

    Bonjour,

    Je lance un appel à l'aide car je n'arrive pas a solutionner mon problème, d'autant que ce problème n'est pas "récurrent".

    Je m'explique: J'ai créer en local un site joomla avec la boutique virtuemart. Lorsque je me balade sur le site pas de soucis, jusqu'à un moment où les pieds de page et la colonne de droite n'apparaissent plus sur les pages de la boutique (en revanche ces éléments sont toujours bien présent dans le reste du site joomla).

    J'ai essayé de comparer le code d'une page "saine" d'une page "malade" de la boutique. Il semblerait qu'il y ai un problème dans le script qui fait avorter la fin du code et qui du coup empêche l'apparition du pied de page et de la colonne de droite.

    Je suis désolé de ne pouvoir mieux vous expliquer mon problème.... mais j'espère qu'avec un peu de chance des gens à qui un problème du même genre est arrivé pourront m'aider...

    Quoiqu'il en soit je suis dispo pour répondre à vos questions qui permettront au sujet d'avancer.

    Merci d'avance!

  • #2
    Re : Problème avec mes fins de pages Virtuemart

    Bon alors, pour ceux qui dans un élan de générosité pourrait m'aider dans la résolution de mon problème, j'ai découvert deux éléments nouveaux:

    1) Mon problème survient lorsque je consulte une des pages "produit" de virtuemart. C'est a dire que je peux me balader dans les catégories sans problème, mais lorsque je consulte une page produit (peu importe laquelle) et que je passe ensuite sur une autre page, je perds pied de page et colonne de droite

    2) J'ai regardé du côté des cookies (j'ai vu deux cookies, virtuemart et un autre "6c77300da4361936c3f3d31c0d110be3"), et j'ai remarqué qu'en supprimant le cookie "6c77300da4361936c3f3d31c0d110be3", le problème disparaissait jusqu'à ce que je consulte à nouveau la page d'un produit....

    Commentaire


    • #3
      Re : Problème avec mes fins de pages Virtuemart

      Bonsoir

      Faire un vidage du cache système dans le back end déjà.

      Si idem alors faire un essai de changement de serveur local ça peut contourner le problème.

      Sinon généralement si tu mets le site en distant ce genre de souci disparait.

      Perso je ferai un essai sur un serveur distant pour en avoir le coeur net

      @+
      SVP pas de MP pour de l'aide, le forum est l’outil idéal

      Commentaire


      • #4
        Re : Problème avec mes fins de pages Virtuemart

        Merci LeMalouin pour ta réponse!

        Je viens justement d'essayer de mettre mon site sur un serveur distant mais cela n'a rien changé. As-tu déjà vu le même genre de soucis que le mien?

        Quand tu parles d'un "vidage du cache système", tu parles par rapport à mon PC ou par rapport à l'administration de Joomla/virtuemart (dans le premier cas le simple fait de faire le test sur 2 PC résout le pb, ce qui n'a pas été le cas, et dans le second cas, c'est une manip que je ne connais pas donc impossible de tester)?

        Merci.

        Commentaire


        • #5
          Re : Problème avec mes fins de pages Virtuemart

          Bonjour

          Vidage dans joomla évidemment :=)
          @+
          SVP pas de MP pour de l'aide, le forum est l’outil idéal

          Commentaire


          • #6
            Re : Problème avec mes fins de pages Virtuemart

            Bonjour,

            Je viens de regarder dans l'adminisitration joomla : configuration générale\système et le "non" est coché au niveau de la ligne "cache".

            J’interprète cela comme le cache qui n'est pas activé et donc pas de données dans le cache. Est-ce que je me trompe ou existe-il un autre cache?

            Merci.

            Commentaire


            • #7
              Re : Problème avec mes fins de pages Virtuemart

              Personne ne peut m'aider?

              Commentaire


              • #8
                Re : Problème avec mes fins de pages Virtuemart

                --> outils ----> nettoyer le cache

                Commentaire


                • #9
                  Re : Problème avec mes fins de pages Virtuemart

                  Merci pour l'aide mimimike64.

                  Le nettoyage du cache n'a pas résolu mon problème malheureusement

                  Commentaire


                  • #10
                    Re : Problème avec mes fins de pages Virtuemart

                    ..l'adresse de ton site...pour voir. As tu essayé de changer de fly page ?

                    Commentaire


                    • #11
                      Re : Problème avec mes fins de pages Virtuemart

                      J'ai en effet déjà essayé de changer les fly pages mais cela n'a rien changé

                      Merci!
                      Dernière édition par Merit à 19/08/2011, 15h06

                      Commentaire


                      • #12
                        Re : Problème avec mes fins de pages Virtuemart

                        as tu vérifié le paramétrage de ton ou de tes modules concernés ? ( ton template est très sympa . gratuit ou payant ?)

                        Commentaire


                        • #13
                          Re : Problème avec mes fins de pages Virtuemart

                          En fait le "module" concerné est uniquement virtuemart et je n'ai pas trouvé d'anomalies dans son paramétrage.

                          As-tu pu constater également ce que j'ai expliqué précédemment à savoir "Mon problème survient lorsque je consulte une des pages "produit" de virtuemart. C'est a dire que je peux me balader dans les catégories sans problème, mais lorsque je consulte une page produit (peu importe laquelle) et que je passe ensuite sur une autre page, je perds pied de page et colonne de droite"

                          Le template est un template payant.

                          Commentaire


                          • #14
                            Re : Problème avec mes fins de pages Virtuemart

                            Bonjour,


                            il te manque la class content-wrapper-b2 pour la fin de ton content.
                            As tu demandé à yootheme ?
                            Création, personnalisation, synchronisation de gestion commerciale selige.fr:http://www.selige.fr
                            "Avant de critiquer un produit gratuit, pense à ce que tu aurais pu dire si tu l'avais payé"

                            Commentaire


                            • #15
                              Re : Problème avec mes fins de pages Virtuemart

                              Merci pour ta réponse selige.

                              Non je n'ai pas demandé à Yootheme car pour moi ce n'est pas leur template qui est en cause (mais je me trompe peut-être..) car les problème concernent uniquement les pages de la boutiques virtuemart (et plus précisément les pages "produits").

                              Ne puis-je pas régler le problème des "content-wrapper-b2" en éditant un ou deux fichiers du site?

                              Merci beaucoup.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X