problème installation SP PLUS

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] problème installation SP PLUS

    Bonjour à tous,

    je cherches désespérément à installer SP PLUS sur virtuemart, j'ai bien suivi à la lettre le tuto d'ALATAK pour la mise en service : http://www.alatak.net/tutoriels-paie...-paiement.html, jusque là tout va bien.

    Dès lors que je test le moyen de paiement en service sur mon site, j'obtiens plusieurs erreurs :

    Code:
    Warning: fopen(http://www.monsite.fr/cgi/hmac_elec_net.cgi?reference=10593&langue=FR&devise=978&montant=17.85&taxe=0.00&valauto=f&validite=29%2F09%2F2011&moyen=CBS&modalite=1x&methode=&urlretour=http%3A%2F%2Fwww.elecsurtoile.fr%2Fspplus_notify.php&email=charlie.bard29%40gmail.com) [function.fopen]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /homepages/30/d262794091/htdocs/administrator/components/com_virtuemart/classes/payment/ps_spplus.php on line 987
    
    Warning: fgetss(): supplied argument is not a valid stream resource in /homepages/30/d262794091/htdocs/administrator/components/com_virtuemart/classes/payment/ps_spplus.php on line 989
    
    Warning: fclose(): supplied argument is not a valid stream resource in /homepages/30/d262794091/htdocs/administrator/components/com_virtuemart/classes/payment/ps_spplus.php on line 992
    erreur lors de la signature de l'URL
    Si quelqu'un peut m'éclairer car là je déséspère...

    Merci d'avance.

    Carotte--

  • #2
    Re : problème installation SP PLUS

    Bonjour,

    je vois ceci : Warning: fopen(http://www.monsite.fr...
    C est toi qui a changé le nom avant de copié le message ou c est comme ça que c est indiqué ?
    Création, personnalisation, synchronisation de gestion commerciale selige.fr:http://www.selige.fr
    "Avant de critiquer un produit gratuit, pense à ce que tu aurais pu dire si tu l'avais payé"

    Commentaire


    • #3
      Re : problème installation SP PLUS

      oui c'est moi qui ai changé avant de poster.

      Commentaire


      • #4
        Re : problème installation SP PLUS

        je me suis rendu compte que le chemin de mon fichier hmac n'était pas bon. Je l'ai modifié et maintenant lorsque je suis rediriger vers le site caisse d'épargne, j'ai une belle erreur 400

        Error 400 - Bad request

        L'URL contient des erreurs et ne peut donc pas être lue. Veuillez si possible corriger l'URL et relancer ensuite la requête.

        oh my god!!!
        Dernière édition par carotte à 28/09/2011, 16h55

        Commentaire


        • #5
          Re : problème installation SP PLUS

          Vérifie que ton domaine est bon de partout dans la configuration joomla
          Vérifie que les droits d’exécution sont actifs sur le cgi
          Photographe en devenir http://www.pictmania.com
          Concepteur de solutions serveurs Linux à base d'Ubuntu http://www.rezobox.com
          Créateur de site internet : http://www.infomagique.com
          ubuntu, joomla, prestashop

          Commentaire


          • #6
            Re : problème installation SP PLUS

            bonjour eric,

            j'ai tout vérifié, ça à l'air bon.

            Je continue à chercher...

            Si une âme charitable avait la réponse, ça ne serait pas de refus!

            Commentaire


            • #7
              Re : problème installation SP PLUS

              à croire que ça n'arrive qu'a moi ce genre de trucs lol

              en fait je n'ai accès qu'au dossier cgi que j'ai créé pour l'occasion, vu qu'il s'agit d'un serveur mutualisé.

              Est-ce que ça peut venir de l'URL REWRITING?

              Commentaire


              • #8
                Re : problème installation SP PLUS

                Ayant tout recommencé depuis le début, ça fonctionne à présent allez savoir pourquoi?

                Autre problème, lors du paiement, et de la redirection vers mon site, et HOP nouvelle erreur...


                Code:
                Warning: fopen(/homepages/30/d262794091/htdocs/logs/logsentinelle.php) [function.fopen]: failed to open stream: Permission denied in /homepages/30/d262794091/htdocs/libraries/joomla/error/log.php on line 202
                et une fois sur mon site : Protection Sentinelle message : Vous n'êtes pas autorisé à accéder à cette ressource

                C'est dingue que tout soit autant instable...
                Dernière édition par carotte à 29/09/2011, 15h54

                Commentaire


                • #9
                  Re : problème installation SP PLUS

                  désactivé le plugin sentinelle, ça fonctionne, au détriment de la sécurité...

                  Nouveau problème, les images spplus affichant le choix du paiement (VISA, MASTERCARD...) ne s'affichent pas alors qu'elles sont bien dans le dossier /components/com_virtuemart/shop_image/payment. Une solution???

                  Sans ça, la caisse d'épargne ne veut pas passer le mode en production.

                  Je vais craquer...

                  Au fait j'aime les monologues.

                  Commentaire


                  • #10
                    Re : problème installation SP PLUS

                    Bonjour,
                    Ah c'est difficile de ne pas avoir de reponse quelque fois.
                    Mais c'est peut être aussi que personne n a la reponse pour l instant

                    Pour les images, si elles sont bien dans le bon repertoire, verifies les chemins que tu prends pour les afficher.

                    Firebug te donne t il une reponse sur ces images ?
                    Création, personnalisation, synchronisation de gestion commerciale selige.fr:http://www.selige.fr
                    "Avant de critiquer un produit gratuit, pense à ce que tu aurais pu dire si tu l'avais payé"

                    Commentaire


                    • #11
                      Re : problème installation SP PLUS

                      Bonjour selige,

                      je dois dire que ca fait chaud au coeur d'avoir une réponse

                      Non, à aucun moment cette image ne s'affiche, aucune trace dans firebug.

                      Ni au moment du choix du paiement, ni lors de la redirection vers le site caisse d'épargne, voir les screen.
                      Fichiers joints

                      Commentaire


                      • #12
                        Re : problème installation SP PLUS

                        Tu parles des images CB, mastercard que tu as à coté des select dans le choix du paiement ?
                        Si c'est ça c'est un hack, de memoire, il faut regarder du coté du fichier ps_payment.
                        Création, personnalisation, synchronisation de gestion commerciale selige.fr:http://www.selige.fr
                        "Avant de critiquer un produit gratuit, pense à ce que tu aurais pu dire si tu l'avais payé"

                        Commentaire


                        • #13
                          Re : problème installation SP PLUS

                          Logiquement avec le module d'alatak, nous devrions avoir un tableau à choix multiples de ce style (pièce jointe) , et qui redirige vers le site de la banque en fonction du choix.
                          Fichiers joints

                          Commentaire


                          • #14
                            Re : problème installation SP PLUS

                            Je vois cette image chargée sur checkout.spplus_cc_form....
                            Regardes
                            Création, personnalisation, synchronisation de gestion commerciale selige.fr:http://www.selige.fr
                            "Avant de critiquer un produit gratuit, pense à ce que tu aurais pu dire si tu l'avais payé"

                            Commentaire


                            • #15
                              Re : problème installation SP PLUS

                              Oui, apparemment c'est censé s'ouvrir dans un pop-up, mais moi j'ai rien

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X