Virtuemart2 - Erreur de récupération des données USERS pendant la migration

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Virtuemart2 - Erreur de récupération des données USERS pendant la migration

    Bonsoir,

    Je viens de faire plusieurs essais pour migrer en local un clone de boutique (J! 1.5.24 + VM 1.1.8) en suivant la procédure officielle : impossible de récupérer les infos concernant les utilisateurs (toute la partie infos supplémentaires de type adresse), avec un message d'erreur (cité sur le forum VM anglophone, mais sans réponse)
    Fatal error: Class 'storing user adress dataTableVmusers' not found in D:\wamp\www\site_test\libraries\joomla\language\la nguage.php on line 171
    Le site est par défaut en français, la boutique également.
    Je ne vois pas ce que j'ai pu oublier.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

  • #2
    Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

    Bonjour

    As tu fait un essai de refaire une migration " utilisateurs"

    Nous avons peut être un souci justement avec la version 1.1.8 pour migrer sur VM2.

    Personnellement pour faire les essais de migration avant j'ai update un backup en local qui était en 1.1.8 sur 1.1.9 puis de la sur VM2.

    C'est peut être une piste

    @+
    SVP pas de MP pour de l'aide, le forum est l’outil idéal

    Commentaire


    • #3
      Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

      J'ai refait plusieurs fois la manœuvre avec toujours le même message concernant les utilisateurs.
      Ce n'est pas un site "à moi" et j'ai testé sur un clone tel quel (partant du principe que la migration n'exige officiellement pas la 1.1.9) donc il faudra d'abord que je fasse les mises à jour en local avant de tester de nouveau cette migration.
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

        Ok quand je disais
        Personnellement pour faire les essais de migration avant j'ai update un backup en local qui était en 1.1.8 sur 1.1.9 puis de la sur VM2.
        C’est parce que VM2 a déboulé dans la semaine ou j'avais migré de 1.1.8 à 1.1.9 ... j'ai toujours ce backup en VM1.1.8 si j'ai le tps je vais faire un essai (de 1.1.8 à VM2) ... avec la migration officiel et nos essais en manuel

        J'ai vu ton topic sur le forum virtuemart effectivement nous n'avons pas de réponse la dessus c'est dommage

        @+
        SVP pas de MP pour de l'aide, le forum est l’outil idéal

        Commentaire


        • #5
          Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

          Je me réfère en fait à ce qui est affiché dans VM2 : migration de 1.1.x vers 2.0.y
          Mais bon, c'est pas gagné, le gestionnaire du site a peur de mettre à jour en 1.1.9 parce que le template avait été acheté en version 1.1.8...
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

            Ok bon migration VM1.1.8 vers VM2

            j'ai effectivement ceci :
            vmError: storing user adress dataTableVmusers::bind failed. Invalid from argument
            vmError: TableVmusers::bind failed. Invalid from argument
            mais aussi
            vmError: TableUserinfos Le paramètre COM_VIRTUEMART_ADDRESS_TYPE est manquant. Impossible d'enregistrer sans ce paramètre COM_VIRTUEMART_ADDRESS_TYPE.
            vmError: TableVmusers::bind failed. Invalid from argument
            Par contre j'ai bien les "Informations additionnelles" disponibles dans la fiche client malgré les erreurs au moment de la migration

            J'ai comparé avec un autre site que j'avais nommé "VM1 migration VM2 manuel" et là effectivement je viens de m’apercevoir que j'ai aucunes "Informations client"

            Je vais voir si sur ce site je peux récupérer malgré la migration déjà effectué les "Informations additionnelles"

            @+


            Edit : Par "Réinitialiser toutes les tables et installer à nouveau" = aucun résultat

            Re Edit : "Migration" avec option coché "utilisateurs" donne = OK

            Voilà pour mes tests ... j'ai bien une récupération des "Informations additionnelles" par la suite si au départ lors de la migration elles ont pas migrés ... à toi de me dire de ton côté
            Dernière édition par LeMalouin à 13/01/2012, 12h18
            SVP pas de MP pour de l'aide, le forum est l’outil idéal

            Commentaire


            • #7
              Re : VIRTUEMART 2.0.0 STABLE disponible sous joomla 1.5.X

              Mes tests s'étaient faits sous PHP 5.2.11, en passant à PHP 5.3, j'ai effectivement ce message
              vmError: storing user adress dataTableVmusers::bind failed. Invalid from argument
              vmError: TableVmusers::bind failed. Invalid from argument
              Erreur de lecture de la table d'origine ? mais après vérification, les infos d'adresse des clients semblent bien importées.

              Par contre, toutes les commandes se retrouvent "en suspens".
              Dernière édition par RobertG à 13/01/2012, 14h24
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire


              • #8
                Re : Virtuemart2 - Erreur de récupération des données USERS pendant la migration

                Par contre, toutes les commandes se retrouvent "en suspens".
                ah je vérifie chez moi

                @+


                Edit : non pour moi c'est ok
                Peux être refaire une importation pour voir non?
                Dernière édition par LeMalouin à 13/01/2012, 14h46
                SVP pas de MP pour de l'aide, le forum est l’outil idéal

                Commentaire


                • #9
                  Re : Virtuemart2 - Erreur de récupération des données USERS pendant la migration

                  J'ai réessayé mais ça n'a pas changé le statut des commandes
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    Re : Virtuemart2 - Erreur de récupération des données USERS pendant la migration

                    Re

                    Désolé, vu que j'ai pas de souci de statut commande je ne peux aider plus et faire de simulation.

                    Par contre il me vient une idée les statuts personnalisés ne sont pas migrants.
                    Ne migrent que les statuts :

                    Suspens P
                    Confirmed C
                    Cancelled X
                    Refunded R
                    Shipped S

                    Ce site n'avait-il pas de statut perso?

                    Si oui il ne peut que mettre par défaut en prenant le 1er ID statut "suspens"

                    @+
                    Dernière édition par LeMalouin à 13/01/2012, 17h48
                    SVP pas de MP pour de l'aide, le forum est l’outil idéal

                    Commentaire


                    • #11
                      Re : Virtuemart2 - Erreur de récupération des données USERS pendant la migration

                      Effectivement, il y a des statuts supplémentaires sur ce site, donc ça va être la galère pour beaucoup de boutiques si la migration n'arrive pas à récupérer le statut de chaque commande après avoir transféré les différents statuts personnalisés de la V1.1 à la V2.

                      Il faut donc à mon avis que la procédure de migration ne cherche pas à faire le lien entre les statuts standard de la V2 et ceux du site en V1, mais transfère Id et autres champs préexistants.

                      Donc pour le moment :
                      - il faut apparemment une version de PHP au moins égale à 5.3.0 pour récupérer les données utilisateurs (malgré le message d'erreur)
                      - on ne récupère pas le statut des commandes si des statuts personnalisés ont été définis...

                      J'ai remarqué également que si j'installais la V2 sans les exemples, je n'avais aucune possibilité de paramétrer la boutique (pas d'onglet "vendeur" par exemple.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire


                      • #12
                        Re : Virtuemart2 - Erreur de récupération des données USERS pendant la migration

                        Bonjour

                        J'ai remarqué également que si j'installais la V2 sans les exemples, je n'avais aucune possibilité de paramétrer la boutique (pas d'onglet "vendeur" par exemple.
                        Oui effectivement j'en parle dans le topic de virtuemart2

                        C'est effectivement ce que nous avons remarqué avec nos essais (je parle avant de voir qu'il y avait un lien tuto sur le site de Virtuemart).

                        Pour cela, il nous a fallu refaire une installation complète de Virtuemart car il semblait impossible de débugger cette situation.

                        Pour les états de commandes c'est effectivement bien un souci de non migrant sur les statuts personnalisés.
                        Faudrait voir du côté de la base de données dans _virtuemart_orderstates si tu peux pas par défaut rajouter des "order_status_id " identique et refaire une migration.

                        Ca doit marcher je pense

                        @+
                        Dernière édition par LeMalouin à 14/01/2012, 09h50
                        SVP pas de MP pour de l'aide, le forum est l’outil idéal

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X