Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus affiché

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus affiché

    Joomla : 1.5.26
    VirtueMart : 1.1.9
    URL : http://www.biootyzen.com/

    Bonjour à tous,

    Je vous soumets un problème dont m’ont fait part plusieurs clientes du site cité ci-dessus.

    Le problème est le suivant :

    Si j’ajoute un produit à mon panier puis que je clique sur le bouton « Précédent » (présent généralement en haut à gauche dans la plupart des navigateurs web), le panier reprend la valeur de la page précédente (par exemple 0 si aucun produit n’a été ajouté précédemment). Il faut alors rafraîchir la page ou accéder à une autre page du site pour que le panier soit bien incrémenté.

    J’ai tenté de régler ce problème en activant / désactivant la vérification des cookies depuis « VirtueMart / Configuration générale / Configuration / Activer la vérification de l'autorisation cookie » mais cela ne résout pas ce problème.

    Le fait est que lors du retour à la page précédente le navigateur web garde en mémoire, je suppose, le contenu de la page précédente sans mettre à jour les informations qui ont été modifiées entre temps.

    Ceci est assez problématique car plusieurs clientes qui utilisent souvent ce bouton « Précédent » ne comprennent pas pourquoi, après avoir ajouté un produit au panier puis être revenu sur la page précédente, leur produit est bien ajouté puis est ensuite « supprimé ».

    Je pense qu’il faudrait forcer un rechargement de la page une fois le produit ajouté mais j’ignore comment l’implémenter, à moins que vous n’ayez d’autres alternatives pour pallier à ce problème ?

    D'avance, je vous remercie

  • #2
    Re : Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus aff

    Bonjour,
    j'ai déjà rencontré ce problème et je l'ai pour ma part résolu en désactivant le système de cache.
    (tente de desactiver le "system-cache" dans extention->plugin)
    Avant d'en venir là, tente dans l'administration du site, onglet outils / nettoyer le cache et purger les fichiers expirés du cache et fais des tests.
    Souhaitant que tu puisses régler le souci avec cette méthode.
    Ca devrait le faire et des fois ça le fait pas...

    Commentaire


    • #3
      Re : Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus aff

      Bonjour,

      Tout d’abord je vous remercie de vous pencher sur mon problème.

      J’ai effectué un « Outils / Nettoyer le cache » et un « Outils / Purger les fichiers expirés du cache » mais le problème est toujours présent.

      Concernant le plugin « System – Cache », celui-ci était déjà désactivé.

      Je pense toujours à la « solution » de recharger la page après l’ajout d’un produit dans le panier, mais ceci ne résout pas totalement le problème car l’internaute peut bien sûr revenir 2 fois voir plus en page précédente.

      Synkro.

      Commentaire


      • #4
        Re : Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus aff

        2 pistes à suivre : sef est-il activé ? (réécriture des url avec Artio, Joomsef ou autre)
        si oui, tenter de le désactiver et faire des tests (sinon vérifier dans la configuration générale, onglets Sef)

        voir ensuite en désactivant le cache sur le site. Ce problème de panier peut avoir à mon sens 2 causes :
        le cache du site qui réaffiche une page du panier qui n'a plus lieu d'être, ou bien une réécriture d'url qui force l'affichage d'une page avec un panier obsolète.
        Regarde également dans les modules Virtuemart si tu as le cache activé dans mod_cart (je ne me souviens plus si cette option existe pour ce module.

        Bonne chance
        Ca devrait le faire et des fois ça le fait pas...

        Commentaire


        • #5
          Re : Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus aff

          Bonjour,

          J’utilise le composant SH404SEF dans sa dernière version (2.5.0.1040) pour Joomla 1.5 avec VirtueMart 1.1.9, mais même si ce composant est désactivé, ainsi que tous les paramètres SEO présents dans « Site / Configuration générale » le problème persiste.

          Le System - Cache est bien désactivé sur le site ( depuis « Extension / Gestion des plug-ins / System – Cache ») et je n’utilise pas d’autre composant ou plug-in de gestion du cache.

          Pour le panier, j’utilise le module « Flexible Drop Down Cart » proposé par Flexible Web Design ( http://www.flexiblewebdesign.com/ ) mais ce module ne comporte pas d’option de mise en cache.

          Le panier par défaut de VirtueMart ( mod_virtuemart_cart ) ne propose pas non plus de mise en cache.

          Synkro.

          Commentaire


          • #6
            Re : Ajout d’un produit au panier puis "Bouton précédent" : le produit n’est plus aff

            as-tu essayé de désactiver le cache dans config générale de Joomla . (colonne de droite)
            Sinon, je ne connais pas ton module de panier. Si tu utilises le panier par défaut de VM tu as le même bug ?
            Peut-être que le concepteur de ton module Flexible Drop Down Cart aurait une idée sur le bug, il doit bien maitriser...
            Ca devrait le faire et des fois ça le fait pas...

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X