Tronquage déscription avec accents

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • ZoOoOoP
    a crée un sujet Tronquage déscription avec accents

    Tronquage déscription avec accents

    Bonjour, je ne sais pas trop dans quelle catégorie placer mon problème, Joomla, VirtueMart ou module éditeur.
    Du jour au lendemain, mes descriptions de produits sur VirtueMart sont tronquées au premier accent. Le même module éditeur ne pose aucun problème autre part que dans VirtueMart.
    Par contre l'éditeur de base de Joomla ne pose pas de problème sur VirtueMart.
    J'ai réessayé de réinstaller le module éditeur en question (WYSIWYG Editor de JXTENDED) (basé sur FCKeditor), mais toujours le même problème.
    Exemple : je met "abcdèfgh", j'obtiens "abcd"
    Par contre, lorsque je met la source en wysiwyg plus aucun problème !
    "é" -> source -> "é" (Problème)
    "é" -> source -> "é" (Plus de problèmes)

    Merci de m'aider à trouver la source de ce problème.
    Dernière édition par ZoOoOoP à 09/12/2008, 20h04

  • hervesage
    a répondu
    Passe un mail au support hot-line de OVH, il serait etonant qu'ils ne proposent pas cette option.

    Peux tu me dire quelle version du composant JCE tu as?

    Laisser un commentaire:


  • ced007
    a répondu
    Bon et bien malgrès les réparations et optimisations de ma base, c'est toujours pareil.
    Le problème persiste.
    Je suis hébergé chez OVH et la base est en PHP4, je ne pense pas qu'il soit possible de basculer en PHP5 comme pour vous hervesage.
    Si quelqu'un à une idée....merci

    Bonne fêtes de fin d'année....

    Laisser un commentaire:


  • hervesage
    a répondu
    J'ai trouvé pour contourner le Pb, passer en PHP5
    Ma base était hébergé en PHP4, je l'ai passé en PHP5 et là plus de PB. Les accents sont bien acceptés dans la description du produit.
    L'avantage c'est que mon hébergeur me propose PHP4 ou PHP5 pour chacune de mes bases d'un simple clic.

    Cependant j'ai plusieurs site dans des sous domaines qui me servent de test, et j 'en ai un en PHP4 qui ne connait pas le pb. Il est aussi sous j1.5.8 vm 1.2
    Les seules différences que je vois comme ça c'est que le pack langue française n'a pas été installé sous vm et que le composant de JCE est le 1.5.0 stable tandis que sur la base qui ne fonctionne pas en PHP4 le composant JCE est le 1.5.0b

    Je vais essayer de gratter pour voir d'ou viens le PB à la base. mais le principal c'est qu'on puisse le contourner.

    Laisser un commentaire:


  • hervesage
    a répondu
    Bonsoir,

    Même pb que vous, j'ai remarqué que ça le faisait avec JCE mais qu'avec TinyMCE pas de problème.
    Si quelqu un avait une solution, elle serait vraiment la bienvenue.
    Merci d'avance.

    Laisser un commentaire:


  • tchouf
    a répondu
    Envoyé par ZoOoOoP Voir le message
    ---
    phpMyAdmin -> Optimiser & Réparer
    ---
    &&&
    ---
    htaccess ->

    "SetEnv REGISTER_GLOBALS 0
    SetEnv ZEND_OPTIMIZER 1
    SetEnv MAGIC_QUOTES 1
    SetEnv PHP_VER 5"
    ---
    Je sais pas si c'est une de ces deux choses que j'ai fait qui a résolu le problème mais il est résolu =)

    Merci

    Désolé, mais je n'arrive pas a appliquer cette methode...

    Pourrais-tu etre un peu plus précis quand a la marche a suivre ?

    Merci

    Laisser un commentaire:


  • sbsamy
    a répondu
    bonsoir à vous

    Merci à vous
    ça marche...

    Laisser un commentaire:


  • roger
    a répondu
    bonsoir a tous

    je suis en php 5.2.6
    er myslq 5.0.

    j'avais de gros souci d'accent d'apostrophe etc.

    j'ai suivi les indication zooop ça marche
    j'ai tous cocher et cliquer sur optimiser la table
    puis tous recocher et cliquer sur reparrer la table

    maintenant tous est ok

    merci bonsoir

    roger

    Laisser un commentaire:


  • col123
    a répondu
    merci de donner la version de php et de mysql.

    cela peux aider à résoudre les problèmes d'encodage

    Laisser un commentaire:


  • ced007
    a répondu
    Bonsoir,
    pourrais-tu développer un peu plus ces deux méthodes pour les débutants?
    Merci

    Laisser un commentaire:


  • ZoOoOoP
    a répondu
    ---
    phpMyAdmin -> Optimiser & Réparer
    ---
    &&&
    ---
    htaccess ->

    "SetEnv REGISTER_GLOBALS 0
    SetEnv ZEND_OPTIMIZER 1
    SetEnv MAGIC_QUOTES 1
    SetEnv PHP_VER 5"
    ---
    Je sais pas si c'est une de ces deux choses que j'ai fait qui a résolu le problème mais il est résolu =)

    Merci

    Laisser un commentaire:


  • ZoOoOoP
    a répondu
    Personne ne sais comment remédier à ce problème ?
    Tout marchant bien avant.
    Cela vous fait le problème avec VirtueMart seulement ?
    Dernière édition par ZoOoOoP à 11/12/2008, 16h01

    Laisser un commentaire:


  • tchouf
    a répondu
    J'ai eu le même problème, j'ai du retirer tous les accents...

    Laisser un commentaire:


  • ced007
    a répondu
    Bonjour,
    Pareil que vous!!
    J'écris mon texte mais dès que je valide, il ne me reste plus qu'une ligne!!
    C'est assez génant!! Je suis obligé de passe par PHPMyAdmin pour que cela fonctionne!!

    Quelqu'un à une idée?
    Merci

    Laisser un commentaire:


  • sbsamy
    a répondu
    J'ai le meme problème aussi...

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins
Travaille ...
X