CGV(manquantes) + case a cocher

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • CGV(manquantes) + case a cocher

    bonjour,

    le script est deja en place, chez moi, dans le bon fichier(je veux dire la traduction francaise, dans components/com_virtuemart/languages/common/french).
    J'ai coche la cacase (accepter les CGV)
    remplit mon champ (c'est la saison!)

    active/desactive/active/desactive/refresh/re-refresh/re-re-refresh et.... pa ni solution!

    Firebug precise, lors de la bonne config, qu'a cet emplacement il y a ce script :

    <noscript> <label for="agreed_field">J'accepte les conditions d'utilisation</label> <a target="_blank" href="http://www.xxxxxxxxx/index.php?option=com_virtuemart&amp;page=shop.tos" title="J'accepte les conditions d'utilisation"> (Conditions d'utilisation) </a></noscript>
    En editant le html via FB, j'enleve les 2 balises <noscript> et, Oh!, le texte apparait bien, dans sa bonne couleur, un peu decale, mais je me contente du mieux. malheureusement, le bonheur est de courte duree, puisque FB ne permet pas de modifier le script definitivement, et heureusement pour nous!

    je consulte quelques fichiers html (genre des centaines), quelques dizaines de milliers de lignes, et la, je retrouve mon script, sans balise, avec le chiffre "1" devant (donc, "active" ?) ; de toutes les facons, j'ai aussi essaye avec "0", sans succes.

    quelqu'un aurait'il une idee pour resoudre ce probleme...."basique"

    merci a vous!

    photo ?

    photo! (voir miniatures attachees, ci-dessous)

    Ah? oui, j'oubliais : "aidez-moi! c'est urgent!"
    Fichiers joints
    Dernière édition par PATSXM971 à 25/03/2009, 13h05
    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
    http://virtuemart.fr


  • #2
    Tu veux rajouter "J'accepte les conditions d'utilisation" après la case à cocher?
    Avec un lien vers les CGV?

    Commentaire


    • #3
      Envoyé par JypX Voir le message
      Tu veux rajouter "J'accepte les conditions d'utilisation" après la case à cocher?
      Avec un lien vers les CGV?
      regarde sur le snapshot en bas de mon post. tu verras que la mention "accepter les conditions generales de vente" manque a cote de la petite etoile. qui plus est, elle existe dans le script (voir citation).

      je te remercie pour ton intervention.
      sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
      http://virtuemart.fr

      Commentaire


      • #4
        Bonjour Pat......je vois que toi aussi tu te prend la tête avec ce satané Agreed.

        j'étais moi aussi dessus hier soir et ce satané module semble intouchable........


        j'ai trouvé et modifié le AGREED dans:

        component/Com_virtuemart/themes/default/index.php

        J'ai modifié le script pour que le champ ressemble aux autres champs du formulaire etc....
        j'ai ajouté du texte à coté de * entre les balises strong..........rien n'apparait sur le site

        un truc de fous, rien ne semble marcher sur ce satané agreed....

        voilà la partie concernée non modifiée

        <fieldset>
        <legend class="sectiontableheader">S'inscrire</legend>
        <div id="agreed_div" class="formLabel "><label for="agreed_field"><script type="text/javascript">//<![CDATA[
        document.write('<label for="agreed_field">J\'accepte les conditions d\'utilisation</label><a href="javascript:void window.open(\'http://localhost/******/index2.php?option=com_virtuemart&page=shop.tos&pop =1\', \'win2\', \'status=no,toolbar=no,scrollbars=yes,titlebar=no, menubar=no,resizable=yes,width=640,height=480,dire ctories=no,location=no\');">');
        document.write(' (Conditions d'utilisation)</a>');
        //]]></script>
        <noscript>
        <label for="agreed_field">J'accepte les conditions d'utilisation</label>
        <a target="_blank" href="http://localhost/bijoux1/index.php?option=com_virtuemart&amp;page=shop.tos" title="J'accepte les conditions d'utilisation">
        (Conditions d'utilisation)
        </a></noscript></label><strong>* </strong> </div>
        <div class="formField" id="agreed_input">
        <input type="checkbox" id="agreed_field" name="agreed" value="1" class="inputbox" /><br /></div>
        <br style="clear:both;" /></fieldset>


        Le truc de fous c'est que les modifs fonctionnent si on les fait e,n direct avec FireBug
        Dernière édition par gregmour à 25/03/2009, 09h36

        Commentaire


        • #5
          J'ai la même chose chez moi et ça marche. As tu essayé de regarder du côté des css ?
          --
          Sylvain
          cadeau anniversaire - Idées cadeaux

          Commentaire


          • #6
            je ne suis pas expert, mais de toute evidence le probleme vient de notre charmante langue car ce agreed est impeccable quand on installe Joomla et Virtuemart en Anglais.

            Commentaire


            • #7
              Envoyé par djimaestro Voir le message
              J'ai la même chose chez moi et ça marche. As tu essayé de regarder du côté des css ?
              mince alors, en effet je viens de voir ton site et toi c'est nickel..........je sens que ton site va se faire firebugguer.........

              Commentaire


              • #8
                lol Régale toi
                --
                Sylvain
                cadeau anniversaire - Idées cadeaux

                Commentaire


                • #9
                  Envoyé par gregmour Voir le message
                  Bonjour Pat......je vois que toi aussi tu te prend la tête avec ce satané Agreed.

                  component/Com_virtuemart/themes/default/index.php
                  Tu te prends la tete? non, moi je m'eclate comme un petit fou...

                  c'est etrange, je n'ai pas de fichier index.php a l'indresse indiquee....
                  j'ai bien un theme.php & theme.config.php ; vm a du me mettre a......l'index!

                  merci pour ton post. on va bien finir par trouver!
                  sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                  http://virtuemart.fr

                  Commentaire


                  • #10
                    Envoyé par djimaestro Voir le message
                    J'ai la même chose chez moi et ça marche. As tu essayé de regarder du côté des css ?
                    pour les css, ca a l'air d'aller. je pense plutot a un probleme html....

                    thk u Dj (non, c'est pas un code a inserer quelque part).
                    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                    http://virtuemart.fr

                    Commentaire


                    • #11
                      Envoyé par djimaestro Voir le message
                      J'ai la même chose chez moi et ça marche. As tu essayé de regarder du côté des css ?
                      voilà mon css pour mon theme virtuemart par defaut

                      General Form Styling
                      */
                      .formLabel {
                      float:left;
                      width:30%;
                      text-align:right;
                      font-weight: bold;
                      margin: 2px;
                      white-space: nowrap;
                      clear: left;
                      vertical-align: middle;
                      margin-top: 8px;
                      }

                      #agreed_div {
                      white-space: normal;
                      }

                      .formField {
                      float:left;
                      width:60%;
                      margin: 2px;
                      vertical-align: middle;
                      margin-top: 8px;

                      }
                      .missing {
                      color:red;
                      font-weight:bold;
                      }

                      Commentaire


                      • #12
                        C'est la faute de l'apostrophe dans

                        Code:
                        conditions d'utilisation
                        Soit modifier le texte dans les fichiers de langues (conditions generales de vente ?), soit corriger le bout de code pour ne pas avoir ce probleme, et là je vous laisse creuser =]

                        P.

                        Commentaire


                        • #13
                          Envoyé par djimaestro Voir le message
                          lol Régale toi
                          tu penses que les balises <noscript> sont ecrites comme telles dans le script ou peuvent-elles etre le resultat, sur FB, d'une autorisation, symbolisee par un chiffre dans le fichier html?

                          si tu arrives a comprendre ce que je te demande,
                          sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                          http://virtuemart.fr

                          Commentaire


                          • #14
                            Envoyé par puzzleGd Voir le message
                            C'est la faute de l'apostrophe dans

                            Code:
                            conditions d'utilisation
                            Soit modifier le texte dans les fichiers de langues (conditions generales de vente ?), soit corriger le bout de code pour ne pas avoir ce probleme, et là je vous laisse creuser =]

                            P.

                            pourtant l'apostrophe existe dans "j'accepte"...

                            Commentaire


                            • #15
                              Envoyé par puzzleGd Voir le message
                              C'est la faute de l'apostrophe dans

                              Code:
                              conditions d'utilisation
                              Soit modifier le texte dans les fichiers de langues (conditions generales de vente ?), soit corriger le bout de code pour ne pas avoir ce probleme, et là je vous laisse creuser =]

                              P.
                              merci de ton intervention puzzleGd ; je n'ai pourtant pas de probleme avec les autres apostrophes dans le fichier french ; j'y ai meme traduit des phrases non traduites, avec apostrophe, en inserant (\) devant l'apostrophe, ce qui resoud le pb.
                              j'y ai meme place du texte en anglais, manquant sur le panneau d'admin vm et pa ni pon pwoblem

                              ca va venir, je le sens
                              sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                              http://virtuemart.fr

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X