Virtuemart passage Sherlocks600 linux à Sherlocks600 windows2003

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Virtuemart passage Sherlocks600 linux à Sherlocks600 windows2003

    Bonjour,
    Sur mon site de test installé sur un serveur OVH (donc linux) j'ai installé ma boutique virtuemart 1.1.0 avec sherlocks 600 linux et le plugin SIPS d'Alatak (merci au passage ) et tout fonctionne correctement les transactions arrive sur le serveur de démo du LCL et tout se passe bien.
    Lundi je dois placer la boutique sur un serveur windows 2003 pour son passage en prod. J'ai le plugin sherlocks 600 pour windows 2003 (les executables doivent déjà être sur le serveur puisque qu'une autre boutique est déjà en prod sur ce serveur).
    J'ai vu dans l'interface d'amin que le module de paiement demande sa version de sherlocks 500 ou 600 et linux ou windows, il me suffira donc de changer ce paramettre, d'indiquer l'emplacement des executables request et response et c'est tout?

    J'essaye d'anticiper les pb que je pourrais rencontrer lundi car je voudrais passer en prod le jour même avec la certif de la première boutique ou un autre certif, j'appellerai ATOS à ce moment.

    Merci de vos conseils

  • #2
    Personne ne sait si la seule différence entre sherlocks 600 linux et sherlocks 600 windows se situe dans les executables request et response et le parametrage du plugin SIPS d'Alatak (version sherlocks et emplacements exe) ?

    Commentaire


    • #3
      ba la comme ca le truc qui me vient s'est l'exécution des scripts cgi : est-ce installé sur ton server windows ?

      l'idéal quand meme c'est que le server de test soit identique au server de prod, sinon tu cours vers des problemes inutiles !

      Commentaire


      • #4
        Je n'ai pas de serveur windows 2003 pour faire mes tests, et pour l'execution des scripts je pense que c'est bon, il y a déjà une boutique en production sur le serveur qui utilise aussi sherlocks.

        Commentaire


        • #5
          bonjour

          Lundi je dois placer la boutique sur un serveur windows 2003 pour son passage en prod. J'ai le plugin sherlocks 600 pour windows 2003 (les executables doivent déjà être sur le serveur puisque qu'une autre boutique est déjà en prod sur ce serveur).
          J'ai vu dans l'interface d'amin que le module de paiement demande sa version de sherlocks 500 ou 600 et linux ou windows, il me suffira donc de changer ce paramettre, d'indiquer l'emplacement des executables request et response et c'est tout?
          Normalement c'est l'unique paramètre que tu dois changer.
          Je ne fais pas beaucoup d'installation sur serveur windows . J'ai du en faire 2 en tout ... si tu as des problèmes , affiche les messages d'erreur , et je verrais si je peux t'aider.
          alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

          Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

          Commentaire


          • #6
            Merci de cette réponse,

            rapidement, en changeant les parametre comme cité au dessus j'ai :

            Erreur CGI
            L'application CGI sp�cifi�e n'a pas renvoy� le jeu complet d'en-t�tes HTTP.

            puisque sherlocks ne se lance pas je regarde plutôt du côté de la config de la méthode de paiement. J'ai déjà vu que je m'étais trompé sur la syntaxe de l'URL j'avais laissé un "\" de windows à la fin alors qu'un "/" est demandé.

            Je suis maintenant sûr des mes URL je les ai testée avec le call_request.php fourni en démo avec le kit SIPS et ça marche bien.

            mais toujours la même erreur.
            Dernière édition par nervmaster à 25/05/2009, 12h40

            Commentaire


            • #7
              pas de pistes?

              Commentaire


              • #8
                bonjour

                Erreur CGI
                L'application CGI sp�cifi�e n'a pas renvoy� le jeu complet d'en-t�tes HTTP.
                Estce que tues sur de l'adresse CGI que tu as donnée?
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  sûr de l'adresse oui mais pas de la syntaxe :

                  C:\\*****\\payment\\bin/

                  et il apparait comme :

                  C:\*****\payment\bin/ dans l'admin du module de paiement, est-ce correct?

                  voici l'adresse qui fonctionne avec le test call_request.php :

                  C:\\*****\\payment\\bin\\request.exe
                  Dernière édition par nervmaster à 25/05/2009, 14h42

                  Commentaire


                  • #10
                    bonjour

                    C:\\*****\\payment\\bin\\request.exe
                    si cette adresse marche,
                    alors
                    essaye ça:
                    C:\\*****\\payment\\bin\
                    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                    Commentaire


                    • #11
                      Merci ça évolue !!!

                      c'était bien ça, maintenant j'ai la page "merci pour votre commande" sur fond blanc....

                      je continue a chercher mais y'a du progrès !

                      ps : par contre depuis que j'ai mis le \ à la fin quand je vais dans l'admin module de paiement ça s'affiche sans template...

                      "Parse error: syntax error, unexpected T_STRING in D:\**************\administrator\components\com_vir tuemart\classes\payment\ps_sips.cfg.php on line 5

                      ça décale tout dans le fichier ps_sips.cfg.php, ça revient dans l'odre en mettant un 2eme \ mais du coup l'erreur d'en tête HTML revient à la commande.....
                      Dernière édition par nervmaster à 25/05/2009, 15h19

                      Commentaire


                      • #12
                        bonjour,

                        par contre depuis que j'ai mis le \ à la fin quand je vais dans l'admin module de paiement ça s'affiche sans template...

                        "Parse error: syntax error, unexpected T_STRING in D:\**************\administrator\components\com_vir tuemart\classes\payment\ps_sips.cfg.php on line 5

                        ça décale tout dans le fichier ps_sips.cfg.php, ça revient dans l'odre en mettant un 2eme \ mais du coup l'erreur d'en tête HTML revient à la commande.....
                        Oui, tu as raison, il faut 2 fois \ .



                        Si tu as une page blanche, tu as peut oublié de configurer le paramètre: Moyen de paiement
                        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                        Commentaire


                        • #13
                          C'est bizarre il n'arrive plus à la page sans template "merci pour votre commande" si je rajoute le 2eme \, il me remet

                          Erreur CGI
                          L'application CGI sp�cifi�e n'a pas renvoy� le jeu complet d'en-t�tes HTTP.

                          Pour les moyens de paiement j'ai essayé avec les liste CB,VISA,MC et en laissant vide aussi...
                          Dernière édition par nervmaster à 25/05/2009, 20h24

                          Commentaire


                          • #14
                            Bon je règlerai ce pb plus tard, en attendant j'ai mis le site sur un serv linux et ça marche sans pb.

                            Par contre pour le passage en prod je me retrouve avec une clé de décryptage mais je n,e sais pas quoi en faire?

                            j'ai bien le certificat a changer dans le plugin d'Alatak mais que dois je faire de cette clé?
                            Dernière édition par nervmaster à 26/05/2009, 16h39

                            Commentaire


                            • #15
                              Est ce la même que celle demandée dans virtuemart/configuration/sécurité ?

                              Pourtant la clé qu'on m'a donnée avec la cerif commerçant c'est pour décrypter le certificat pas les numéros de cartes bleues comme dans la config de virtuemart.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X