virtuemart + cybermut 3.0 parse error

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • virtuemart + cybermut 3.0 parse error

    J'essaye désespérément d'installer le cybertmut version 3.0.

    Après plusieurs jour d'essais avec les différentes version cmcic de virtuamart sans succès (problème d'erreur dans cgi2).
    Je me suis décidé de tout réinstallé avec la version de ALATAK.

    Et puis je n'arrive mémé pas au site sécurisé du cic

    suite à la confirmation de commande s'obtient :

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez..../al....../www/administrator/components/com_virtuemart/html/cmcic3.0/CMCIC_Tpe.inc.php on line 36

    1) Ce fichier CMCIC_Tpe.inc.php, doit-il étre renseigné ?
    2) avec quelle syntaxe (je nul en php).

    Je suppose que se fichier evite de passer par un hmac-sha1.

    3) Pour la suite j'ais déjà envoyé au cic le lien direct vers
    http://www.monsite.com/ad...cmcic_cgi2.php.
    suis obliger d'utiliser le cgi2 sous www ?

    de l'aide ou je crack

    Merci d'avance
    ps: merci pour vos encouragements téléphoniques.
    Dernière édition par laclolo à 05/06/2009, 22h38

  • #2
    Un peu plus de précision SVP!

    Salut,

    Peux-tu nous donner plus de précision ?

    Quelle version de Joomla (v1.5.11 ) ?
    Quelle version de Virtuemart ( v1.1.3 ) ?

    Et surtout, as-tu utilisé le bon fichier sur le site ALATAK ?
    C'est à dire la cmcic_V30_J15_VM11_v2.0

    Pour le chemin du CGI2, tu dois placer manuellement celui-ci sur la racine de ton site, toutefois certains hébergeurs semblent exiger que celui-ci soit dans un répertoire bien précis. De plus, lorsque tu envois ta demande au prestataire qui s'occupe du paramétrage pour ta banque, il peut y avoir un délai conséquent, notamment avec CIC Centrecom.

    Pour le paramétrage du module, tu n'as pas à modifier manuellement les fichiers, dans la version v3 de CIMCIC, tu dois utiliser l'onglet "paramétrage" de ton module. il te fait posséder le fichier du TPE que la banque a dû te transmettre, c'est impératif. A ce moment là, tu suis à la lettre le tutorial de ALATAK.

    Si tu n'arrives même pas à accéder au module ou au paramétrage, c'est que tu as eu un problème de transfert de fichiers avec ton Client FTP, çà arrive avec Filezilla. Envoi tes fichiers en binaire au lieu de automatique.

    Si tu as bien installé et renseigné le module, et que tu as bien paramétré le serveur de TEST, le CGI2 produit une erreur au niveau de la réponse de ton site marchant, mais la transaction doit quand même être enregistrée dans l'interface SSL de ta banque. Il te reste juste à valider le paiement manuellement sur cette même interface. Ceci dit, ce n'est pas très clean, car le client voit un message d'erreur, après la validation de son paiement, du coup çà met le trouble. Il vaut mieux que le chemin du CGI2 soit valide avant de passer le site en production.

    Une petite dernière pour la route, ton site n'est-il pas hébergé chez CELEONET par hasard ?

    J'espère que cela t'aura éclairé un peu.
    L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

    Ne réponds pas aux MPs. Exposez votre problème sur le forum !

    Commentaire


    • #3
      les précisions que tu me demande

      Salut,

      Et merci pour ta réponse.

      Ma version joomla 1.5.10, virtuemart 1.1.0

      Le fichier alatak utilisé est bien le bon.
      La procédure parfaitement suivi.

      Le fichier tpe que tu parle est bien le fichier qui conprend

      VERSION 1 4xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      HMAC-SHA1
      #
      76xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxd

      le code à renseigner est celui derrière VERSION 1 ?

      Malgré cela toujours le même défaut:

      Nous avons bien enregistré votre commande.
      Elle sera valider après avoir payé.
      Pour payer, nous allons sur le serveur de notre banque partenaire le CIC qui enregistrera votre transaction en toute sécurité.
      
      Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.167/alinstitx/www/administrator/components/com_virtuemart/html/cmcic3.0/CMCIC_Tpe.inc.php on line 36


      Quand j'ouvre le fichier CMCIC_Tpe.inc.php voila ce que l'on trouve.




      Ce fichier doit certainement générer le HMAC-SHA1 que l'on connait sur les autre kit que jais essayé.

      Que faire renseigner ce fichier au endroit indiqué ? et avec quelle syntaxe ?

      J'ai essayé les syntaxes html ( public $sVersion = "3.0"; // Version du TPE - TPE Version (Ex : 3.0)
      pas pas de succés

      Epuisant

      Merci à bientot

      Commentaire


      • #4
        Oui, le Fichier TPE dont je te parle est celui que t'a transmis la banque avec le kit. Il est nommé comme suit : numerotpe.key et contient effectivement :
        VERSION 1 4xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
        HMAC-SHA1
        #
        76xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxd
        Il faut bien mettre les 40 caractères entre l'espace qui suit VERSION 1 et HMAC

        Non, il n'y a rien a saisir manuellement dans le fichier : CMCIC_Tpe.inc.php

        Ce fichier est effectivement là pour éviter de générer les clefs avec le KIT de Cybermut.
        Il va récupérer les variables saisies dans les champs de paramétrages du module et les appliquer dans les différentes fonctions. En théorie, c'est même bien plus simple qu'avant .

        Ton message d'erreur semble dire qu'il y a une erreur dans la saisie d'une variable ou dans la version de ton TPE (ce qui revient au même en fait). Comme tu me confirmes que les variables sont correctement renseignées, ce ne peut être qu'un problème sur la variable $sVersion, hors, nous ne renseignons pas directement cette variable, donc je pense que tu es dans le même cas que dans ce post :

        http://forum.joomla.fr/showthread.php?t=89205&page=2

        C'est bizare, à part un problème de chemin de CGI, à cause de l'hébergeur, je n'ai jamais eu d'autre souci avec le module de ALATAK. à suivre. Je continue de chercher de mon côté. Mais, je pense que la balle est du côté de la CIC.
        L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

        Ne réponds pas aux MPs. Exposez votre problème sur le forum !

        Commentaire


        • #5
          Si tu accèdes directement à http://www.monsite.fr/cmcic_cgi2.php , tu dois obtenir ceci :

          version=2 cdr=1 numeroTPE*****3.0***************
          J'utilise bien le cmcic_V30_J15_VM11_v2.0, avec VM 1.1.3+J1.5.11 et le site est hébergé chez CELEONET en TURBO (PHP5) et tout marche parfaitement, sans aucune modification de quoi que ce soit. Je dois certainement avoir de la chance.

          Je peux vous affirmer qu'il n'y a aucune erreur se syntaxe dans les scripts de ALATAK. Par contre comme tu as apparemment fais de multiples essais avec différentes versions as-tu bien supprimé manuellement les traces des anciennes versions avant d'installer la dernière ? Vérifie que tu n'es pas victime d'une perte de sauts de lignes lors du transfert des fichiers vers ton FTP. Ca arrive assez souvent avec Filezilla en automatique. As-tu passé les droits sur le fichier cmcic_cgi2.php en 755 ?

          Penses aussi à vérifier que ton hébergement est bien en PHP5, car ton erreur de parse peut venir du fait que tu sois en PHP4, et ce module de paiement ne marche pas en PHP4. En effet, "var" en PHP4 correspond à "public" en PHP5. Alors si tel est ton cas, mieux vaut passer en PHP5 que d'adapter le script. Pour passer en PHP5, cela dépend de ton hébergeur, suit, tu dois renseigner le .htaccess, soit tu te rends dans l'interface de contrôle de ton hébergement et tu y trouveras, soit une case à cocher ou autre pour passer en PHP5.

          Je vais continuer de chercher, mais je n'arrive pas à reproduire votre bug, sur mon site de test (sauf en passant en PHP4).
          Dernière édition par cybergaby à 08/06/2009, 20h42 Raison: faute de frappe
          L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

          Ne réponds pas aux MPs. Exposez votre problème sur le forum !

          Commentaire


          • #6
            Php4

            J'ai trouver mon probléme,
            je suis en php4 au lieux de php5.

            j'ai modifier le fichier CMCIC_Tpe.inc.php en mettant ver au lieu de public et ca marche.

            merci pour tout

            je vais essayé avec php5 aprés

            Commentaire


            • #7
              Tu devrais passer ton hébergement en PHP5 rapidement au lieu de modifier le code source, car tu vas avoir rapidement des problèmes avec les futures évolutions de joomla et certains modules.

              N'oublie pas de passer ton post en [REGLE].

              Cordialement.
              L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

              Ne réponds pas aux MPs. Exposez votre problème sur le forum !

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X