Joomladay francophone 2018 à Paris 18 et 19 mai

Agora, problème utilisateur

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Agora, problème utilisateur

    Bonjour,
    Je viens d’installer Agora sur mon hébergeur et j’ai un message d’erreur lorsque je clique sur Utilisateurs dans le panneau de configuration d’Agora :

    Parse error: syntax error, unexpected '(', expecting '}' in /homepages/37/d146481882/htdocs/joomlatest/components/com_agora/model/user.php on line 280

    J’ai créé 3 groupes, 2 forums et 2 sous-forums, j’ai fait un lien dans le top menu.
    J’ai le même message lorsque je clique sur Forum dans le top menu en tant que visiteur.
    Quelqu’un pourrait me dire ce que j’ai oublié.

    Merci
    Dernière édition par dominic_75 à 27/07/2009, 08h39
    Quelques infos :
    Hébergé chez 1an1, Php 4.4.9 ou 5.2.10, Joomla V1.5.13 avec Template Made your Web.
    Peu de connaissance Html. Autodidacte

    Dominic

  • #2
    Problème agora utilisateur n°2

    Salut salut,
    Désolé Dominique je ne peut t'aider car j'ai exactement le même problème et je galère depuis deux jours.
    Moi quand je vais dans utilisateur depuis l'administration ou encore directement sur le forum en Frontend j'obtient:
    Parse error: syntax error, unexpected '(', expecting '}' in /homez.169/aterr/www/Joomla/components/com_agora/model/user.php on line 280

    Et lors de l'installation un problème avec la décompression d'un morceau du composants:
    Warning: zip_entry_read() [function.zip-entry-read]: The bytes parameter must greater then zero in /homez.169/aterr/www/Joomla/libraries/joomla/filesystem/archive/zip.php on line 238

    J'ai désinstallé réinstallé plusieurs fois, tenté les versions antérieure, Kunena, rien de marche...

    J'ai écumé les forums, et lut (en anglais alors je suis pas certain) que cela viendrai d'un problème entre PHP 5 (Agora) et PHP 4 (serveur) or mon serveur (OVH) est en php5, donc cela ne marche pour moi... J'ai aussi tenter de mettre PHP 5 en PHP par défaut sur mon serveur mais cela ne change rien.

    Aidez nous s'il vous plait, j'aime bien bidouiller mais la je cale.

    Info système:
    Joomla 1.5
    OVH Start 5G

    Merci d'avance tout le monde
    Dernière édition par Toutoufoufou à 25/07/2009, 08h55

    Commentaire


    • #3
      Idem mais peut être un Solution

      Salut Toutoufou,
      Même si tu ne m'aide pas directement, ca me rassure de ne pas être seul à avoir ce problème.
      Moi aussi j'ai visité les forums et j'ai cru comprendre qu'effectivement il s'agit bien d'un problème de Php4 sur l'hébergeur, mais moi aussi sur 1and1 je suis en Php5, enfin c'est ce que j'ai compris car c'est marqué dans mon admin 1and1 de Mysql : Mysql5 ?
      par contre je ne sais pas quelle version, ni si Mysql 5 veut bien dire Php 5 ?
      Je ne sais pas ou trouver cette info.

      Par contre j'ai trouvé ca, à 3 heure du mat cette nuit, sur www.jvitals.com :

      Hi, Have just installed the forum and I get the following error when trying to sync users

      Parse error: syntax error, unexpected '(', expecting '}' in /public_html/tiger-woods-ps3/components/com_agora/model/user.php on line 280

      I have searched through the forums here for this topic but am unable to find one similar.
      I have correctly CHMOD cache file etc.

      I am using a fresh install of Joomla Version 1.5.12 - Cache on


      Any help greatly appreciated.

      Will leave comment on joomla.org about this component once I have it up and running.

      Thanks for you help

      [SOLVED] - Hi Gang, I managed to suss this one out. It was due to my PHP not being php5. To ensure you are using php5 you can do the following.
      You need to specify the following in a .htaccess file:-

      SetEnv DEFAULT_PHP_VERSION 5

      This means that any php file ending in .php will be executed as PHP5 rather that PHP4.

      If this file doesn't exist, you can create it using a normal text editor. It should be created on a per-site basis and uploaded into the folder containing your script (or simply into the public_html folder if you want it to affect site-wide).

      Some PHP 4 scripts require short_open_tag to be enabled, this is off by default in php 5.

      To enable this in php 5 add the following to your php5.ini file:-

      short_open_tag = 1




      I hope this helps others with a similar problem - regards
      lien direct : http://jvitals.com/index.php?option=...mid=105#p41060

      Apparemment il faudrait ajouter un fichier dans le htacces.file ?
      mais comme je n'y connait pas grand chose en Htlm/php et encore moins en anglais.
      Si quelqu'un pouvait nous éclairer car la solution est peut être là.

      Merci.
      a plus
      Quelques infos :
      Hébergé chez 1an1, Php 4.4.9 ou 5.2.10, Joomla V1.5.13 avec Template Made your Web.
      Peu de connaissance Html. Autodidacte

      Dominic

      Commentaire


      • #4
        rerobleme utilisateur agora

        Bon bon bon,
        moi je l'avais déja vu ce post, j'ai modifié mon .htaccess, mais rien n'y fait, cela ne marche toujours pas.
        Il y a un problème de fond car même avec les anciennes versions, et Kunena (autre forum Joomla) cela ne marche pas.
        J'ai remarqué aussi que ma partie lien web m'affiche elle aussi le même message d'erreur...

        La je tente de tout reprendre a partir d'une ancienne sauvegarde, je croise les doigts...

        Si quelqu'un a la solution cela m'interesse, car c'est pas sur que je soit sortit des problèmes...

        ... Nouveau rebondissement je m'appercois que je m'était planté et que mon .htaccess je l'avais mal écrit (.htacces), on va voir si ca marche, quand j'aurais tout réinstallé...
        Dernière édition par Toutoufoufou à 25/07/2009, 12h26

        Commentaire


        • #5
          Je viens de voir mon probleme avec un connaisseur en code et il a trouvé l'astuce, il semblerait qu'il faille remplacer les " de la requête de la ligne 280 par des quote : '
          ça donne ceci:

          $this->db->setQuery('SELECT name'.
          ' FROM {$this->table} AS u'.
          ' INNER JOIN #__users AS j'.
          ' ON u.jos_id = j.id'.
          ' WHERE LOWER(TRIM(j.username)) = LOWER({$this->db->Quote(trim($username))})');

          ET ça MARCHE !
          @+
          Quelques infos :
          Hébergé chez 1an1, Php 4.4.9 ou 5.2.10, Joomla V1.5.13 avec Template Made your Web.
          Peu de connaissance Html. Autodidacte

          Dominic

          Commentaire


          • #6
            Merci !
            Moi j'ai tout réinstallé avec une ancienne version et le truc pour forcer le PHP5 et ca marche aussi.

            A + et bon site

            Commentaire


            • #7
              Re belotte

              Envoyé par Toutoufoufou Voir le message
              Merci !
              Moi j'ai tout réinstallé avec une ancienne version et le truc pour forcer le PHP5 et ca marche aussi.

              A + et bon site
              Re Salut,
              mon astuce ne marche que pour l'erreur Utilisateur car en postant un message dans le forum je retrouve une autre erreur du meme type : Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/37/d146481882/htdocs/joomlatest/components/com_agora/helpers/emailprocessor.php on line 5

              donc je pense qu il faut faire comme dans le poste en anglais, mais je sais pas faire tu peux m'expliquer car je pense que c'est ca que tu appelles le truc pour forcer php5.


              Au fait j'ai vérifié je suis en php 4 sur 1and1

              a plus
              Quelques infos :
              Hébergé chez 1an1, Php 4.4.9 ou 5.2.10, Joomla V1.5.13 avec Template Made your Web.
              Peu de connaissance Html. Autodidacte

              Dominic

              Commentaire


              • #8
                Moi ****l

                Salut dominic,
                c'est nul pour toi ca... Si tu est en PHP 4 et que ton hébergement ne prend pas en compte le PHP 5 ca va peut être être coton...
                Moi j'avais demander au support OVH et ils m'ont dit
                Pour activer le php5 il vous faut bien mettre la ligne "SetEnv PHP_VER 5" dans un fichier .htaccess qui se trouve à la racine de votre site.
                En plus je l'avais fait mais le fichier était mal nommé, c'était comme d'habitude tout bête...

                Bonne chance

                http://www.aterr.fr/

                Commentaire


                • #9
                  Php5 avec 1 and 1

                  Envoyé par dominic_75 Voir le message
                  ... le truc pour forcer php5.
                  Au fait j'ai vérifié je suis en php 4 sur 1and1
                  a plus
                  Pour passer en php 5 avec 1 and 1 :
                  http://faq.1and1.fr/scripts/php/5.html

                  Lit aussi, eventuellment, les infos concernant MySql 5 :
                  http://faq.1and1.fr/scripts/mysql/13.html
                  www.horizonweb.fr

                  Commentaire


                  • #10
                    Bingo ca marche

                    Envoyé par Patrick IZZO Voir le message
                    Pour passer en php 5 avec 1 and 1 :
                    http://faq.1and1.fr/scripts/php/5.html

                    Lit aussi, eventuellment, les infos concernant MySql 5 :
                    http://faq.1and1.fr/scripts/mysql/13.html
                    Bonsoir,
                    je ne t'ai pas répondu plus tot car j'étais en train de tout supprimer pour réinstaller, j'en ai profitté pour installer la 1.5.13.
                    Merci pour tes liens car j'avais pas trouvé sur 1and1.
                    j'ai mis la formule magique : AddType x-mapp-php5 .php dans mon .htacces et ca marche.
                    Mille mercis à toi.

                    @plus
                    Quelques infos :
                    Hébergé chez 1an1, Php 4.4.9 ou 5.2.10, Joomla V1.5.13 avec Template Made your Web.
                    Peu de connaissance Html. Autodidacte

                    Dominic

                    Commentaire


                    • #11

                      Bonjour tout le monde je suis sur le meme probleme que vous mais je suis un jeune debutant et je galère.
                      J ai un hebergement ovh et joomla 1.5.14 j' ai installer agora 3 tout ****l j ai bien le menu dans admin j ai creer le lien dans le menu et je tombe sur la meme erreur ligne 280 donc j ai vérifier.
                      J ai bien le dossier de cache j ai alors chercher le fameu fichier .htaccess pour coller la ligne donner pour ovh mais je n'ai trouver qu'un fichier htaccess.txt

                      Je voudrais savoir si c le bon et ou je dois coller cette fameuse ligne

                      Voici un copier coller de mon fichier htaccess.txt

                      ##
                      # @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
                      # @package Joomla
                      # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
                      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
                      # Joomla! is Free Software
                      ##


                      ################################################## ###
                      # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
                      #
                      # The line just below this section: 'Options +FollowSymLinks' may cause problems
                      # with some server configurations. It is required for use of mod_rewrite, but may already
                      # be set by your server administrator in a way that dissallows changing it in
                      # your .htaccess file. If using it causes your server to error out, comment it out (add # to
                      # beginning of line), reload your site in your browser and test your sef url's. If they work,
                      # it has been set by your server administrator and you do not need it set here.
                      #
                      ################################################## ###

                      ## Can be commented out if causes errors, see notes above.
                      Options +FollowSymLinks

                      #
                      # mod_rewrite in use

                      RewriteEngine On

                      ########## Begin - Rewrite rules to block out some common exploits
                      ## If you experience problems on your site block out the operations listed below
                      ## This attempts to block the most common type of exploit `attempts` to Joomla!
                      #
                      # Block out any script trying to set a mosConfig value through the URL
                      RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
                      # Block out any script trying to base64_encode crap to send via URL
                      RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
                      # Block out any script that includes a <script> tag in URL
                      RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
                      # Block out any script trying to set a PHP GLOBALS variable via URL
                      RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
                      # Block out any script trying to modify a _REQUEST variable via URL
                      RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
                      # Send all blocked request to homepage with 403 Forbidden error!
                      RewriteRule ^(.*)$ index.php [F,L]
                      #
                      ########## End - Rewrite rules to block out some common exploits

                      # Uncomment following line if your webserver's URL
                      # is not directly related to physical file paths.
                      # Update Your Joomla! Directory (just / for root)

                      # RewriteBase /


                      ########## Begin - Joomla! core SEF Section
                      #
                      RewriteCond %{REQUEST_FILENAME} !-f
                      RewriteCond %{REQUEST_FILENAME} !-d
                      RewriteCond %{REQUEST_URI} !^/index.php
                      RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
                      RewriteRule (.*) index.php
                      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
                      #
                      ########## End - Joomla! core SEF Section


                      Merci d'avance pour votre aide
                      Dernière édition par math38 à 20/10/2009, 11h12

                      Commentaire


                      • #12
                        Pour le fichier htacess :
                        Tu prends ton fichier htacess.txt tu l'ouvre et tu colle la ligne voulu.
                        Ensuite tu enregistre ton fichier en : ".htacess"
                        Si tu n'arrive pas à le renomer ainsi tu peux le faire directement à la racine de ton site.

                        Autrement pour OVH il me semble que j'ai vu des choses, va sur la partie SEF / URL Rewriting

                        Tu trouveras surement ton bohneur.
                        Site de mon club : http://www.badminton-sombernon.fr/ et mon village : http://www.sombernon.fr/

                        aesecure, optimisation et sécurisation de vos sites : http://www.aesecure.com/fr/
                        bgMax, la gestion facile de l'image de fond: (http://lomart.fr/)
                        AllEvents, la gestion d'événements: (http://www.allevents3.fr/)

                        Commentaire


                        • #13
                          le probleme est sans fin

                          Bonjour
                          ce problème récurant est frustrant....
                          Je ne comprends pas ce qu'il faut changer. Pour moi le fichier htacss.txt (à la racine du site) n'a pas 280 lignes, je suis donc un peu ennuyer pour faire cette petite modif. Donc si quelqu'un qui a réussi peut me donner une sorte de tuto pour faire fonctionner Agora

                          Merci beaucoup

                          Commentaire


                          • #14
                            Il y a des éléments de réponse ici pour OVH:
                            http://forum.ovh.com/showthread.php?t=33897&page=2
                            Ecris ton fichier .htaccess et non pas htaccess.txt avec notepad++.
                            Ou bien, écris un fichier htaccess.txt, transfère le par FTP à la racine de ton site et une fois transféré renomme le .htaccess

                            Le problème n'a rien à voir avec Agora comme semble le suggérer le titre ce sujet.
                            Dernière édition par Zakkai à 24/01/2010, 22h35

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X