Problème avec kunena

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème avec kunena

    Bonsoir,

    J'ai un souci avec mon forum Kunena.

    Le site en question : http://www.planete-nextgen.com

    Quand on clique sur le bouton profil ou sur un profil d'utilisateur on tombe sur une page d'erreur.

    Comment corriger sa ?

    De plus, quand on écrit un message, les smiley ne marchent pas ....
    Dernière édition par ede42 à 09/12/2010, 10h52
    Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

  • #2
    Bonjour,
    Quand on clique sur le bouton profil ou sur un profil d'utilisateur on tombe sur une page d'erreur.
    Problème d'URL rewriting ... Tu utilises un logiciel style JoomSEF ou sh404SEF ? Tu as activé l'option dans la config Kunena ?

    De plus, quand on écrit un message, les smiley ne marchent pas ...
    Et le + dans le template non plus... Ça sent la version 1.6 sans l'Upgrade Mootools activé... Version de Kunena ? De Joomla ? Le plugin MtUpgrade est activé ?
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Bonjour Gran Schtroumpf,

      Alors 1 :
      Oui j'ai mis Sh404SEF avec l'option d'activé dans Kunena (Search Engine Friendly URLs à oui).
      Si tu veux, je peux poster mon fichier com_kunena.php dans sh404sef ?

      J'ai aussi Utiliser le module Apachemod_rewrite a oui et URLs explicites (SEF) sur oui.

      2. Je viens à l'instant d'activé le plugin MtUpgrade mais sa n'a rien changé.

      Il me semble avoir vu quenque part dans Kunena un endroit ou on spécifie la version de Mootools mais je n'arrive pas à retrouver ou
      Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

      Commentaire


      • #4
        Bonjour,
        Si tu veux, je peux poster mon fichier com_kunena.php dans sh404sef ?
        Il est sans doute en cause, donc je désactiverais plutôt la prise en charge de kunena par sh404SEF, en principe la réécriture de Kunena suffit.

        Il y a deux mootools dans ta page : un de 105Ko qui correspond bien au MtUpgrade et un de 73Ko qui est embarqué par le template (ce qui prouve accessoirement qu'il est écrit avec les pieds : il devrait évoquer le mootools Joomal vie Behavior, pas charger son propre mootools.js...) Trouve la ligne dans l'index.php du template et vire-la (copie de sauvegarde avant et tout ça, hein...).

        Acessoirement, tu n'as pas répondu à ça :
        Version de Kunena ? De Joomla ?
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Salut

          J'ai eu des problèmes d'erreur 404 dans kunena suite à la mise à jour vers la 1.6.
          Ces erreurs étaient dues à l'utilisation du composant error404. Personnellement, la MàJ de error404 a suffit à régler le problème.


          EDIT : Il semble que tu ais des problèmes de boucles redirection. J'ai également eu cela après MàJ. C'était du au fait que Kunena, lors de sa mise à jour, crée lui-même un nouveau menu. Je pense que le doublon avec ton menu déjà existant pose problème.
          Dernière édition par nico.bzh à 09/12/2010, 08h36
          Regarde Bill ... Y'a encore des £ogici€l$ gratuits !!

          Commentaire


          • #6
            Alors ma version de Joomla : 1.5.22
            Version de kunena : 1.6.1

            J'ai enlever le mootools de mon index.php et désactivé le plugin update mootools.

            Les smileys fonctionnent

            Par contre j'ai toujours le problème des liens. Quand je désactive la prise en charge de kunena dans sh404sef je n'ai aucune réécriture qui se fait.

            nico.bzh : je n'ai pas le composant erreur404, j'ai sh404sef.
            Oui kunena créé bien un nouveau menu, mais c'est bizarre quand sa plante je n'arrive même pas sur une page erreur 404 ....
            Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

            Commentaire


            • #7
              Envoyé par ede42 Voir le message
              je n'ai pas le composant erreur404, j'ai sh404sef
              Peu importe le composant, le problème pour moi venait de la gestion des erreurs 404, ce que fait également sh404sef. Non ?

              Envoyé par ede42 Voir le message
              c'est bizarre quand sa plante je n'arrive même pas sur une page erreur 404 ....
              C'est normal, le problème c'est qu'il y a une boucle de redirection ...
              Regarde Bill ... Y'a encore des £ogici€l$ gratuits !!

              Commentaire


              • #8
                Ok donc tu me conseille une mise à jour de SH404 c'est sa ?
                Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

                Commentaire


                • #9
                  Re,
                  Quand je désactive la prise en charge de kunena dans sh404sef je n'ai aucune réécriture qui se fait.
                  Tu es sûr d'avoir pasé le paramètre Kunena "Search Engine Friendly URLs " à oui ?
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    Envoyé par Grand Schtroumpf Voir le message
                    Re,

                    Tu es sûr d'avoir pasé le paramètre Kunena "Search Engine Friendly URLs " à oui ?
                    Oui. J'ai : Paramètres SEO
                    Search Engine Friendly URLs : Oui

                    Dans SH 404SEF j'ai mis : Cliquez sur l'image pour l'afficher en taille normale

Nom : screen.jpg 
Affichages : 1 
Taille : 80,0 Ko 
ID : 1796902

                    Retourne sur mon site, tu verra qu'il n'y a plus de réécriture d'url...
                    Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

                    Commentaire


                    • #11
                      Problème corrigé.

                      Voici comment j'ai fais au cas ou sa peut servir a quelqu'un :
                      dans sh404sef : dans extension de configuration -> kunena, bien vérifier que Insérer nom Kunena est à non.

                      Dans sh404sef configuration -> par composant -> kunena -> il faut que le dernier champ soit vide (moi j'avais mis un nom a mon forum et sa ne marché pas).

                      merci à vous d'avoir pris du temps pour m'aider.
                      Vous êtes passionnés de jeux vidéo ? Venez découvrir notre forum jeux vidéo http://www.planete-nextgen.com garantie sans kikoolol

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X