Bridge Joomla 1.5 => Phenix 5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Bridge Joomla 1.5 => Phenix 5

    Bonjour,
    je viens de finir de le développer (cf titre). Il fonctionne chez moi avec phenix 5.01 et Joomla 1.5.3.

    Il comporte : un plugin et un composant. Il n'y a pas de hack des fichiers de joomla.

    Je me suis inspiré (très fortement) du très bon rokbridge (forum PHPBB) pour coder le plugin.

    J'aimerais avoir vos remarques, suggestions.

    Merci et Enjoy.
    Fichiers joints

  • #2
    Bonne initiative

    Bonjour,

    Bonne initiative
    Pas encore installer mais cela ne saurais tarder.
    Pour tous ceux qui pourrais ce poser la question voici le lien du site officiel de Phenix 5.01 : http://www.phenix.gapi.fr/
    Cordialement,
    Theking83
    Webmaster
    www.ltdw.net
    Pas de support par MP je réponds aux questions exclusivement posées sur le forum.

    Commentaire


    • #3
      Phenix ----> Joomla

      Bonjour,
      Avez vous pu faire une mise à jour du bridge pour la version 5.51 de Phenix et 1.5.9 de joomla ?

      Car je viens d'installer ce bridge et je ne peux pas fusionner les utilisateurs de phenix et de joomle et je pense qu'il y ai incompatibilité de version.

      Merci pour votre réponse.
      Dernière édition par dcompan à 16/02/2009, 14h36

      Commentaire


      • #4
        Phenix ----> Joomla

        Bonjour,

        Suite à mon précédent message j'ai pu faire fonctionner le bridge pour phenix et fusionner les utilisateurs.
        Mais lorsque je m'identifie sur joomla c'est un autre utilisateur qui apparait dans phenix.

        Savez vous d'où peut provenir cette anomalie ?

        D'avance merci pour votre aide.

        Cordialement.

        Commentaire


        • #5
          Envoyé par VorteX-on Voir le message
          Bonjour,
          je viens de finir de le développer (cf titre). Il fonctionne chez moi avec phenix 5.01 et Joomla 1.5.3.

          Il comporte : un plugin et un composant. Il n'y a pas de hack des fichiers de joomla.

          Je me suis inspiré (très fortement) du très bon rokbridge (forum PHPBB) pour coder le plugin.

          J'aimerais avoir vos remarques, suggestions.

          Merci et Enjoy.

          Bonjour à tous !
          j'ai découvert phenix il n'y a pas très longtemps et on l'a adopté dans notre société (mais on est encore en phase de test quand même ...) et on voudrait aussi utiliser JOOMLA pour faire notre portail Internet. Je suis très très intéressé par ce Bridge entre les 2 ...
          Pour moi, l'install se passe bien. Je peux configurer le répertoire de PHENIX. mais lorsque je veux paramétrer les utilisateurs ... boom ... erreur 500 !
          Quelqu'un a t-il une explication ?

          Merci d'avance

          Commentaire


          • #6
            Pour ceux qui seraient intéressés par ce bridge, voici mes premières modifications :

            j'ai remplacé dans le fichier "function.php" :
            Code:
            $px_db_opt = array ( 'driver' => 'mysqli', 'host' => $cfgHote, 'user' => $cfgUser, 'password' => $cfgPass, 	'database' => $cfgBase, 'prefix' =>  "$PREFIX_TABLE" );
            $px_db =& JDatabase::getInstance($px_db_opt);
            par :

            Code:
            $px_db_opt = array ( 'driver' => 'mysql', 'host' => $cfgHote, 'user' => $cfgUser, 'password' => $cfgPass, 	'database' => $cfgBase, 'prefix' =>  "$PREFIX_TABLE" );
            $px_db = & JDatabase::getInstance($px_db_opt);
            if ( JError::isError($px_db) ) {
            	jexit('Database Error: ' . $px_db->toString() );
            }
            if ($px_db->getErrorNum() > 0) {
            	JError::raiseError(500, 'JDatabase::getInstance: Could not connect to database <br />');
            }
            et déjà j'arrive à ne plus avoir d'erreur lorsque je clique sur "gestion des utilisateurs" !

            A suivre ...

            Commentaire


            • #7
              Modifications

              Bonjour,
              Je n'ai plus travaillé sur ce bridge depuis un an déja (faute de temps). Je n'ai plus très bien en tête tous les détails du code. Mais tu peux modifier le code à ta guise! Poste les modifications si elles apportent qqc, n'hésite pas à faire une archive.

              ++

              Commentaire


              • #8
                Bonjour,

                je ravive le sujet j'ai installé ce bridge qui fonctionne bien, je récupère bien mes utilisateur pour les bridger avec phenix mais par contre je n'ai que les users "enregistrés" de Joomla, pas les super admin. est-ce normal ?

                Merci de votre aide.

                Cdlt,

                Commentaire


                • #9
                  Bonjour,
                  Oui c'est tout à fait normal. J'avais pensé que ça pouvait être une faille que de permettre aux administrateurs loggés sous Joomla de passer à Phenix sans avoir de mot de passe à tapper. Du coup - c'est vrai - que ça ne fonctionne pas avec les admin et super admin.

                  Commentaire


                  • #10
                    Ah oui, c'est vrai. bien vu
                    Merci

                    Commentaire


                    • #11
                      problème urgent

                      Bonjour a tous,

                      je suis intéresse par ce mod, jai joomla Version 1.5.18 , le bridge s'installe et phenix s'ajoute dans la liste des composants, mais lorsque je click que gerer les utilisateurs depuis l'admin de joomla il me renvoie "Impossible d'accéder au fichier de configuration de phenix. Vérifiez le paramètre "Dossier d'installation de phenix".

                      et dans mon site joomla il m'affiche " Vous n'êtes pas autorisé à accéder à cette ressource."

                      je fais quoi la svp ??

                      merci d'avance

                      Commentaire


                      • #12
                        Bonjour,

                        Je viens d'installer le composant et le plugin sur joomla 1.5.21.
                        L'installation s'est déroulé parfaitement.

                        Mon soucis est le suivant.

                        J'avais déjà des comptes sur phenix et d'autre sur joomla.
                        Il se trouve que certaine personne avait déjà un compte sur l'une et l'autre des deux bases.

                        et je n'arrive pas à faire le lien pour ces utilisateurs.
                        Quand je m'identifie avec un compte sur joomla qui existe déjà sur phenix, il me met que le compte n'existe pas.

                        De plus, lorsque je valide la liste de "Gérer les utilisateurs" du plugin, et que je sauvegarde, il me supprime tous les comptes phenix qui n'existe pas dans joomla.

                        Merci d'avance pour votre aide.
                        Dernière édition par remi82 à 19/10/2010, 12h51

                        Commentaire


                        • #13
                          Re : Bridge Joomla 1.5 =&gt; Phenix 5

                          Bonjour,

                          J'ai testé la solution sous joomla 2.5 mais cela ne fonctionne pas... j'ai l'erreur suivante qui apparait:
                          Fatal error: Call to a member function getPath() on a non-object in /home/www/02fce14aa0497688bd309b2b9acec73c/web/administrator/components/com_phenixbridge/admin.phenixbridge.php on line 5

                          Pouvez-vous m'aider?

                          Merci

                          Commentaire


                          • #14
                            Re : Bridge Joomla 1.5 =&gt; Phenix 5

                            Envoyé par usemines Voir le message
                            Bonjour,

                            J'ai testé la solution sous joomla 2.5 mais cela ne fonctionne pas... j'ai l'erreur suivante qui apparait:
                            Fatal error: Call to a member function getPath() on a non-object in /home/www/02fce14aa0497688bd309b2b9acec73c/web/administrator/components/com_phenixbridge/admin.phenixbridge.php on line 5

                            Pouvez-vous m'aider?

                            Merci
                            Bonjour,

                            Ce bridge n'étant qu'en 1.5, ça ne fonctionnera pas sur Joomla! 2.5 sans en faire un portage.
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X