Problème ajout d'image, introduction formulaire Artforms

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème ajout d'image, introduction formulaire Artforms

    Bonjour à tous,

    Je suis entrain de créer un site en local avec Joomla! 1.5 et le composant Artforms.

    Dans la partie "introduction du formulaire", l'éditeur remplace automatiquement les guillemets par \"
    Le problème est facile a contourner lorsqu'il s'agit d'un texte mais plus difficile lorsqu'on souhaite ajouter une image.

    Dans mon cas, la ligne de code initiale
    Code:
    <img src="monimage.jpg" />
    est automatiquement remplacée par
    Code:
    <img src="\" border="0" />
    Si quelqu'un a une idée pour résoudre ce problème, je le remercie d'avance pour son aide.

  • #2
    Problème de \ rajoutés par artforms

    Envoyé par domstang Voir le message
    Bonjour à tous,

    Je suis entrain de créer un site en local avec Joomla! 1.5 et le composant Artforms.

    Dans la partie "introduction du formulaire", l'éditeur remplace automatiquement les guillemets par \"
    Le problème est facile a contourner lorsqu'il s'agit d'un texte mais plus difficile lorsqu'on souhaite ajouter une image.

    Dans mon cas, la ligne de code initiale
    Code:
    <img src="monimage.jpg" />
    est automatiquement remplacée par
    Code:
    <img src="\" border="0" />
    Si quelqu'un a une idée pour résoudre ce problème, je le remercie d'avance pour son aide.
    Bonjour domstang

    Je vois que tu as le même problème que moi et c'est la première fois depuis des semaines que quelqu'un en parle sur un forum.

    Mais je vois aussi que tu as mis :
    Le problème est facile a contourner lorsqu'il s'agit d'un texte
    Peux-tu m'expliquer comment tu fais parce qu'il ajoute systématiquement des \ à toutes les apostrophes et à tous les liens que je mets :

    http://www.passe28.com il me remplace par :

    http://essais28.free.fr/\"http://www.passe28.com\"

    Si tu as une solution pour cela je suis très intéressé

    A part ce problème, Artforms est super !
    Cordialement, Bruno Joomla! 3.8 www.bp2i.fr
    Que l’Eternel te bénisse, et qu’il te garde ! Que l’Eternel fasse luire sa face sur toi, et qu’il t’accorde sa grâce ! Que l’Eternel tourne sa face vers toi, et qu’il te donne la paix !

    Commentaire


    • #3
      Problème liens Artforms

      Rebonjour Domstang

      Pour les caracatères spéciaux j'ai trouvé cette solution :
      http://forum.joomla.fr/showthread.ph...438#post502438

      Pour les images et les liens toujours rien
      Cordialement, Bruno Joomla! 3.8 www.bp2i.fr
      Que l’Eternel te bénisse, et qu’il te garde ! Que l’Eternel fasse luire sa face sur toi, et qu’il t’accorde sa grâce ! Que l’Eternel tourne sa face vers toi, et qu’il te donne la paix !

      Commentaire


      • #4
        Salut

        Voila une solution qui marche ****l pour moi
        http://joomlacode.org/gf/project/jar...thread_id=8586

        Commentaire


        • #5
          Envoyé par stevaz Voir le message
          Salut

          Voila une solution qui marche ****l pour moi
          http://joomlacode.org/gf/project/jar...thread_id=8586
          Merci pour le lien !
          Attention, pour la dernière version d'Artform v. 2.1b7.1 [RC1 For Joomla 1.5], seul la dernière solution fonctionne

          remplacer la ligne 127 dans components/com_artforms/artforms.php par
          $row = $rows[0];
          $row->text = stripcslashes( $row->text);
          $row->danktext = stripcslashes($row->danktext);
          $row->titel = stripcslashes($row->titel);
          et remplacer la ligne 419 dans administrator/components/com_artforms/admin.artforms.php
          $formid = $row->id;
          $row->text = stripcslashes($row->text);
          $row->danktext = stripcslashes($row->danktext);
          $row->titel = stripcslashes($row->titel);
          Voilou !
          Dernière édition par ceronumos à 22/03/2010, 16h36
          mon Portfolio : Marc Héron
          mon site Pro: Magic Design

          Commentaire


          • #6
            Bonjour et merci à tous

            Version: 2.1b7.1 [For Joomla 1.5]
            Pour ma part j'ai changé en ligne 134 dans components/com_artforms/artforms.php ...
            Cependant, une fois l'opération effectuée dans administrator/components/com_artforms/admin.artforms.php, je ne peux plus changer mes champs (aucun n'apparait...) lorsque je remet le fichier d'origine, je peux changer mes champs par contre plus d'image et de lien dans la zone d'introduction...
            Quelqu'un peut-il m'expliquer mon erreur ?
            Merci d'avance

            Commentaire


            • #7
              Si tu lis attentivement mon post précédent tu auras la réponse...
              mon Portfolio : Marc Héron
              mon site Pro: Magic Design

              Commentaire


              • #8
                Envoyé par ceronumos Voir le message
                Si tu lis attentivement mon post précédent tu auras la réponse...
                Bon, Ok pour les deux changements mais lorsque je veux changer un champ, j'ai ce message : Fatal error: Call to undefined function afBindArrayToObject() in /*/*/*/*/*/administrator/components/com_artforms/admin.artforms.php on line 344
                Avez-vous une solution pour ce problème car là, je coince.
                Merci d'avance

                Commentaire


                • #9
                  Un echo en haut de page...

                  Envoyé par zenmops Voir le message
                  Bon, Ok pour les deux changements mais lorsque je veux changer un champ, j'ai ce message : Fatal error: Call to undefined function afBindArrayToObject() in /*/*/*/*/*/administrator/components/com_artforms/admin.artforms.php on line 344
                  Avez-vous une solution pour ce problème car là, je coince.
                  Merci d'avance
                  Après avoir résolu ce pb (j'ai rechargé les fichiers d'origine pour les retransformer et cela a fonctionné...), j'ai un soucis d'echo en haute de page :"Nom: Prénom: Adresse: CODE POSTAL: VILLE: E-mail: N�..." />"
                  Quelqu'un a-t-il une solution, j'ai optimisé la base, je pense que l'erreur se trouve dans le fichier artform.php mais ne sait pas où...Help
                  et encore merci pour ceux qui planchent...

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X