Impossible d'installer une extension

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Impossible d'installer une extension

    Bonjour à tous,
    Je suis nouveau sur votre forum. Je tentes de créer un site internet pour mon plaisir.
    Mais je rencontre plusieurs problèmes, si vous auriez l'amabilité de m'aider je vous en serai reconnaissant. Je commence donc ici par le premier de ces problèmes.
    • J'ai créé un site en local sur mon ordi à l'aide de divers tutos et en installant Joomal 1.5.0
    • Plutard, je l'ai transféré par FTP sur un serveur
    • Tout semblait fonctionner correctement jusque là (sauf dans l'onlet "Configuration" de ma page de gestion de Joomal, qui est pleine de caractères illisibles).
    • Après diverses modifications du sites je voulais insérer un formulaire. J'ai donc téléchargé l'extension "ChronoForm". Mais je n'arrive pas à l'installer. J'ai aussi essayé avec ckforms. Le résultat est le même.
    • J'ai suivi vos tutos pour mettre à jour Joomal vers la version 1.5.20, toujours sans résultat.


    Voici quelques informations:
    • Version de Joomla!: Joomla! 1.5.20 Stable [ senu takaa ] 18-July-2010 18:00 GMT
    • template: siteground-j15-56
    • Version de PHP: 5.2.6
    • Serveur Web: Apache/2.2.3 (CentOS)
    • caractères: utf8_general_ci


    problème et message d'erreur:

    quand j'essaie de transférer et d'installer l'extension après l'upload le message suivant apparaît au bout d'un cours instant:
    * JFolder::create: Ne peut pas créer le dossier
    * Unable to write entry
    si je tentes de transférer sur le serveur, via FTP, l'extension décompressée c'est le message suivant qui s'affiche lorsque je l'installes:
    * Le fichier sélectionné n'a pas pu être copié.
    * JInstaller::install: Echec lors de la copie du fichier : /var/www/vhosts/cafedumonde.ch/httpdocs/portail/tmp/ChronoForms_V3.1_RC5.5/chronocontact.php vers /var/www/vhosts/cafedumonde.ch/httpdocs/portail/components/com_chronocontact/chronocontact.php
    Je pensais que c'était des problèmes de droits d'écritures, je n'en étais pas sûr car je ne parle pas anglais.
    Après quelques essais au hasard d'autorisations sur des dossiers. Tout cela sur le site d'administration de mon hébergeur. Le résultat est toujours le même.
    En désespoir de cause, j'ai commis l'erreur du siècle.
    Avec le gestionnaire de fichier Konqueror qui gère bien FTP j'ai voulu changer les droits de lecture et écriture sur tous les dossiers et sous dossier de mon site. Visiblement Joomal n'a pas aimé du tout cela.......

    Maintenant dès que je me connectes sur l'administration de Joomal un message en rouge apparaît en haut de la page:
    ERROR LOADING FEED DATA
    Je n'ai aucune idée ce que cela peu être.

    Comme vous le voyiez je nages, toute aide me sera utile. Je vous en remercie d'avance.

    A+
    Rodyste
    Dernière édition par rodyste à 03/10/2010, 17h33

  • #2
    Bienvenue !

    La dernière erreur que tu cites n'a aucune importance. Une recherche sur le forum te dira quel module désactiver.

    Quant au reste, il faut que tu cherche chez ton hébergeur ou ici avec son nom si la solution n'a pas déjà été donnée. Il s'agit apparemment bien d'un problème de droits d'écriture. Commence peut-être par activer la couche FTP dans la configuration du site.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Merci Robert,
      quand tu parles d'activer la couche FTP, tu entends sur le serveur ou y-a-t-il une fonction de cette nature dans Joomal?

      Si tu parles chez l'hébergeur, c'est fait et cela fonctionne bien.
      A+
      cordialement
      Rodyste

      Commentaire


      • #4
        C'est dans Joomla!, dans les paramètres généraux de configuration, que tu as cette possibilité.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          ok, je fais déjà cela.
          merci

          Commentaire


          • #6
            resalut à tous,
            j'ai essayé d'activé le FTP dans Joomal et de renseigner les champs.
            mais j'ai à nouveau des erreurs...
            en rouge:
            * JFTP::write: Bad response
            en bleu:
            * Une erreur est survenue ! Impossible de modifier le fichier de configuration (configuration.php) (fichier en lecture seule) !
            J'ai contrôlé via Konqueror les droits sur le fichier configuration.php, ils sont en lecture écriture pour tout le monde. Mais pas en mode exécutable, devraient-ils l'être?

            Commentaire


            • #7
              RobertG à écrit
              La dernière erreur que tu cites n'a aucune importance. Une recherche sur le forum te dira quel module désactiver.
              c'est juste l'on ne cherche jamais comme il faut,
              la solution est ici:
              http://forum.joomla.fr/showthread.php?t=78371&page=2

              un premier problème de réglé.

              Commentaire


              • #8
                Salut à tous,
                bon j'avance.
                Après plusieurs heures de recherche (en fait une nuit), j'ai fini par trouver ce post:
                http://forum.joomla.fr/showthread.ph...highlight=JFTP

                Les explications de RobertG m'ont aiguillée dans la bonne direction. Merci.

                et à tatons j'ai trouvé ceci:
                • donner les droits lecture et écriture pour tous sur le fichier configuration.php et le rendre exécutable,
                • activé la couche FTP sur l'administration de Joomla,
                • installer le nouveau module.


                Seulement en installant le nouveau module les messages suivants apparaissent:
                en rouge:
                * JFTP::store: Bad response
                * Attention ! - Le fichier n'a pas pu être déplacé
                en bleu:
                * Installateur Module Succès
                Quand je vais dans gestion des modules le nouveau module est présent, je n'ai pas encore fait des essais mais votre avis m'intéresse pensez-vous que cela fonctionne vu le message en rouge cité ci-dessus?
                Dernière édition par rodyste à 02/10/2010, 17h23

                Commentaire


                • #9
                  Manifestement, il doit encore exister des restrictions, pour que tu aies ce message d'alerte.
                  Quel est ton hébergeur ? As-tu cherché sur son nom s'il y a déjà des conseils sur le forum ?
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    salut,
                    je suis chez EasyGiga, j'ai fait une recherche sur le forum avec son nom, plusieurs réponses apparaissent. Mais les messages ne semblent pas récents. J'ai notament rajouté la ligne
                    php_value upload_max_filesize "6M"
                    à mon fichier .htaccess. Je ne sais pas trop ce que cela veut dire, mais sur un fil de discussion (http://forum.joomla.fr/archive/index.php/t-43135.html) cela avait réglé un problème d'upload chez le même hébergeur.
                    Dans ce fil ils parlent aussi du fichier php.ini, mais moi je ne trouve pas ce fichier sur mon site.

                    Commentaire


                    • #11
                      Heu...... mille excuses,
                      je crois que pour le dernier message d'erreur le bug c'est...... moi

                      en effet je pense avoir installé le module ckform avant le composant
                      d'où le problème de déplacement.
                      J'ai refait la manipulation et tout à l'air de fonctionner.

                      encore merci RobertG
                      Cordialement
                      A+ pour les prochains problèmes(flash)
                      Rodyste


                      après essai de création d'un formulaire avec CKform, ça fonctionnne,
                      merci encore.
                      Je passe le message en résolu.
                      Dernière édition par rodyste à 03/10/2010, 17h32

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X