aucun affichage de .jpg

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] aucun affichage de .jpg

    Bonjour,

    J'ai installé joomla sur un serveur web que j'ai monter tout sa marche sans problème mais lorsque j'importe des images en l'occurrence des .jpg elle ne s'affiche pas dans la gallerie d'image je voie le nom de l'image en bleu sous fond blanc dans le gestionnaire de photo et rien dans la page web, peut importe que je passe par filezila ou que je l'importe avec joomla directement même problème ??
    Est ce que quelqu'un peut m'aider svp ?
    merci.

  • #2
    Bonjour,
    quel est le gestionnaire de galerie ? C'est visible en ligne ?
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Merci,
      Et bien je n'est pas fait de modification particulière, c'est la première fois que je fais un site avec joomla, j'ai prit la dernière version donc sa doit être le gestionnaire de galerie par default ?

      Commentaire


      • #4
        Bonjour,
        il n'y a pas de gestionnaire de galerie dans le core de Joomla.
        Soit tu as installé un package qui inclut une galerie, soit il s'agit juste de l'éditeur ?
        Sur quoi cliques-tu exactement pour charger une photo ? Où t'attends tu à la voir apparaître ?
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Bonjour,
          J'utilise la Version 1.5.9, pour charger des photos je fais cette manipulation :

          Onglet site >> Gestion des Médias >> Transférer un fichier [ Max = 10M ] >> parcourir >> et j' ajoute ma photo

          Sinon j'ai utilisé aussi cette manipulation :

          Connexion avec filezilla en ftp à mon serveur >> copie des fichier dans /var/www/site/images/stories

          mais dans aucun des deux cas j'ai l'images de ma photos , j'ai éssayé de diminué la taille de la photo mais cela ne résous pas le problème, les fichiers .jpg sont autorisé . Je ne vois d'où sa pourrais venir ?
          Merci de m'aider
          Dernière édition par jagogordonne à 24/03/2009, 08h25

          Commentaire


          • #6
            schtroumpf moi grand schtroumpf

            Commentaire


            • #7
              Bonjour,
              donc si je comprends bien tu as uploadé des images dans le gestionnaire de médias et les fichiers sont bien transférés et maintenant tu voudrais les afficher dans une page.
              Pour celà il faut que sous ton éditeur tu cliques sur le bouton qui représente un petit arbre vert sur fond bleu qui ressemble vaguement à une diapo.
              > Si ton éditeur est tinyMCE, il faudra taper tout le le chemin de la photo (à partir de la racine du site, je crois sans le premier / sinon essaye avec)
              > Si ton éditeur est JCE tu as la possibilité de parcourir les dossiers et sélectionner une image.
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Merci de me répondre,
                non justement on arrive à mon problème initiale, lorsque mon image est uploadé elle est sous fond blanc et le nom de l'image est bleu par dessus mais aucun n'aperçus n'est disponible et impossible de les mettes dans un billet, dans aucun des cas je ne peux voir mon image ? pourtant la taille de l'image est bonne ainsi que le format. Qu'en pensez vous ?
                Dernière édition par jagogordonne à 01/04/2009, 13h03

                Commentaire


                • #9
                  J'ai fais quelque recherche car j'ai aussi des problèmes pour des templates que je veux ajouter, ainsi que params.ini n'est pas Modifiable! tous sa est lié je pense. J'ai donc changé les droits qui désormait sont en 775 et param.ini n'est toujours pas modifiable, j'ai donc continué mes recherches et je suis arriver sur un site qui expliquait ceux ci "Les fichiers creer par des scripts PHP (par exemple si vous utilisez Joomla et que vous installez et utilisez des Composant ou Module externe) le propriétaire est à 85% des cas, le fameux "nobody" ou "99" (et donc il est impossible de uploader / supprimer / renommer / changer les droits CHMOD de ces fameux fichiers)" et donc :

                  Le seul remède : Faire un CHOWN

                  source : http://www.developpez.net/forums/d63...ission-joomla/

                  J'aimerai avoir votre avis la dessus.
                  Merci

                  Commentaire


                  • #10
                    Re,
                    je ne suis pas sûr de comprendre : est-ce que ce postulat que je faisais : les fichiers sont bien transférés est vrai ? Quand tu fais un upload par exemple en FTP, tu vois ensuite tes fichiers dans le dossier sur le serveur ?
                    Schtroumpfe toi le Schtroumpf t'aidera.
                    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                    Commentaire


                    • #11
                      re,

                      oui, je les vois mais elles sont sous fond blanc avec le nom de mon image en bleu par dessus et c'est tout voilà. Mais elles sont bien là.

                      Commentaire


                      • #12
                        Bonjour
                        je les vois mais elles sont sous fond blanc avec le nom de mon image en bleu par dessus et c'est tout voilà. Mais elles sont bien là.
                        Toujours pas convaincu qu'on parle de la même chose.. quand tu uploades une image en FTP, par exemple avec Filezilla est-ce que tu vois les fichier uploadé dans la liste du répertoire ? Là pas question d'images blanches avec le nom sur fond bleu : juste une liste de fichiers...

                        Le blanc avec le nom bleu c'est où quand tu mets l'image dans une page ? Tu fais comment ? Si tu regardes la source de la page et que tu cherches l'image, tu vas trouver un <img src="..." .../> Il y a quoi après src= ? C'est bien le chemin de l'image ?
                        Schtroumpfe toi le Schtroumpf t'aidera.
                        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                        Commentaire


                        • #13
                          Bonjour,
                          Oui je voie bien mon fichier dans filezilla, et les photos blanc avec le titre en bleu se trouve dans le gestionnaire, je n'ai rien en ligne et la source de l'image est bonne avez vous lu l'article sur les droits des fichiers lorsque des fichiers sont créé avec un script php ?
                          Merci.

                          Commentaire


                          • #14
                            Bonjour,
                            Résolution du problème en faisant un chown www-data sur mes photo.

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X