GMa

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] GMa

    Je viens d'installer GMaccess sur un site en production !

    L'install s'est bien passée et au moment de confirmer, a la fin, j'ai un message d'erreur et tout est bloqué backend et fronted.

    C'est la panique !

    Message:


    * Error loading Plugins: Table 'zazakely.jos_gmacl' doesn't exist SQL=SELECT DISTINCTROW a.folder AS type, a.element AS name, a.params FROM jos_plugins AS a LEFT JOIN jos_gmacl AS gi ON a.id = gi.axo AND gi.aco = "read" AND gi.axosection = "plugin" WHERE a.published >= 1 AND (gi.aro IN ( 0 ) OR a.access <= 0) ORDER BY a.ordering
    * Error loading Plugins: Table 'zazakely.jos_gmacl' doesn't exist SQL=SELECT DISTINCTROW a.folder AS type, a.element AS name, a.params FROM jos_plugins AS a LEFT JOIN jos_gmacl AS gi ON a.id = gi.axo AND gi.aco = "read" AND gi.axosection = "plugin" WHERE a.published >= 1 AND (gi.aro IN ( 0 ) OR a.access <= 0) ORDER BY a.ordering
    * Error Loading ModulesTable 'zazakely.jos_gmacl' doesn't exist SQL=SELECT DISTINCTROW m.id, m.title, m.module, m.position, m.content, m.showtitle, m.control, m.params FROM jos_modules AS m LEFT JOIN jos_modules_menu AS mm ON mm.moduleid = m.id LEFT JOIN jos_gmacl AS gm ON m.id = gm.axo AND gm.aco = "read" AND gm.axosection = "module" WHERE m.published = 1 AND (gm.aro IN ( 0 ) OR m.access <= 0 OR m.client_id = 1) AND m.client_id = 1 ORDER BY position, ordering
    * Error loading Plugins: Table 'zazakely.jos_gmacl' doesn't exist SQL=SELECT DISTINCTROW a.folder AS type, a.element AS name, a.params FROM jos_plugins AS a LEFT JOIN jos_gmacl AS gi ON a.id = gi.axo AND gi.aco = "read" AND gi.axosection = "plugin" WHERE a.published >= 1 AND (gi.aro IN ( 0 ) OR a.access <= 0) ORDER BY a.ordering

    Visiblement j'ai un problème au niveau de la base de données ! ?

    Je rencontre ce type de blèm pour installer Highslide.

    Même chose avec k2.

    Ici, c'est la base jos_gmacl qui n'est pas créée.

    Merci de m'aider
    Dernière édition par Pakoo à 02/01/2010, 13h13
    PAKOO

  • #2
    Bonjour,
    Quel est ton hébergeur ?
    en attendant de résoudre le problème, tu peux supprimer gma par le ftp et nettoyer la base depuis l'admin de l'hébergeur

    Commentaire


    • #3
      Salut,(bonne année)

      Merci pour ta réponse.Ca fait un moment que je tente de répondre à mon tour mais j'étais bloqué car je viens de changer de mail. Bref ...

      Je suis chez ovh.

      Et pour ce qui est de supprimer les dossiers par le ftp, pas facile:

      Les droits sont en 0755 et surtout propriétaire/groupe nobody/nobody

      Pour la base, elle est vide ! (de GMa)

      Tu as une idée ?
      PAKOO

      Commentaire


      • #4
        bon ça résoudra pas le problème mais pour récupérer le site de prod.

        As tu tenté de dépublier le module à la main depuis la db? sauf erreur table jos_modules tu cherches ton item et change le flag published à 0. et pareil pour les plugins si tu en as activés.
        Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher, il mangera toujours. En Résumé, j'aide mais tu fais le boulot!

        Commentaire


        • #5
          aie en fait vu que GM Access est un hack, je suis pas sur que ça suffise... il faudra peut être encore remettre certains fichiers core à leur version originale...
          Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher, il mangera toujours. En Résumé, j'aide mais tu fais le boulot!

          Commentaire


          • #6
            Merci pour les réponses, mais je ne comprends pas tout.

            Je suis obligé de m'absenter, désolé, si tu peux m'éclairer plus sur la marche à suivre ne te prive pas.

            Merci encore, je refais surface Dimanche.

            Il faut que j'ouvre les huitres , il est déjà 19h 15 ici.

            Merci et bonne soirée.
            PAKOO

            Commentaire


            • #7
              Yo!
              L'idée serait la suivante:
              1- deactiver les modules et plugins GMAccess depuis la base de données.
              avec phpmyadmin, edit les tables jos_modules et jos_plugins. Dans ces 2 tables, identifie les entrée liées à GMAccess et change la valeur dans la colonne Published de 1 à0
              2 - teste ton site... tu devrais plus avoir ces messages d'erreur là... par contre, si tu as d'autres erreurs, il faut continuer...
              3 - GMAccess est un Hack. C'est à dire qu'il modifie les fichiers du Core de joomla. Il te faut donc identifierles fichiers qui ont été changés lors de l'installation et les remplacer par ceux d'une installation fraiche.

              j'espère que ca aide et bon appétit!
              Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher, il mangera toujours. En Résumé, j'aide mais tu fais le boulot!

              Commentaire


              • #8
                Bonjour,
                A l'install, gmaccess te crée un backup, je ne sais plus trop où, peut-être dans les fichiers d'admin. Il suffit de le récupérer, et de remplacer les fichiers par ceux du backup. Je l'ai fait au moins 2 fois, j'ai eu beaucoup de mal à installer gmaccess parce que mon serveur est sous mysql 3.23, et les tables ne se créaient pas à cause des character set que mysql 3.23 ne connait pas. J'ai du dézipper les fichiers gmaccess, trouver où étaient ceux qui créaient les tables, modifier et rezipper, finalement j'ai réussi. Je ne sais pas si c'est ton problème...

                Commentaire


                • #9
                  Bonjour,
                  pour compléter jtrinche,
                  essaye de vider ton cache explorateur.

                  Tu dois savoir également que chaque version GMAccess est spécifique à une version de Joomla. Il est donc nécessaire d'installer la bonne version de GMAccess. Aussi en cas de mise à jour, il faut impérativement utiliser le patch de mise à jour pour GMAccess (qui n'est rien d'autre que le patch officiel adapté à la gestion GMAccess).
                  Par ex; il faut GMA 5.14 avec joomla 1.5.14

                  Si ca ne donne rien, tu dois désinstaller le plugin et le composent via l'accès à ta BDD (valeur published = 0)

                  Puis récupérer les fichiers d'avant l'installation dans administrator/gmabackup (c'est la sauvegarde dont parles madoo) via ton FTP.

                  Si tu ne t'en sors pas, va sur le site de gma et pose ton problème dans le forum
                  http://www.eduvs.ch/gmaccess/index.p...id=2&Itemid=59
                  gregmab (concepteur du compo) te répondra peut être.
                  Dernière édition par SCARPIA à 02/01/2010, 17h32

                  Commentaire


                  • #10
                    Salut à tous et bonne année.

                    Juste un mot pour dire que vous êtes juste super, vous soucier de mes problèmes pendant que je mange mes huîtres, c'est très fort.... un grand merci.

                    Bon, vous l'avez déjà compris, je ne suis pas trop au top.
                    Je ne comprends pas :
                    Pour les plugins OK.
                    Mais
                    Je n'ai pas d'entrée gma dans jos_modules mais dans jos_components, et là, pas de published 1/0. ???

                    Pour le composent puis-je utiliser "effacer" dans la bdd ?

                    A+
                    PAKOO

                    Commentaire


                    • #11
                      En attendant une réponse pour le composent, j'ai restaurer le backup GMa, sur les conseils de mado0,

                      et cela fonctionne très bien.

                      Pour répondre à mado0, la version ovh de mysql est bien 3.23.58-log.
                      Pense-tu (ou pensez-vous) que mon problème d'install de K2 soit du même genre ? effectivement les tables ne se créent pas !

                      Merci encore.
                      PAKOO

                      Commentaire


                      • #12
                        Bonjour,
                        je vais essayer de retrouver les modifications que j'avais faites, si ça t'intéresse... si je ne me trompe pas, c'est les "character set utf8" ou un truc du genre qui ne passe pas avec mysql 3.23, il faut les enlever.

                        Commentaire


                        • #13
                          J'ai retrouvé mon fichier, mais attention :
                          -je ne suis pas programmeuse, c'est de la bidouille qui a marché pour moi...
                          -J'ai joomla 1.5.14, c'est donc pour le gmaccess 5.14
                          -Il faut faire une bonne sauvegarde bien complète avant, et c'est un truc que j'ai risqué parce que mon site n'était pas très avancé, mais maintenant qu'il est bien rempli, je n'oserais plus trop bidouiller comme ça...
                          c'est le fichier qui se trouve là :
                          COM_GMACCESS_5.14\admin\component\install\install. mysql.utf8.sql
                          http://skias.free.fr/install.mysql.utf8.sql
                          C'est pareil, je ne suis plus tout à fait sûre de ce que j'avais fait, mais je crois que j'ai juste dézippé le gmaccess, modifié le fichier, et rezippé, puis j'ai fait l'installation normale. Je ne suis plus tout à fait sûre parce que après, j'ai refait pareil pour uddeim, et là, je crois que j'ai du créer les tables manuellement avec phpmyadmin ...

                          Enfin, voilà si ça peut t'aider

                          Commentaire


                          • #14
                            J'ai essayé, ça ne marche pas, même punition, les tables ne se créent pas.
                            Pourtant tu ne dois pas être loin de la vérité !
                            Je cherche, si je trouve, je te dis.

                            Merci.
                            PAKOO

                            Commentaire


                            • #15
                              Bonjour,
                              si vraiment tu ne trouves pas, n'hésites pas à aller poser la question sur le forum de gmaccess
                              http://www.eduvs.ch/gmaccess/index.p...id=2&Itemid=59
                              Dernière édition par SCARPIA à 06/01/2010, 16h51

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X