Joomladay francophone 2018 à Paris 18 et 19 mai

lien de menu ne s'affiche pas avec GMACCESS

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • lien de menu ne s'affiche pas avec GMACCESS

    bonjour à tous
    j'ai installé GMACCESS pour régler les droits spécifiques de mon site. J'ai créé un groupe "test" avec des membres.
    Je voudrais que lorsque un des membres de ce groupe se logue en frontend un lien de menu spécifique apparaisse, mais uniquement pour ce groupe.

    Problème c'est que dès que je mets les droits du lien de menu sur GMACCESS le lien ne s'affiche plus ! or si je le met sur "enregitrés" il s'affiche mais alors pour tout les membres.

    Merci de m'aider !
    Dernière édition par ced1870 à 15/01/2010, 15h57
    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
    http://www.template-creator.com Outil de création de templates
    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

  • #2
    vu que tout le monde boycotte mes questions, je m'autoréponds

    j'ai trouvé la solution ici :
    http://www.eduvs.ch/gmaccess/index.p...=329&Itemid=59

    c'est un problème de template apparemment.
    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
    http://www.template-creator.com Outil de création de templates
    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

    Commentaire


    • #3
      Bonjour ced1870,
      j'ai actuellement le même problème, bien que j'ai regardé le lien donné ci-dessus, je ne comprends pas comment régler le problème.
      Si tu as trouvé l'astuce, peux-tu me l'expliquer ?

      merci d'avance
      joomla c'est un nouveau monde pour moi ,
      mais quel monde !!! je ne pense plus le quitter

      Commentaire


      • #4
        salut
        tu utilises aussi ja-purityii ? le lien est spécifique à ce template
        sinon as-tu recherché sur le forum de gmaccess ?
        quel template utilises-tu ?
        Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
        http://www.template-creator.com Outil de création de templates
        Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

        Commentaire


        • #5
          j'utilise un template que j'ai crée moi même
          sinon j'ai essayé avec les templates de base de joomla
          mais rien ne passe
          joomla c'est un nouveau monde pour moi ,
          mais quel monde !!! je ne pense plus le quitter

          Commentaire


          • #6
            bah normalement si tu charges le module de menu avec jdoc:include, tu ne devrais pas avoir de souci parce que moi ça marchait sous ja-purity ou rhuk-milkyway livrés avec joomla
            Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
            http://www.template-creator.com Outil de création de templates
            Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

            Commentaire


            • #7
              c'est ce que je fais
              et pourtant rien à faire
              pour le moment je n'ai pas encore fait le menu déroulant, j'utilise swfreemenu peut-être que le problème vient de là
              Dernière édition par kakashi à 03/02/2010, 20h57
              joomla c'est un nouveau monde pour moi ,
              mais quel monde !!! je ne pense plus le quitter

              Commentaire


              • #8
                j'avais même pas fais attention
                pour la création de mon template c'est votre e-book que j'ai utilisé, je dois dire qu'il est très bien fait et surtout très clair
                joomla c'est un nouveau monde pour moi ,
                mais quel monde !!! je ne pense plus le quitter

                Commentaire


                • #9
                  j'ai essayé avec le template basket et la sa fonctionne parfaitement
                  alors sa vient bien de swfreemenu
                  donc je vais terminer mon template

                  merci pour votre aide
                  joomla c'est un nouveau monde pour moi ,
                  mais quel monde !!! je ne pense plus le quitter

                  Commentaire


                  • #10
                    maintenant que tu le dis, ça parait évident ... oui si tu utilises swmenufree c'est fort possible que le problème vienne de là

                    j'avais même pas fais attention
                    pour la création de mon template c'est votre e-book que j'ai utilisé, je dois dire qu'il est très bien fait et surtout très clair
                    Merci, j'en suis ravi
                    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                    http://www.template-creator.com Outil de création de templates
                    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                    Commentaire


                    • #11
                      Bonjour, désolé de faire remonter ce topic mais j'utilise actuellement le template Ja_purity ii et j'ai ce souci.

                      J'ai deux menus (un menu utilisateur et un principal). Dans le menu utilisateur je qu'un lien ne s'affiche que si l'utilisateur fait partie d'un certain groupe (afin de pouvoir gérer les différents membres!) sauf que ça ne fonctionne pas. Si le lien n'est pas coché pour les membres, et bien il ne s'affiche pas. Par exemple je ne peux pas donner accès juste pour le groupe test!

                      Je viens de suivre le lien du topic donné ci dessus. J'ai modifié base.class.php mais rien n'a changé je ne comprend pas. Help please.

                      Merci d'avance. A bientôt!

                      Commentaire


                      • #12
                        tu utilises ja-purity ii, le mod_mainmenu standard de joomla ? tu as fait la modif dans le template et ça ne marche pas ?

                        je crains de ne pas pouvoir t'aider...
                        Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                        http://www.template-creator.com Outil de création de templates
                        Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                        Commentaire


                        • #13
                          Aie et bien apparemment ça va être dur. J'ai créé un menu appelé menu_utilisateur qui utilise bien le mod_mainmenu. Donc je n'ai aucun espoir alors?
                          N'y aurait-il a pas de réglage (a force de tester) que j'aurai enlevé?
                          Bon sinon ça fonctionne avec d'autres templates donc je suppose bien que ça vient de là. Si jamais ça ne devait pas marcher, il faudrait me résigner à changer de template!!!

                          Merci quand meme

                          A bientot

                          Commentaire


                          • #14
                            J'ai trouvé (enfin) comment faire. J'ai modifier une ligne mais ce n'est pas la ligne cité plus haut

                            le fichier à modifier c'est:

                            /templates/ja_purity_ii/html/mod_mainmenu/default.php

                            ligne 30

                            remplacer
                            Code PHP:
                            if ($child->attributes('access') > $user->get('aid'0)) { 
                            par

                            Code PHP:
                            if (!fonctionGmaccess::checkgmaccess2('com_content','read','users',$user->gmid,'menu',$child->attributes('id'))) { 
                            en espérant que ça aide quelques personnes
                            Dernière édition par Crazy Dragon à 14/05/2010, 08h51

                            Commentaire


                            • #15
                              hello je remonte le sujet car je rencontre le même pb
                              j'utilise gmaccess et on me demande un menu déroulant type swmenufree
                              or, seuls les menus publics apparaissent
                              j'ai corrigé le fichier function.php comme dit au début du post mais ça ne fait rien
                              quelqu'un a une solution ???

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X