Problème avec users-lists sous CB

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème avec users-lists sous CB

    Bonjour,

    Pour ceux qui ont un peu suivi, je n'ai eu que des soucis jusqu'à hier où tout semblait réglé... Mais maintenant, ça recommence...

    à mon avis, le problème, c'est la page user-lists (parce que si je retire le lien du menu, tout fonctionne normalement)

    Premièrement, à "trié par" il n'y a plus "statut de connexion" alors que c'est mon premier tri (sous j!2.5, ça apparaissait normalement) déjà ça, c'est un problème... (par défaut, j'ai mis "trié au hasard" en attendant)

    Ensuite, dès que je mets un lien vers cette page, plein de choses déconnent : cb_online et cb_login au lieu de renvoyer vers la page du membre qui est en ligne, renvoient vers users-lists... Le menu utilisateur, en cliquant sur le lien "votre profil" renvoie vers cette page http://voyance.montki.eu/component/c...gin?Itemid=102 où il est juste écrit "Connexion, bonjour machin" avec le portrait... mais si on clique dessus, ça renvoie vers users-lists...

    Là, je dois dire que je sèche...

  • #2
    Re : Problème avec users-lists sous CB

    Bonjour,

    Il doit y avoir un problème quelque part dans cette installation. Les user-lists n'ayant en général jamais ce type de comportement, sauf si les droits sont mal définis
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Problème avec users-lists sous CB

      Ne me dis pas que je dois à nouveau réinstaller CB !

      Parce qu'en plus, il y a un autre problème : impossible de modifier tous les liens sociaux (FB, twitter, etc) dans "infos de contact" côté site (côté admin : aucun souci) D'autant que, dans "infos de contact", j'ai rajouté un champ (identifiant skype) qui lui s'affiche dans "modification de page" sans problème... Et si je compare les 2 (skype et FB) c'est scrupuleusement identique... pourtant skype s'affiche et FB pas...

      Commentaire


      • #4
        Re : Problème avec users-lists sous CB

        Tu as certainement un vrai problème dans ton site ou sa configuration. Au vu du nombre assez faramineux de dysfonctionnements divers, impossible de détecter ce qui en est la cause originelle avec simplement des descriptions des défauts.
        Il est fort probable que des problèmes de droits ou des ACL mal définis puissent en être la cause.
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : Problème avec users-lists sous CB

          cela dit, il me semble que le problème est plutôt lié à CB qu'à joomla!3 (que je ne connais pas du tout...) mais je dis ça parce que si je vais sur le forum (kunena) et que je clique sur mon nom (seul endroit où mon nom apparaît qui ne soit pas de CB) il renvoie correctement vers mon profil...

          (je croyais avoir trouvé le problème dans la configuration puisque hier, une fois que c'était bon, j'ai renommé le site pour qu'il soit à la bonne adresse et en fait, dans la configuration, les dossiers logs et tmp étaient encore à l'ancienne adresse... mais après correction, ça ne change rien)

          Je crois que je vais à nouveau supprimer CB et le réinstaller...

          Commentaire


          • #6
            Re : Problème avec users-lists sous CB

            et le module 'mod_whosonline' qui affiche mon nom comme un lien... sauf que ce n'est pas cliquable... C'est normal ça ?

            Commentaire


            • #7
              Re : Problème avec users-lists sous CB

              Sous CB, c'est le module cb online et pas whosonline qui doit être utilisé.
              Pas de demande de support par MP.
              S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

              Commentaire


              • #8
                Re : Problème avec users-lists sous CB

                oui je m'en doute, je fais ça juste pour essayer de déterminer si le problème est lié à joomla ou à CB

                Commentaire


                • #9
                  Re : Problème avec users-lists sous CB

                  oui je pense que le problème est lié à CB : j'ai fait un débogage système et des phrases comme celles ci-dessous, j'en ai au moins 70 ! (et toutes liées à CB)

                  Bref, pour la troisième fois, je vais désinstaller et réinstaller ce truc-là...

                  Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homez.55/montki/www/voyance/administrator/components/com_comprofiler/library/phpinputfilter/phpinputfilter.inputfilter.php on line 328

                  Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homez.55/montki/www/voyance/administrator/components/com_comprofiler/library/phpinputfilter/phpinputfilter.inputfilter.php on line 331

                  Strict Standards: Declaration of getcaptchaTab::getDisplayRegistration() should be compatible with cbTabHandler::getDisplayRegistration($tab, $user, $ui, $postdata) in /homez.55/montki/www/voyance/components/com_comprofiler/plugin/user/plug_cbcaptcha/cb.captcha.php on line 0

                  etc

                  Commentaire


                  • #10
                    Re : Problème avec users-lists sous CB

                    Ces Deprecated sont dus uniquement à une ancienne bibliothèque phpinputfilter qui est utilisée. Dans les versions récentes de PHP, la compilation avec la bibliothèque pcre provoque ce Deprecated, pcre ayant déprécié le modificateur e des expressions.

                    Sur le forum Joomlapolis, il ets indiqué que phpinputfilter sera modifié dans la prochaine version.
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : Problème avec users-lists sous CB

                      oui, ben j'ai commencé par désinstaller/réinstaller cb_login et cb_online mais sans succès puis j'ai désinstallé/réinstallé com_comprofiler et donc maintenant j'ai plein de réglages à refaire mais cb_login et cb_online fonctionnent correctement...

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X