sh404sef et affichage/masquage de module par page ou menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • sh404sef et affichage/masquage de module par page ou menu

    Bonjour,

    Je suis joomla 1.5.11 et j'ai installé sh404sef qui fonctionne correctement sur mon site.

    Mon soucis est que j'essaie de ne pas afficher les modules positionnés à droite pour une page ou un menu. Pour ce, j'ai dé-sélectionné le menu en question au niveau du paramétrage des différents modules.
    Quand le sh404sef est désactivé, ça marche très bien. Dès que j'active le sh404sef ça ne marche plus.

    J'ai exploré le forum et je n'ai pas trouvé la réponse à mon problème.
    Ne connaissant pas toutes les subtilités du mécanisme d'affichage/masquage des modules, je ne sais pas exactement à quel niveau et comment intervenir : modification au niveau du sh404sef, modification du code des modules, etc.

    Merci pour vos réponses !
    Dernière édition par barry_cool à 01/09/2009, 17h03 Raison: Résolu

  • #2
    il faudrait un peu plus d'info sur ce qui ne marche pas. quels sont les symptomes?
    Sinon tu peux faire la mise à jour de ton site joomla vers 1.5.13 ;o) ca mange pas de pain.
    Reaweb 2.0 : webmaster de proximité Lyon et val de saône
    http://reaweb.fr
    portail de couzon au mont d'or

    Commentaire


    • #3
      Salut Korrigan,

      Oui tu as raison, j'ai fait quelques tests depuis et il y a quelques subtilités. Je vais essayer de m'étendre un peut plus.

      La plupart des pages de mon site sont disposées en trois colonnes, sachant que la première et la troisième colonne ne sont composées que de modules (en position left et right).

      Lorsqu'un utilisateur avec un niveau d'accès "Auteur" se connecte au site, il peut voir et accéder via mon menu principal au menu "Envoyer un article" (menu de type "Article::Nouveau" dans le back-end). En cliquant sur ce menu l'utilisateur accède à une page d'édition d'un article. Comme éditeur j'utilise JCE (version de composant 157 et version de plugin 154).

      Comme je l'ai dis dans mon premier posts, je ne souhaite pas afficher les modules de position right donc je dé-sélectionne ce menu dans la configuration de ces modules.

      Quand je n'active pas sh404sef, tout fonctionne bien avec une url du type "http://monsite.com/index.php?option=com_content&task=new&sectionid=4& Itemid=41".
      Quand j'active le sh404sef, ça ne fonctionne pas, c'est à dire que les modules de droite s'affiche comme sur toutes les pages, avec une url du type "http://monsite.com/?task=new".

      Par contre, quand je désactive le sh404sef et que je configure pour ne pas afficher un module sur un menu standard, ça marche, que l'utilisateur soit enregistré ou non.

      A noter, que le menu "Envoyer un article" ne peut être accessible en public, il renvoie à une erreur 403, ce qui est compréhensible.
      J'utilise un fichier .htaccess et dans sh404sef j'ai configuré "avec .htaccess en mod_rewrite".

      Si tu as besoin d'autres détails fais moi signe.
      Dernière édition par barry_cool à 25/08/2009, 16h57

      Commentaire


      • #4
        Petit UP !

        Commentaire


        • #5
          Hum

          Salut,

          Comme je l'ai dis dans mon premier posts, je ne souhaite pas afficher les modules de position right donc je dé-sélectionne ce menu dans la configuration de ces modules.
          Déselectionner c'est-à-dire : désactiver le module ou le mettre accessible en tant que membre enregistré ?

          Je vois un problème de gestion du cache d'un module là dessous.

          Explique plutôt le résultat que tu souhaites obtenir à l'arrivée...

          @+
          Liderapro www.liderapro.com

          Commentaire


          • #6
            Envoyé par tristan.stgermain Voir le message
            Salut,

            Déselectionner c'est-à-dire : désactiver le module ou le mettre accessible en tant que membre enregistré ?

            Je vois un problème de gestion du cache d'un module là dessous.

            Explique plutôt le résultat que tu souhaites obtenir à l'arrivée...

            @+
            Salut,

            A l'arrivée, je souhaite qu'un membre enregistré qui a un statut "auteur", lorsqu'il clique sur le lien de menu "enregistrer un article" (seul un membre enregistré avec un statut "auteur" peut voir le lien), à l'affichage de la page de rédaction d'un article ne voit pas les modules de droite s'afficher.

            J'espère avoir été clair.

            Je vais explorer ta piste!

            Commentaire


            • #7
              test

              Test en mettant 'Mettre en cache > Jamais' dans la gestion de tes modules...
              Liderapro www.liderapro.com

              Commentaire


              • #8
                Envoyé par tristan.stgermain Voir le message
                Test en mettant 'Mettre en cache > Jamais' dans la gestion de tes modules...
                Malheureusement, ça n'a pas marché.

                Commentaire


                • #9
                  La solution consiste à faire une redirection personnalisée d'url en changeant bien "lang=fr" au lieu de lang="en" inséré par défaut lorsque que le code langage est inséré.

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X