Pas de menu actif avec le SEO activé

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Pas de menu actif avec le SEO activé

    Bonjour à tous,

    Je viens vers vous pour m'aider à résoudre un petit problème :
    J'ai 2 menus paramétrés dans la feuille de style afin qu'ils affichent un style particulier lorsqu'ils sont actifs.
    Lorsque j'active le SEO de Joomla, un des deux menus n'affichent plus le style du menu actif.
    En regardant dans le code, je n'obtiens pas le id="current" dans le <li> actif.
    Visitez le site pour tester : http://www.sa27-securite.com
    Le menu incriminé est celui de gauche. Celui du haut fonctionne.
    Le menu de gauche est de type liste dans les paramètres modules mod_mainmenu.

    Merci d'avance
    Dernière édition par studioh à 15/10/2009, 13h16
    "Qu'est ce que je vais raconter aux enfants?" -- "Dis-leur que papa est parti à la pêche."
    Les dents de la mer - 1975

  • #2
    Bonjour
    même problème chez moi
    Je me retrouve avec uniquement ma page d'accueil qui s'affiche correctement, sinon, plus rien ne marche lorsque j'active la réécriture d'url
    Si je trouve une solution, je vous tiens au courant
    Je suis chez Mavenhosting, j'ai peut-être loupé un truc...
    Bonne journée

    Commentaire


    • #3
      Problème résolu !!!
      Essayez de suivre ce que dit cette page
      http://jice.lavocat.name/blog/2008/0...a-1-5-cas-ovh/
      J'ai modifié les 3 fichiers ( htaccess, configuration et application).
      Par contre vérifiez bien avant que vous ayez les droits pour le configuration.php.
      Tenez-nous au courant

      Commentaire


      • #4
        Et bien, tu n'as qu'à mettre mon post sur "réglé" au passage
        Je suis ravi que tu aies résolu ton problème, sincèrement, mais il n'avait malheureusement rien à voir avec le mien.
        Tous les menus fonctionnent parfaitement au niveau des liens ( pas d'erreurs 404, pas de problème d'affichage ). Il y a juste le fait qu'il ne reconnait pas le menu actif dans le menu de gauche.
        Au passage, j'ai testé un truc :
        Lorsque je mets un thème du menu gauche par défaut, à l'arrivée sur le site l'item s'affiche bien comment étant actif. Les autres item, eux ne réagissent pas et toujours pas de trace de id="current" dans le code. l'autre menu se comporte toujours correctement.
        j'y comprends rien
        Je crois que je vais essayer avec une application tierce pour la gestion du SEF pour voir....
        "Qu'est ce que je vais raconter aux enfants?" -- "Dis-leur que papa est parti à la pêche."
        Les dents de la mer - 1975

        Commentaire


        • #5
          Oups désolée
          J'avais mal lu...
          Je me suis un peu emballée sur ce coup là !

          Commentaire


          • #6
            Y a pas de mal
            "Qu'est ce que je vais raconter aux enfants?" -- "Dis-leur que papa est parti à la pêche."
            Les dents de la mer - 1975

            Commentaire


            • #7
              résolu

              ok ok
              Le problème est réglé.
              J'ai juste refait mon menu en changeant l'ID. J'avais certainement employé un caractère ( un tiret je pense ) qu'il n'appréciait pas.
              Le sujet est donc clos...
              "Qu'est ce que je vais raconter aux enfants?" -- "Dis-leur que papa est parti à la pêche."
              Les dents de la mer - 1975

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X