SEO ne fonctionne pas sur 1&1

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] SEO ne fonctionne pas sur 1&1

    Bonjour,

    voilà j'ai un problème récurrent sur les joomla installé sur un hébergement mutualisé 1&1... mon URL rewriting, SEO, ne fonctionne pas... J'ai tout essayé avec ce que je trouvais sur Google, les sois-disant fichiers .htaccess devant fonctionner sur 1&1, et aussi le fichier htaccess pour joomla indiqué dans la FAQ 1&1. Rien n'y fait. Soit je tombe sur une erreur 404 en cliquant sur un lien de mon menu, soit suivant les test de htaccess que j'ai fais, encore pire : erreur 500 même sur la page d'accueil.

    Ma config est la suivante :
    Joomla version 1.5.15
    Hébergement 1&1
    Les 3 paramètres SEO activés (sur OUI)
    à savoir : mon site ne se trouve pas à la racine, mais dans un sous-répertoire nommé /website/

    Voici l'URL du site concerné : http://www.ninetyninedegrees.com/website/

    Je demande votre aide car j'ai sincèrement besoin d'utiliser l'URL rewriting pour bien référencer le site.
    Je vous remercie d'avance pour toutes vos solutions,

    Jérémy.

  • #2
    Même problème que toi, peux-tu me dire si tu as trouvé une solution?
    D'avance merci!

    Commentaire


    • #3
      Houra!
      http://forum.joomla.fr/showthread.php?t=20860

      Commentaire


      • #4
        Merci geraldinechx !

        Je vais tester la solution.

        Pour info, j'avais entendu du mal de 1&1 mais ne voulait pas le croire.
        Je leur ai également adressé un message pour qu'ils me proposent une solution...

        Voilà leur SUPER réponse !

        Monsieur K*******,

        Suite à votre demande, nous vous informons que 1&1 Internet ne propose
        aucune assistance dans la conception d'un site internet.

        Nous n'effectuons que l'hébergement de votre site internet et ne pouvons
        vous assister dans la conception ou le développement de ce dernier. Si
        vous désirez de l'aide dans la conception de ce dernier, nous vous
        invitons à consulter vos proches, des sites internet spécialisés ou de
        contracter auprès de société de création de sites internet pour
        particuliers.

        En vous remerciant de votre compréhension, nous vous souhaitons une
        agréable journée.

        Cordialement,
        Thierry

        Commentaire


        • #5
          Alors... négatif ! ça ne marche pas chez moi. J'ai une erreur 500 internal error... ça saoule

          Commentaire


          • #6
            modif du fichier .htaccess pour 1and1

            je viens de me prendre un peu la tete avec SH404 et 1and1 car je voulais enlever la partie /index.php/ dans mes urls :

            1- j'ai régler 404 sef avec utilisation de htaccess
            2- j'ai activer "url explicites" et "Utiliser le module Apachemod_rewrite (réécriture au "vol" des URLs) " dans la config de joomla.

            Ensuite j'avais des erreurs 500... j'ai alors modifier mon .htaccess avec cette config... (code trouvé dans un forum credit à son auteur... mais je ne l'ai plus retrouvé)

            Code:
            ##
            # @version $Id: htaccess.txt 2368 2006-02-14 17:40:02Z stingrey $
            # @package Joomla
            # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
            # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
            # Joomla! is Free Software
            ##
            
            
            ##################################################
            ##
            # LISEZ CECI COMPLÈTEMENT SI VOUS CHOISISSEZ D'EMPLOYER CE FICHIER
            #
            # la ligne juste en-dessous de cette section : 'options FollowSymLinks peuvent poser des
            # problèmes avec quelques configurations de serveur.  On l'exige pour l'usage du mod_rewrite,
            # mais l'administrateur de serveur a peut être configurer ceci pour que le serveur rejette
            # cette option dans ce fichier (.htaccess). Si le fait de l'employer cause l'erreur 500 à
            # l'affichage de page sur serveur, commenter là avec ceci (ajoutez # au commencement de la
            # ligne), reactualisez la page de votre site dans votre navigateur et examinez vos URLs.
            # Si cela fonctionne sans, cette option a été placé par l'administrateur du serveur et vous
            # n'avez pas besoin de placer celle-ci.
            #
            # A lire si utilisation d'une des deux sections de SEF qui suivent.  Les lignes qui peuvent
            # être décommenter (et utilisé ainsi) ont seulement un seul # (1 dièse). Les lignes avec
            # deux # ne doivent pas être decommenter, dans les sections que vous n'employez pas, toutes les
            # lignes doivent commencer par un #
            #
            # Pour SEF Standard, employez la section standard de SEF.  Vous pouvez commenter
            # toutes les lignes de RewriteCond et réduire la charge de votre serveur si vous
            # n'avez pas les URLs dans votre racine appelée 'componant' ou 'content '
            #
            # si vous employez un tiers SEF ou la solution du noyau SEF
            # decommenter tout des lignes dans la section '3rd Party ou Core SEF'
            #
            ##################################################
            ##
            
            ##### RÉSOLVANT LES PROBLÈMES AVEC les URLs de COMPOSANT qui ne fonctionnent pas #####
            # NOTE SPÉCIALE POUR DES UTILISATEURS DE SMF QUAND CELUI CI EST INTÉGRÉ ET GREFFÉ
            # OU TOUTE SITUATION OÙ LES URLs DE COMPOSANTS NE FONCTIONNENT PAS
            #
            # Dans les deux sections 'Standard SEF', et '3rd Party ou Core SEF' la ligne :
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##facultatif - voir notes##
            # Doit être decommentée. Si vous faites fonctionner Joomla/Mambo depuis
            # un sous-répertoire, le nom du sous-répertoire devra être inséré dans cette
            # ligne.  Par exemple, si votre Joomla/Mambo est dans un sous-répertoire appelé '/test/',
            # changer ceci :
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##facultatif - voir notes##
            # par ceci :
            # RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##facultatif - voir notes##
            #
            ##################################################
            ##
            
            
            ## Peut être commenté si cela cause des erreurs, voir les notes ci-dessus.
            Options +FollowSymLinks
            
            #
            #  mod_rewrite in use
            
            RewriteEngine On
            
            
            #  Décommenter la ligne qui suit si l'URL de votre serveur
            #  n'est pas directement lié aux chemins physiques de dossier.
            #  Mettre à jour le chemin de votre Joomla/Mambo (juste / pour la racine)
            
            #RewriteBase /~username ## ok avec ovh
            RewriteBase /
            
            
            ##########  Debut Standard SEF Section
            ## TOUTES LES lignes (RewriteCond) dans cette section sont seulement requises si vous avez
            ## des dossiers appelés 'content' ou 'component' sur votre serveur
            ## si vous n'en avez pas portant ces noms, commentez-les.
            #
            #RewriteCond %{REQUEST_FILENAME} !-f
            #RewriteCond %{REQUEST_FILENAME} !-d
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]         ##facultatif - voir notes##
            #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            #RewriteRule ^(content/|component/) index.php
            #
            ########## Fin Standard SEF Section
            
            
            ########## Debut 3rd Party or Core SEF Section
            #
            RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]         ##facultatif - voir notes##
            RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule (.*) index.php
            #
            ########## Fin 3rd Party or Core SEF Section
            reste ensuite à le re sécuriser un peu mais ca fonctionne parfait chez 1&1
            Antéane, spécialiste joomla à toulouse : http://www.anteane.fr
            Galerie d'art à Toulouse :http://www.tokade.com
            La tv 3d débarque en France:http://www.tv-3d.fr

            Commentaire


            • #7
              Salut,

              bizarre que tu ne force pas le PHP5 avec la ligne
              Code:
              AddType x-mapp-php5 .php
              adishatz, érix
              https://www.agerix.fr/
              Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : https://www.joomla.fr/association/adherer

              Commentaire


              • #8
                Et si je ne me trompe, le .htaccess est celui d'un site en version 1.0 de Joomla!
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Envoyé par RobertG Voir le message
                  Et si je ne me trompe, le .htaccess est celui d'un site en version 1.0 de Joomla!
                  Yep pour Joomla 1.0 et non 1.5, risque pas de marcher. Pour la réponse de 1&1, c'est normal pour le prix demandé ils ne peuvent pas mettre en place de l'infogérance il leur faudrait un personnel de fou

                  A+

                  Commentaire


                  • #10
                    1and1 SEO et erreur 404

                    je ne trouve pas la solution au problème en ce qui me concerne, malgré les modifications du htaccess proposées, et en forçant l'utilisation de php5...

                    Une erreur 404 est renvoyée dès que je clique sur un lien.

                    Quelqu'un peut-il m'aider ?

                    Commentaire


                    • #11
                      Bienvenue !

                      Si tu es chez 1&1, trois impératifs pour de la réécriture native Joomla! : le passage en PHP5, décommenter la ligne "RewriteBase /" et y ajouter éventuellement le nom du répertoire Joomla! si l'accès au site se fait avec cette référence en plus du nom de domaine, et cocher les trois cases à "Oui" pour les paramètres SEO.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire


                      • #12
                        toujours une erreur 404

                        Envoyé par RobertG Voir le message
                        Bienvenue !

                        Si tu es chez 1&1, trois impératifs pour de la réécriture native Joomla! : le passage en PHP5, décommenter la ligne "RewriteBase /" et y ajouter éventuellement le nom du répertoire Joomla! si l'accès au site se fait avec cette référence en plus du nom de domaine, et cocher les trois cases à "Oui" pour les paramètres SEO.
                        Je pense avoir correctement suivi ces étapes, mais toujours une erreur 404...
                        -Si je n'active pas le module Apachemod_rewrite, cela fonctionne, mais toujours avec index.php dans le nom de l'url.
                        -Si j'active le module Apachemod_rewrite, index.php disparaît de l'url mais l'erreur 404 est renvoyée.
                        -Dans mon htaccess, j'ai ajouté : "AddType x-mapp-php5 .php" pour forcer le php5
                        -j'ai décommenté la ligne "RewriteBase /". Dans un premier temps, j'ai ajouté le nom de répertoire "propaie" : "RewriteBase /propaie" car c'est aussi dans ce répertoire que joomla est installé. Mais comme c'est aussi ce répertoire que j'ai mis en destination avec l'interface d'administration de 1and1, je l'ai ensuite supprimé et suis revenu à "RewriteBase /". Dans les 2 cas, erreur 404...

                        Je dois faire un truc qui ne va pas... une idée ? Merci pour l'aide...

                        Commentaire


                        • #13
                          Tu as bien nommé ton fichier ".htaccess" ?
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            je n'avais pas fait attention à ce petit point devant le nom du fichier... Merci beaucoup ! Ca fonctionne à présent !

                            Commentaire


                            • #15
                              Envoyé par john hoover Voir le message
                              je n'avais pas fait attention à ce petit point devant le nom du fichier... Merci beaucoup ! Ca fonctionne à présent !
                              LMAO Et on dit que le diable est dans les détails, ça se vérifie tout les jours en informatique, bien vu RobertG
                              adishatz, érix
                              https://www.agerix.fr/
                              Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : https://www.joomla.fr/association/adherer

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X