Problème de liens relatifs (peut-être lié à SH404SEF)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème de liens relatifs (peut-être lié à SH404SEF)

    Bonjour,

    j'ai un gros souci qui me mine depuis des heures, alors je m'en remets à la communauté pour m'aider à trouver le problème, SVP :
    Sur mon site, lorsqu'on clique par exemple sur la catégorie "Madagascar" du menu "Protéger", puis sur le titre du 1er article, puis à nouveau sur le même lien du menu, toutes les images disparaissent ! En regardant leur source, je vois que leur url relative ne part plus de la racine du site.

    Parmi mes soupçons :
    • J'ai récemment installé -puis désinstallé depuis- SH404SEF que j'avais utilisé en conservant l'usage du htaccess. Serait-ce lié ?
    • une histoire de slash quelque part ?
    • le paramètre $live_site dans configuration.php (javais dû le saisir à la main pour faire fonctionner SH404SEF, mais je ne sais pas s'il le faut, ni même s'il faut un slash à la fin etc...)
    • autre


    Un grand merci à tous ceux qui voudront bien m'aider.
    Pierre
    Dernière édition par Pi_R à 18/10/2010, 00h38

  • #2
    hm, bizarre ...

    l'image disparait, et le lien vers l'image est suivant :

    http://www.acroporis.fr/proteger-val...ada_sandra.jpg

    c'est bien là qui tu les as?
    Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
    RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

    Commentaire


    • #3
      Non, l'image est là :
      http://www.acroporis.fr/images/stori...ada_sandra.jpg
      Il y a l'alias de la catégorie qui s'est rajouté avant /images/...

      Est-ce qu'au moment de désinstaller sh404sef les paramètres reviennent à ce qu'ils étaient avant l'installation ?

      Commentaire


      • #4
        Bonjour,

        SH404SEF, mais je ne sais pas s'il le faut, ni même s'il faut un slash à la fin etc
        Oui il le faut et non il ne faut pas de / à la fin en fait il faut mettre http://www.acroporis.fr.

        De même le SEO natif de Joomla doit être à Non pour les 3 demandes, le .htaccess doit être activé dans le panneau Quick Start de SH404.

        A+

        Commentaire


        • #5
          Bonsoir,

          c'est bien comme cela que j'avais complété le $live_site, mais par contre j'avais laissé actives les 3 coches du SEO natif de J!
          Mais maintenant que j'ai désinstallé le composant...
          D'où pourrait venir le fait que le pathway des images soit modifié entre la vue article et la vue catégories ?

          Commentaire


          • #6
            Bonsoir,

            Le mieux est d'essayer sans SEO, donc désactives le complètement dans la configuration, vide le cache de Joomla et vois si les erreurs se reproduisent. Regardes aussi si il ne traine pas des plugins SH404.

            A+

            Commentaire


            • #7
              Bonsoir,

              merci zepelin57 de t'être penché sur mon problème.
              J'ai donc regardé et il restait effectivement un plugin, que j'ai désinstallé.
              En désactivant tout le SEO le problème ne se reproduisait plus, mais réapparaissait dès que j'activais les URL explicites.
              En retournant voir les plugins, je me suis souvenu avoir récemment activé le système-cache. Je l'ai désactivé et depuis, tout semble rentré dans l'ordre (?) ce qui est l'essentiel !
              D'ailleurs ces histoires de cache sont assez obscures je trouve, difficile de savoir lesquels activer ou pas. Il y a des conseils à suivre à ce sujet ?

              Commentaire


              • #8
                Envoyé par Pi_R Voir le message
                Bonsoir,

                merci zepelin57 de t'être penché sur mon problème.
                J'ai donc regardé et il restait effectivement un plugin, que j'ai désinstallé.
                En désactivant tout le SEO le problème ne se reproduisait plus, mais réapparaissait dès que j'activais les URL explicites.
                En retournant voir les plugins, je me suis souvenu avoir récemment activé le système-cache. Je l'ai désactivé et depuis, tout semble rentré dans l'ordre (?) ce qui est l'essentiel !
                D'ailleurs ces histoires de cache sont assez obscures je trouve, difficile de savoir lesquels activer ou pas. Il y a des conseils à suivre à ce sujet ?
                gzip & cache = le site se charge plus vite ... site qui rame -> mal vu par googli )))
                Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
                RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

                Commentaire


                • #9
                  Paramètrer le cache

                  Envoyé par nart Voir le message
                  gzip & cache = le site se charge plus vite
                  Il n'y a pas de contre-indication à utiliser le cache sur certains modules ou autre ?
                  Dans ce cas je mets cash cache partout...

                  Commentaire


                  • #10
                    Il n'y a pas de contre-indication à utiliser le cache sur certains modules ou autre ?
                    Attention certains modules/plugins provoquent des erreurs sur certains hébergement dans le cas d'activation du cache a outrance !

                    A+

                    Commentaire


                    • #11
                      OK, merci pour ces précieux conseils.
                      @+

                      Commentaire


                      • #12
                        Envoyé par Pi_R Voir le message
                        Il n'y a pas de contre-indication à utiliser le cache sur certains modules ou autre ?
                        Dans ce cas je mets cash cache partout...
                        pas partout )))) trop, c'est trop

                        pour ce qui est contre-indication, je ne sais pas, vu que j'ai pas eu de problèmes ...
                        Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
                        RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X