url rewriting ne fonctionne qu'à moitié...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • url rewriting ne fonctionne qu'à moitié...

    Bonjour à tous !

    J'ai découvert joomla il y a peu et j'avoue des fois je patauge un peu mais c'est quand même bien pratique

    Alors j'ai donc un soucis avec le rewriting de mes urls, tout se passe bien jusque là, le site est en ligne nickel, rien à dire, les adresses sont les bonnes sauf ... pour une chose ...

    Par exemple : je vais sur cette page : http://**************/42-infogene/29...8aout2008.html

    Je veux revenir à la catégorie informations générales en cliquant sur le lien sous le titre de l'article... et là c'est le drame j'ai une page 404

    Code:
    404 - Article #42 introuvable
    
    Vous ne pouvez pas visiter cette page du fait de :
    
       1. bookmark/favoris périmé
       2. Un moteur de recherche possède un listing périmé pour ce site
       3. une adresse erronée
       4. vous n'avez pas accès à cette page
       5. La ressource demandée n'a pas été trouvée
       6. Une erreur est survenue pendant l'exécution de la requête.
    
    Veuillez essayer l'une des pages suivantes :
    
        * Page d'accueil
    
    Si les difficultés persistent, merci de contacter l'administrateur de ce site.
    
    Article #42 introuvable
    Et pour toutes les catégories c'est pareil lorsque je clique sous le titre d'un article...

    J'ai revérifié le .httaccess, j'ai enlevé / remis le SEF, la réécriture d'adresse au vol est à oui, et le suffixe aux url's aussi.

    Je suis chez OVH, 60GP.

    Alors à part ne plus rendre le lien cliquable, je peux essayer de faire quoi (sans tout cassé comme j'ai déjà fait ) ?

    Merci d'avance pour votre aide
    Dernière édition par flepinou à 10/03/2011, 23h35

  • #2
    Personne n'a d'idée?

    Et si je veux enlever le lien cliquable (ça m'ennuie mais au pire je pourrais le faire ) ça se trouve où?

    S'il vous plait?

    Commentaire


    • #3
      Je pensais trouver une réponse sur le forum

      C'est les vacances ou y'a personne qui a la solution?

      ça le fait sur chaque catégorie sous mes articles, peut importe si la page est en blog ou en section, peut importe les paramètres, ça me met une erreur 404 à chaque fois... c'est super génant pour mon site .

      En fait, il va me chercher l'url comme ça :

      Code:
      http://**************/blagues/37-blagues.html
      Mais si je cliques sur mon lien dans le menu :

      Code:
      http://****************/blagues.html
      Donc la page dans le dossier blagues n'existe pas

      Merci de m'aider s'il vous plait
      Dernière édition par flepinou à 10/03/2011, 23h34

      Commentaire


      • #4
        Moi aussi je suis sur OVH (90plan) et j'ai eu ce problème...

        Voilà comment je l'ai résolu : j'ai activer en même temps URLs explicites (SEF) et Utiliser le module Apachemod_rewrite (réécriture au "vol" des URLs).

        Avant j'ai vérifié que le htacess soit bien configuré.

        Voilà, si ton problème est résolu, merci de le faire savoir...

        Commentaire


        • #5
          Temporairement j'ai enlevé le lien cliquable...

          J'vais chercher le module alors et je te tiens au courant dès que possible, merci

          Commentaire


          • #6
            Je suis chez OVH, et n'ai aucun probleme de rewritting....
            Teste : 404Sef
            et ce .htacces :
            Code:
            ##
            # @version $Id: htaccess.txt 2368 2006-02-14 17:40:02Z stingrey $
            # @package Joomla
            # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
            # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
            # Joomla! is Free Software
            ##
            
            
            #####################################################
            #  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
            #
            # The line just below this section: 'Options FollowSymLinks' may cause problems
            # with some server configurations.  It is required for use of mod_rewrite, but may already
            # be set by your server administrator in a way that dissallows changing it in
            # your .htaccess file.  If using it causes your server to error out, comment it out (add # to
            # beginning of line), reload your site in your browser and test your sef url's.  If they work,
            # it has been set by your server administrator and you do not need it set here.
            #
            # Only use one of the two SEF sections that follow.  Lines that can be uncommented
            # (and thus used) have only one #.  Lines with two #'s should not be uncommented
            # In the section that you don't use, all lines should start with #
            #
            # For Standard SEF, use the standard SEF section.  You can comment out
            # all of the RewriteCond lines and reduce your server's load if you
            # don't have directories in your root named 'component' or 'content'
            #
            # If you are using a 3rd Party SEF or the Core SEF solution
            # uncomment all of the lines in the '3rd Party or Core SEF' section
            #
            #####################################################
            
            #####  SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
            # SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
            # OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
            #
            # In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
            # May need to be uncommented.  If you are running your Joomla! from
            # a subdirectory the name of the subdirectory will need to be inserted into this
            # line.  For example, if your Joomla! is in a subdirectory called '/test/',
            # change this:
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
            # to this:
            # RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
            #
            #####################################################
            
            SetEnv REGISTER_GLOBALS 0
            ##  Can be commented out if causes errors, see notes above.
             Options +FollowSymLinks
            
            #
            #  mod_rewrite in use
            
            RewriteEngine On
            
            
            #  Uncomment following line if your webserver's URL
            #  is not directly related to physical file paths.
            #  Update Your Joomla! Directory (just / for root)
            
             RewriteBase /
            
            
            
            ########## Begin Standard SEF Section
            ## ALL (RewriteCond) lines in this section are only required if you actually
            ## have directories named 'content' or 'component' on your server
            ## If you do not have directories with these names, comment them out.
            #
            #RewriteCond %{REQUEST_FILENAME} !-f
            #RewriteCond %{REQUEST_FILENAME} !-d
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		##optional - see notes##
            #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            #RewriteRule ^(content/|component/) index.php
            #
            ########## End Standard SEF Section
            
            
            ########## Begin 3rd Party or Core SEF Section
            #
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		##optional - see notes##
            RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule (.*) index.php
            #
            ########## End 3rd Party or Core SEF Section
            ########## Begin - Rewrite rules to block out some common exploits
            ## If you experience problems on your site block out the operations listed below
            ## This attempts to block the most common type of exploit `attempts` to Joomla! 
            #                              
            # Block out any script trying to set a mosConfig value through the URL
            RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
            # Block out any script trying to base64_encode crap to send via URL
            RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
            # Block out any script that includes a <script> tag in URL
            RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
            # Block out any script trying to set a PHP GLOBALS variable via URL
            RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
            # Block out any script trying to modify a _REQUEST variable via URL
            RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
            # Send all blocked request to homepage with 403 Forbidden error!
            RewriteRule ^(.*)$ index.php [F,L]
            # 
            ########## End - Rewrite rules to block out some common exploits
            Et dis nous si ca va mieux !

            Commentaire


            • #7
              Je teste vos deux solutions dans la nuit entre temps j'ai eu pas mal à faire

              Merci encore

              edit première solution c'est pareil

              Seconde solution : encore pire les urls se mélangent (je clique sur la section trackmania, je me retrouve sur la page d'accueil générale sans le css ) je vais finir par abandonner

              Réédit ! Merci beaucoup Zitoon

              J'suis juste idiote, j'activais pas sef404 dans la configuration donc tout fonctionne nickel merci

              (par contre j'ai gardé mon .httpacces :
              Code:
              ##
              # @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $
              # @package Joomla
              # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
              # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
              # Joomla! is Free Software
              ##
              
              
              #####################################################
              #  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
              #
              # The line just below this section: 'Options +FollowSymLinks' may cause problems
              # with some server configurations.  It is required for use of mod_rewrite, but may already
              # be set by your server administrator in a way that dissallows changing it in
              # your .htaccess file.  If using it causes your server to error out, comment it out (add # to
              # beginning of line), reload your site in your browser and test your sef url's.  If they work,
              # it has been set by your server administrator and you do not need it set here.
              #
              #####################################################
              
              ##  Can be commented out if causes errors, see notes above.
              Options +FollowSymLinks
              
              #
              #  mod_rewrite in use
              
              RewriteEngine On
              
              
              #  Uncomment following line if your webserver's URL
              #  is not directly related to physical file paths.
              #  Update Your Joomla! Directory (just / for root)
              
              # RewriteBase /
              
              
              ########## Begin - Joomla! core SEF Section
              #
              RewriteCond %{REQUEST_FILENAME} !-f
              RewriteCond %{REQUEST_FILENAME} !-d
              RewriteCond %{REQUEST_URI} !^/index.php
              RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
              RewriteRule (.*) index.php
              RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
              #
              ########## End - Joomla! core SEF Section
              
              
              ########## Begin - Rewrite rules to block out some common exploits
              ## If you experience problems on your site block out the operations listed below
              ## This attempts to block the most common type of exploit `attempts` to Joomla!
              #
              # Block out any script trying to set a mosConfig value through the URL
              RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
              # Block out any script trying to base64_encode crap to send via URL
              RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
              # Block out any script that includes a <script> tag in URL
              RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
              # Block out any script trying to set a PHP GLOBALS variable via URL
              RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
              # Block out any script trying to modify a _REQUEST variable via URL
              RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
              # Send all blocked request to homepage with 403 Forbidden error!
              RewriteRule ^(.*)$ index.php [F,L]
              #
              ########## End - Rewrite rules to block out some common exploits
              J'espère que ça posera pas de soucis parce que je n'y comprends pas grand chose mais le tiens ne voulais pas faire ce qu'il fallait )
              Dernière édition par flepinou à 08/08/2008, 01h16

              Commentaire


              • #8
                Super ! Bonne continuation sur J!

                Commentaire


                • #9
                  Bonjour
                  Je ne vais pas ouvrir un sujet puisque je pense que c'est la suite de sef404

                  Alors cet après midi j'ai une drôle d'erreur :

                  Code:
                  RLDiskCache[321]='index.php?option=com_content&Itemid=98&catid=53&id=228&lang=fr&view=article#Trucs-et-Astuces/Petit-Coin-Cuisine/nolifemangeaussi.html#0'; ?>
                  Ce qui me donnait des erreurs 500 sur tout mon site sauf l'admin et la page d'accueil

                  Donc j'ai désactivé le cache des urls dans sef404 et je me demande si c'est bien ce qu'il fallait faire ou pas?

                  et ça change quoi d'activer ou non le cache url dans sef404? (j'ai pas compris en anglais )

                  Merci d'avance

                  Commentaire


                  • #10
                    Tu peux le désactiver... Il est juste là pour "accélérer" les redirections...

                    Commentaire


                    • #11
                      d'accord merci donc j'ai pas fait de bêtises

                      Merci encore

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X