Free et le rewriting d'url ...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Free et le rewriting d'url ...

    Bonjour tout le monde !

    C'est ici ma première requête sur ce magnifique forum !

    Donc comme dit dans le titre de ce sujet : j'ai un soucis de rewriting d'url avec mon site hébergé chez free.

    Vous allez me dire "tu as cherché avant de demander ?", la réponse est un grand oui, j'ai cherché pendant un bon moment, j'ai trouvé un semblant de solution ici : http://forum.joomla.fr/showthread.ph...highlight=free, mais la solution donnée en page 2 par François ne fonctionne pas chez moi ... Toujours des erreurs 404 partout ...

    Donc je vous demande si vous avez une solution à ce problème, car le fait de voir des liens du type : "http://univers.ordi.free.fr/index.php/forum" me gêne beaucoup pour la suite de la conception de mon site ... Je préférerai largement "http://univers.ordi.free.fr/forum"

    Voici le lien de mon site :

    http://univers.ordi.free.fr

    Je souhaiterai donc que vous m'indiquiez la marche à suivre pour remédier à ce problème, soit grâce à un nouveau module/composant/extension de joomla! soit grâce à une manip' manuelle.

    Je tiens à préciser que j'ai déjà essayé avec JoomSEF et sh404sef.

    Merci d'avance pour votre soutien
    Dernière édition par Killian à 29/09/2008, 21h55
    Site d'aide en informatique (en construction) :

    http://univers.ordi.free.fr/

  • #2
    Personne ne peut m'aider ? Me donner une piste ? Me dire que c'est totalement impossible ? (Ce qui ne l'est pas ).
    Site d'aide en informatique (en construction) :

    http://univers.ordi.free.fr/

    Commentaire


    • #3
      Eeeee c'est normal que je n'ai pas de réponse ... ? Ça me change du support de phpBB , c'est dommage
      Site d'aide en informatique (en construction) :

      http://univers.ordi.free.fr/

      Commentaire


      • #4
        Envoyé par Killian Voir le message


        Vous allez me dire "tu as cherché avant de demander ?", la réponse est un grand oui, j'ai cherché pendant un bon moment, j'ai trouvé un semblant de solution ici : http://forum.joomla.fr/showthread.ph...highlight=free, mais la solution donnée en page 2 par François ne fonctionne pas chez moi ... Toujours des erreurs 404 partout ...
        En utilisant, à la lettre, la méthode proposée par François, ça marche sur mon site:
        http://cirrus.montgolfiere.free.fr/

        Commentaire


        • #5
          Oui mais à l'étape 4 je bloque :

          # Modifier dans le fichier index.php
          Dans le fichier index.php à la racine, ajouter la ligne :
          Code :
          header("Status: 200 OK", false, 200);
          Je ne trouve pas cette ligne, je ne trouve même pas le mot "header" ...
          Site d'aide en informatique (en construction) :

          http://univers.ordi.free.fr/

          Commentaire


          • #6
            Je l'ai simplement rajouté comme ça:
            * Joomla! is free software. This version may have been modified pursuant
            * to the GNU General Public License, and as distributed it includes or
            * is derivative of works licensed under the GNU General Public License or
            * other free or open source software licenses.
            * See COPYRIGHT.php for copyright notices and details.
            */

            header("Status: 200 OK", false, 200);

            Commentaire


            • #7
              Et bien ça ne fonctionne décidément pas ...

              Je vais reprendre étape par étape :

              1) Installer le composant sh404SEF
              Là aucun soucis l'installation se déroule très bien.

              2) Création du fichier .htaccess


              Créer un ficher .htaccess à mettre à la racine de votre site web avec le code suivant :

              Code :
              php 1
              Options -Indexes
              <Files .htaccess>
              order allow,deny
              deny from all
              </Files>
              ErrorDocument 404 /
              ErrorDocument 405 /index.php
              ErrorDocument 500 /index.php
              ErrorDocument 403 /index.php
              ErrorDocument 303 /index.php
              Idem j'ai créé et uploadé le fichier .htaccess comme il faut.

              3) Configurer le composant "sh404SEF"
              Dans site / Configuration du site / SEO Mettez 'URLs explicites (SEF):' à Oui Dans composant / Sh404SEF Cliquez sur "Cliquez ici pour l’interface avancée (affiche tous les paramètres disponibles)" Dans "Configuration", passez Activé à Oui Dans l'onglet "Avancé", passez 'Mode de ré-écriture' à 'avec .htaccess (mod_rewrite)' Dans l'onglet 'Composant', si vous utilisez communauty builder, je vous conseille de mettre 'comprofiler' à 'passer' . Il n'y aura pas d'url rewriting pour CB, mais vous pourrez toujours vous connecter à votre site ! Sinon, le login est impossible Si vous utilisez Xmap, mettez aussi à passer, sinon votre sitemap ne marchera plus. Et pareil pour Datso où vous ne pourrez plus poster de photo s'il est actif. Si d'autres composants posent des problèmes, mettez-les aussi à 'passer'
              - SEO "URLs explicites (SEF) validé.
              - Activation de Sh404SEF effectuée.

              En ce qui concerne la compatibilité des composants je ne sais pas du tout si un composant n'est pas compatible ...

              Voici la liste des composants affichés par Sh404SEF :

              artforms
              contact
              content
              easycaptcha
              joomap
              newsfeeds
              poll
              search
              spsnewsletter
              user
              weblinks
              wrapper
              Je viens d'essayer de tout mettre à "passer" mais c'est encore pire : j'ai une page blanche avec écrit en gros "OK" et en anglais "La redirection se fait à l'adresse suivante :" ça m'affiche le lien que je veux (sans le index.php) et quand je clique dessus rebelotte "erreur 404" ...

              4) Modifier dans le fichier index.php
              Dans le fichier index.php à la racine, ajouter la ligne :
              Code :
              header("Status: 200 OK", false, 200);
              de la manière suivante :
              Code :

              echo $k+1 . "\n" . $sql . '<hr />';
              }
              echo '</pre>';
              }

              header("Status: 200 OK", false, 200);

              doGzip();
              ?>
              Cette étape est importante, sinon vos URL fonctionnent bien mais ne seront pas indexé par Google.
              Là j'ai fais comme tu as dis :

              * Joomla! is free software. This version may have been modified pursuant
              * to the GNU General Public License, and as distributed it includes or
              * is derivative of works licensed under the GNU General Public License or
              * other free or open source software licenses.
              * See COPYRIGHT.php for copyright notices and details.
              */

              header("Status: 200 OK", false, 200);
              Je n'ai rien touché d'autre.
              5) Pb validation dans les Outils Google pour les webmaster
              Si vous avez choisi la méthode de la validation de votre site web en ayant déposé un fichier FTP sur votre site. Celui-ci ne sera plus considéré comme validé. Pour le validé de nouveau, employer la 2ème méthode de Google : celle qui utilise les Meta. Dès que les Meta sont ajoutés, vous pouvez relancer une vérif et là, ça doit marcher.
              Bon là je pense qu'il va falloir que je réinitialise comme j'avais avant de me lancer dans ce tuto ...

              6) Utilisez les Meta de Sh404SEF
              Si vous activer le module de gestion des meta de Sh404SEF, vous devez enlever la compression Gzip dans vos pages Web. Dans la partie Administrator : Site / Configuration du site /Onglet Serveur / mettez 'Compression GZIP des pages:' à non. Si vous ne faites pas cela, votre site n'affichera plus une seule pas web et vous mettra une erreur sur GZIP
              La compression GZIP n'était pas activée, je l'ai laissé désactivée et j'ai laissé activé la gestion méta de Sh404SEF, mais ça ne fonctionne pas, j'ai essayé en désactivant la gestion méta et en laissant toujours désactivé la compression GZIP, idem ça ne fonctionne pas.

              Voilà voilà.
              Site d'aide en informatique (en construction) :

              http://univers.ordi.free.fr/

              Commentaire


              • #8
                Je suis très très loin d'être un spécialiste et je ne vois rien de particulier dans ce que tu as fait. J'ai l'impression que j'ai fait la même chose...
                Désolé

                Commentaire


                • #9
                  C'est dommage ...

                  Je pense donc que ça vient des composants, mais si quelqu'un a une idée qu'il se manifeste !!!

                  Mici
                  Site d'aide en informatique (en construction) :

                  http://univers.ordi.free.fr/

                  Commentaire


                  • #10
                    Quelqu'un connaît-il la compatibilité de sh404SEF avec les composants que j'ai installé ?
                    Site d'aide en informatique (en construction) :

                    http://univers.ordi.free.fr/

                    Commentaire


                    • #11
                      Bon et bien vous n'allez jamais le croire mais je viens d'activer le "Apache_mod_rewrite" (parce que oui je ne l'avais pas activé ... ) et ça fonctionne nickel ... Mais par contre avec sh404SEF désactivé ... Je l'ai même désinstallé, viré tous les fichiers en rapport avec sur mon ftp, et ça fonctionne nickel ... J'ai laissé les modifs sur le .htaccess et le index.html

                      Bon après je ne sais pas si ça n'engendre pas de soucis, quelqu'un sait si ça peut amener une ******* ?

                      EDIT : j'ai tout de même un petit soucis, pour le lien du forum que j'avais mis en wrapper maintenant ça me l'affiche en page complète, comme si ça ne me prenait plus en compte le wrapper ... Mais j'y tiens à mon wrapper !

                      EDIT 2 : c'est bon pour le forum ! Il fallait juste que je remplace l'alias "forum" par un autre, je pense que c'est parce que ça envoyait sur le même lien que si on voulait y accéder directement (car sur le ftp c'est dans root/forum).

                      EDIT 3 : j'ai encore un mini-soucis, lorsque je vais sur un article je vois son ID juste avant son nom, il me semble déjà avoir vu ce soucis chez d'autres personnes, mais si vous avez une solution pour free avant que j'essaie celles déjà données pour d'autres hébergeurs et que je casse tout je vais attendre vos paroles
                      Dernière édition par Killian à 10/10/2008, 19h49
                      Site d'aide en informatique (en construction) :

                      http://univers.ordi.free.fr/

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X