Communicator impossible de s'inscrire

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Communicator impossible de s'inscrire

    Bonjour,

    J'ai un site sous Joomla 1.5.14

    Je voudrais pouvoir envoyer des Newsletters au personnes qui s'inscrivent au module ( sans être inscrit au site ).

    Cependant lorsque j'entre mon mail et valide mon inscription à la Newsletter ,Joomla me dit que je ne suis pas connecter .

    J'ai déjà lu se Post mais ça ne correspond pas http://forum.joomla.fr/showthread.php?t=72463

    Quelqu'un aurait-il déjà eu se problème ?

    d'avance merci
    Dernière édition par Guik à 20/10/2009, 07h48

  • #2
    Il y avait ce problème sur une version RC ... Actuellement 2.02 sauf erreur !!
    As-tu la dernière version avec son module ?
    Règlement du forum : http://forum.joomla.fr/faq.php
    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
    http://www.iwannaclick.org

    Commentaire


    • #3
      Non je suis en version 2.0 car elle est en français mais je vais tester la version finale 2.0.2

      Merci

      Commentaire


      • #4
        Je viens de tester en installant la version 2.0.2 prise à l'adresse suivante : http://extensions.joomla.org/extensi...ewsletter/4600

        cependant je me retrouve avec le même problème .

        auriez vous une solution ?

        Commentaire


        • #5
          Boujours comme je sais pas trop à qui m'adresse je poste ici!
          Voilà vous utilsé sur ce site des TAG,ou balise. Je voudrais moi aussi pouvoir utiliser un Tag pour renvoyer un texte d'article de mon site dans une newletter de communicator mais voilà je suis plus graphiste que programmeur.
          J'ai trouvé dans le pack ceci sous le fichier Communicator.js
          ce code

          Code:
          function addContentTag(){
            var form = document.adminForm;
            var tempval=eval("document.adminForm.content_tag");
            if(form.contentid.options[form.contentid.selectedIndex].value != 0) {
              //alert(form.contentid.options[form.contentid.selectedIndex].value);
              var text = '[CONTENT id="' + form.contentid.options[form.contentid.selectedIndex].value + '"]';
              
              insertAtCursor(form.nl_content, text);
          
            }
            //form.contentid.options[0].selected = true;
          }
          
          
          function insertAtCursor(myField, myValue) {
            //IE support
            if (document.selection) {
              myField.focus();
              sel = document.selection.createRange();
              sel.text = myValue;
            }
            //MOZILLA/NETSCAPE support
            else if (myField.selectionStart || myField.selectionStart == '0') {
              var startPos = myField.selectionStart;
              var endPos = myField.selectionEnd;
              myField.value = myField.value.substring(0, startPos)
              + myValue
              + myField.value.substring(endPos, myField.value.length);
            } else {
              myField.value += myValue;
            }
          }
          Quelqu'un peu t'il me dire les modifs à effectuer pour que je script fonctionne ou le placer et comment rediger le tag dans ma lettre ce doit être un truc comme [CONTENT id='']mais sans modifier la page celà ne fonctionne pas

          J'ai essayé en mettant
          Code:
          if(form.contentid.options[form.contentid.selectedIndex].value != 1)
          mais aussi avec ceci
          Code:
          function addContentTag(){
            var form = document.adminForm;
            var tempval=eval("document.adminForm.content_tag");
            if(form.contentid.options[form.contentid.selectedIndex].value != 0) {
              alert(form.contentid.options[form.contentid.selectedIndex].value);
              var text = '[CONTENT id="' + form.contentid.options[form.contentid.selectedIndex].value + '"]';
              
              insertAtCursor(form.nl_content, text);
          
            }
            form.contentid.options[0].selected = true;
          }
          
          
          function insertAtCursor(myField, myValue) {
            //IE support
            if (document.selection) {
              myField.focus();
              sel = document.selection.createRange();
              sel.text = myValue;
            }
            //MOZILLA/NETSCAPE support
            else if (myField.selectionStart || myField.selectionStart == '0') {
              var startPos = myField.selectionStart;
              var endPos = myField.selectionEnd;
              myField.value = myField.value.substring(0, startPos)
              + myValue
              + myField.value.substring(endPos, myField.value.length);
            } else {
              myField.value += myValue;
            }
          }
          Sans résultat
          Quelqu'un peu t'il m'aider, je suis pleine de bonne volonté mais là je sèche??

          Commentaire


          • #6
            Question: ton but est de pouvoir mettre dans ta news du contenu, c'est ça ?
            Règlement du forum : http://forum.joomla.fr/faq.php
            Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
            Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
            http://www.iwannaclick.org

            Commentaire


            • #7
              Envoyé par Guik Voir le message
              Je viens de tester en installant la version 2.0.2 prise à l'adresse suivante : http://extensions.joomla.org/extensi...ewsletter/4600

              cependant je me retrouve avec le même problème .

              auriez vous une solution ?
              Il y a une erreur ? ou autre ?
              Règlement du forum : http://forum.joomla.fr/faq.php
              Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
              Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
              http://www.iwannaclick.org

              Commentaire


              • #8
                En fait lorsque je met mon mail et valide il me demande de me connecter (au front end) .

                Du coup si je veux m'inscrire et recevoir les newsletter je doit m'inscrire au site se qui n'est pas souhaité.

                Il est possible de faire le test a cette adresse http://www.ville-larochesuryon.fr/jeunes

                Commentaire


                • #9
                  Je viens de m'inscrire: user testsharky
                  Est-ce qu'il dans les abonnée de communicator ?
                  As-tu installer un composant ACL qui gère les droits (comme GMaccess) ?
                  En faite après inscription je suis renvoyer sur index.php?option=com_communicator&Itemid=138
                  As-tu changer cette URL après inscription ?
                  Es-tu sur d'utiliser la dernière version du module ?
                  mod_communicatorsubscribe, 2.0.0, 2009-05-10
                  Règlement du forum : http://forum.joomla.fr/faq.php
                  Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                  Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                  http://www.iwannaclick.org

                  Commentaire


                  • #10
                    Tiens!! encore autre chose : as-tu SH404SEF ?

                    Si oui désactives-le pour voir !!
                    Dernière édition par sharky à 15/10/2009, 19h36
                    Règlement du forum : http://forum.joomla.fr/faq.php
                    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                    http://www.iwannaclick.org

                    Commentaire


                    • #11
                      J'utilise ni SH404SEF ni de composant ACL par contre j'utilise le composant de rewriting par défaut de Joomla.

                      En desactivant SEO ça ne change rien à mon problème.

                      Pour le module je suis bien sur la bonne version et je n'ai pas changer l'URL de redirection.

                      Je n'ai actuellement pas d'abonné dans communicator mais je vais tester d'en mettre un .

                      Commentaire


                      • #12
                        Pour SEO tu as activer 1 seule, les 3 ?
                        As-tu changer le htaccess.txt en .htaccess à la racine ?
                        Le fait d'avoir activer/désactiver, il faut vider le cache ou attendre 15 minutes !!!

                        En tout cas chez moi il fonctionne, c'est un nouveau site ?
                        tu as tout les prérequis PHP Joomla OK ?
                        Version PHP ?
                        Mode de sécurité (safe mode): Désactivé
                        Afficher les erreurs: Désactivé
                        Short open tags: Activé
                        Fichiers transférés: Activé
                        Magic quotes: Désactivé
                        Variables globales (register globals): Désactivé
                        Tampon de sortie (output buffering): Désactivé
                        Session auto start: 0
                        XML activé: Oui
                        Zlib activé: Oui
                        Dernière édition par sharky à 15/10/2009, 19h53
                        Règlement du forum : http://forum.joomla.fr/faq.php
                        Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                        Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                        http://www.iwannaclick.org

                        Commentaire


                        • #13
                          Pour SEO j'ai activée 1 et 2 (seul le suffixe d'URL est désactivé) et le htaccess à été renommé.

                          Je vais retenter en le désactivant et en re-vidant le cache histoire d'être sur.

                          Commentaire


                          • #14
                            En tout cas chez moi il fonctionne, c'est un nouveau site ?
                            tu as tout les prérequis PHP Joomla OK ? Qu'appelle tu pré-requis ? je suis à mon 3-4 site Joomla et ça fait environ 1 an que je le bidouille Joomla et j'ai une licence pro WebDev
                            Version PHP ? php 5 me semble t'il
                            Mode de sécurité (safe mode): Désactivé Je ne sait pas je regarderai demain au taf
                            Afficher les erreurs: Désactivé Je ne sait pas je regarderai demain au taf
                            Short open tags: Activé Oui
                            Pour tout le reste je ne sait pas je regarderai demain
                            Fichiers transférés: Activé
                            Magic quotes: Désactivé
                            Variables globales (register globals): Désactivé
                            Tampon de sortie (output buffering): Désactivé
                            Session auto start: 0
                            XML activé: Oui
                            Zlib activé: Oui
                            Désoler j'avais pas vu la deuxième partie du message. je repond en rouge à coter des question

                            Le site à environ 1 mois déjà
                            Dernière édition par Guik à 15/10/2009, 20h10

                            Commentaire


                            • #15
                              Je viens de regarder les paramètres sont bon par contre j'ai fait des essais avec ccNewsletter cela fonctionne, mais je perd l'édition de newsletter en FrontEnd.

                              J'ai aussi fait un test en local avec une version tout propre de Joomla 1.5.14 et Communicator (cela fonctionne) j'ai ensuite ajouter mon template (cela fonctionne toujours) j'ai ajouter les plugins BCA RSS et Bookmark (cela fonctionne toujours).

                              Je me demande si mon problème ne pourrais par être causé par un Composant mal désinstallé .

                              je vais tester en copiant ma base .
                              Dernière édition par Guik à 16/10/2009, 09h57 Raison: Le test de copie de base n'a pas été fructueux :(

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X