Joomladay francophone 2018 à Paris 18 et 19 mai

Nouvelle position dans Ja purity

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Nouvelle position dans Ja purity

    Bonjour!
    je cherche à ajouter une nouvelle position dans mon Template ja purity. la position devra être pareille a celle ou se place les articles mais il devra être au dessus de tous les article.
    jai essayé plusieusr guide, mais soie la position n'est pas pris en compte par les modules même en l'ajoutant dans le fichier xml.
    soie cette position se creer mais prend trop de place car empiete i sur la barre des menu.

    quelqu'un pourrait-il m'aider svp ?
    Dernière édition par pazogueye à 04/08/2009, 17h02

  • #2
    fait une petite recherche, j'ai déjà du répondre au moins dix fois à cette question

    Commentaire


    • #3
      Allez, je t'aiguille quand même :
      http://forum.joomla.fr/showpost.php?...6&postcount=13

      Commentaire


      • #4
        Envoyé par Dens Voir le message
        Merci pour ta réponse.
        j'ai essayer de suivre ce guide, mais le problème c'est que la position apparait au niveau du Template, mais les modules ne s'y place pas quand on choisi cette nouvelle emplacement.

        Commentaire


        • #5
          plus de précision, je ne comprends pas ce qui coince :
          • la posiiton n'apparait pas dans la gestion de modules
          • le module ne s'affiche pas
          • le module ne s'affiche pas correctement

          Lien vers le site ?

          Commentaire


          • #6
            Je develope le site en local pour l'instant.
            -la position apparait quand je fait previsualisé le template.
            -la position apparait aussi dans la liste des positions proposés pour placer les modules.

            mais le probleme c'est que jai installer le module gavick photoslide gk2. quand je configure ce module et que je choisi de le placer a la position banner2 (qui est la nouvelle position créer) il refuse de s y mettre.

            Commentaire


            • #7
              copie ton index.php (juste la partie content).
              Parce que là je ne vois pas, ça doit fonctionner, je viens de vérifier

              Edit : truc tout con, tu as activé ton module ?

              Commentaire


              • #8
                oui j'ai activer le module.
                Code PHP:
                <!-- BEGIN: CONTENT -->
                        <div id="ja-contentwrap">
                        <div id="ja-content">

                            <jdoc:include type="message" />

                            <?php if(!$tmpTools->isFrontPage()) : ?>
                            <div id="ja-pathway">
                                <jdoc:include type="module" name="breadcrumbs" />
                            </div>
                            <?php endif ; ?>
                            
                                <?php if($this->countModules('banner2')) : ?>
                        <div id="banner2">
                            <jdoc:include type="modules" name="banner2" />
                        </div>
                    <?php endif; ?>        
                            <jdoc:include type="component" />

                            <?php if($this->countModules('banner')) : ?>
                            <div id="ja-banner">
                                <jdoc:include type="modules" name="banner" />
                            </div>
                            <?php endif; ?>

                        </div>
                        </div>
                        <!-- END: CONTENT -->

                Commentaire


                • #9
                  tu as essayé de publié ton module ailleurs pour voir si ce n'est pas un paramètre du module qui pose problème (width et height par exemple) ?

                  Commentaire


                  • #10
                    oui jai assayer sur d'autres positions comme left right ou hornav et ca marche.
                    jai aussi essayer de placer d'autres modules sur la position banner2 mais ca ne marche.
                    Dernière édition par pazogueye à 03/08/2009, 21h37

                    Commentaire


                    • #11
                      attention, peut être problème de syntaxe différente dans templateDetails.xml et index.php
                      ...vérifie que l'orthographe est la même : banner2

                      Commentaire


                      • #12
                        Envoyé par Dens Voir le message
                        attention, peut être problème de syntaxe différente dans templateDetails.xml et index.php
                        ...vérifie que l'orthographe est la même : banner2
                        Merci beaucoup en effet c'était un probleme de syntaxe. j'avais ecrit: <position> banner2 </position>avec espace dans le fichier templatedetail.xml alors que c'était sans espace dans le fichier index.php.
                        Merci encore, mon probleme est Résolu

                        Commentaire


                        • #13
                          Envoyé par pazogueye Voir le message
                          Merci beaucoup en effet c'était un probleme de syntaxe. j'avais ecrit: <position> banner2 </position>avec espace dans le fichier templatedetail.xml alors que c'était sans espace dans le fichier index.php.
                          Merci encore, mon probleme est Résolu
                          Salut,
                          si il est résolu, veux-tu passer ton sujet en [Réglé]
                          Merci

                          j!lm
                          http://www.joomlabox.com

                          Commentaire


                          • #14
                            Envoyé par pyor Voir le message
                            Salut,
                            si il est résolu, veux-tu passer ton sujet en [Réglé]
                            Merci

                            j!lm
                            comment s'il te plait ?

                            Commentaire


                            • #15
                              Envoyé par pazogueye Voir le message
                              comment s'il te plait ?
                              Bonjour,

                              cf http://forum.joomla.fr/announcement.php?f=112

                              TT
                              Templates Joomla sur mesure & responsive http://alphadesign.fr/creation-de-sites-templates-joomla-responsive.html
                              Formations Joomla http://alphadesign.fr/services/formations-joomla.html
                              Formations Joomla conventionnées: DIF et autres formations continues.
                              Checklist SEO pour Joomla http://alphadesign.fr/joomla/checklist-seo-pour-joomla-referencement-joomla.html

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X