Joomladay francophone 2018 à Paris 18 et 19 mai

modifier affichage articles mode blog

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • modifier affichage articles mode blog

    Bonjour,

    J'ai lu plusieurs threads sur le sujet mais aucun ne m'a apporté de réponse.
    J'ai créé un élément de menu pour afficher les articles d'une catégorie en mode blog.

    Le problème est que je voudrais supprimer l'affichage "principal" pour que tous les articles soient rangés en colonne. Mais, que je mette 0 ou 10 dans les paramètres du menu, cela ne change rien. Le premier article est toujours sur toute la largeur et les suivants en colonne.

    J'ai pensé à modifier le css, mais l'inconvénient est que l'article principal est dans une <div class="contentpaneopen"> . Et si je modifie cette div, cela va aussi modifier l'affichage de la page d'accueil (qui me convient comme elle est).

    Merci pour votre aide

    edit : j'utilise le teplate Ja Purity, mais j'ai le même problème avec les autres templates que j'ai testé
    Dernière édition par glouglou2 à 17/08/2009, 13h26

  • #2
    bizarre ton problème, chez moi ça marche sur ja_purity lorsque je mets 0 comme paramètre pour #principal

    Commentaire


    • #3
      Je me suis dit que c'était peut-être à cause de ma page d'accueil qui est en mode blog avec un article en principal et les autres en colonnes.

      Ce n'est peut-être pas possible d'avoir 2 configurations différentes pour le mode blog ?

      Commentaire


      • #4
        non, pas de souci normalement !

        Commentaire


        • #5
          J'ai bien lu ce topic (même si je veux le contraire de ce qui est décrit)
          https://forum.joomla.fr/showthread.php?t=75712

          Je n'ai qu'un seul menu pointant vers cette catégorie, et qu'une seule catégorie pointée par ce menu (c'est clair ? lol)
          J'ai bien coché "entre" ds "tri selon plusieurs colonnes"

          Ce qui bizarre, c'est que si j'essaye l'inverse (ne mettre qu'une seule colonne et tous les articles en "principal" ... ça ne marche pas non plus.

          On dirait que les paramètres ne sont pas pris en compte (pourtant je sauvegarde et vide les caches).

          ...

          Commentaire


          • #6
            Bonjour,
            tu es sûr de modifier le bon élément de menu ? Tu n'aurais pas deux éléments de menus au format blog pour cette catégorie ?
            Regarde l'url de la page affichée, relève le n° derrière &Itemid= et compare le au n° dans la colonne ID qui s'affiche dans la liste des éléments de menu.
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Bonjour,

              Merci pour ta suggestion Grang Schtoumpf.

              Je n'ai qu'un élément de menu pour cette catégorie. Mais en voulant voir le n° de l'ID, le problème s'est résolu.

              J'ai désactivé sh404SEF et effacé les URL ... et les changements ont été pris en compte

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X