Joomladay francophone 2018 à Paris 18 et 19 mai

JA_Purity_II et Mega menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • JA_Purity_II et Mega menu

    Je tente de d'insérer le module de connexion (celui de Community Builder) dans un menu :

    Je me suis basé sur le tuto de Joomlart

    Je créé un menu de type "separator" puis lui donne ce titre :
    Connexion [cols = 1 modname = Connexion] ou s'inscrire

    Quand je clique le menu il ne se passe absolument rien

    Une piste ?

    Amicalement

    Stéphane
    Dernière édition par sfourre à 05/12/2009, 21h13

  • #2
    Un lien à ns montrer ?

    je suis arrivé à le configurer en suivant ce tuto justement, c bizarre
    http://annuaire-rank.fr/jomap/

    Commentaire


    • #3
      Comme je ne suis pas chien, je vais te montrer la partie admin de mon menu, ça pourras peut être t'aider :



      Au lieu de modmane, tente

      [cols = 1 modid = id_du_module]
      Dernière édition par Peter_P à 05/12/2009, 15h00

      Commentaire


      • #4
        Salut,

        je vois que tu as mis [cols = 1 modname = Connexion]

        Exemple avec le module de connexion de joomla.
        On va dire que celui-ci se nomme Connexion et son type est mod_login.

        Dans le menu il ne faut pas mettre son titre mais son type en supprimant mod_

        Connexion [cols=1 modname=login] ou s'inscrire

        Tu peux le faire avec l'ID du module aussi

        Connexion [cols=1 modid=18]ou s'inscrire
        Le numéro d'ID est ici donné à titre indicatif évidemment.

        Evite les espace aussi de chaque coté de " = "

        edit: grilled

        Commentaire


        • #5
          Envoyé par still31 Voir le message
          Evite les espace aussi de chaque coté de " = "
          +1 !

          Préfère cette syntaxe plutôt :
          [cols=1 modid=id_du_module]


          Envoyé par still31 Voir le message
          edit: grilled
          Mais non, voisin !

          @+

          Pierre

          Commentaire


          • #6
            Pas un problème d'espaces ?
            il me semblait avoir lu qu'il ne fallait pas d'espace avant et après []
            de même cols=1 et non cols = 1

            Edit : grillé aussi

            Commentaire


            • #7
              Je viens de me rappeler que j'avais procéder différemment pour afficher un module, j'avais eu quelques problèmes en utilisant la méthode simple du tuto.

              Un peu comme sur la capture de Peter_P en fait :




              Mais non, voisin !


              [hs]
              Concepttoulouse > Tarbes ?

              Anciennement toulousain ?
              [/hs]

              Commentaire


              • #8
                Je reviens sur ce j'ai dit précédemment, d'après l'auteur, il faut un espace avant []
                Mais visiblement, ça fonctionne aussi si on n'en met pas (déjà fait l'essai)

                Commentaire


                • #9
                  Oups, je vous laisse 5 minutes, pour aller acheter 3 cadeaux de Noël et vous en profitez pour vous éclater. En tous cas, Peter, Still et Dens je vous remercie pour votre diligence.

                  Puisquu'il s'agit du module mod_cblogin nommé Connexion ID n° 17 J'ai essayé :
                  Connexion [cols = 1 modname = cblogin] ou s'inscrire -> HS
                  Connexion [cols = 1 modname = Connexion] ou s'inscrire -> HS
                  Connexion [cols = 1 modid = 17] ou s'inscrire -> HS
                  Connexion [cols = 1 modid = 17] -> HS
                  Connexion [cols=1 modid=17] -> OK enfin
                  Connexion [cols=1 modid=17] ou s'inscrire -> Oups c'est la bonne

                  Bon au final le problème étaient les espaces avant et après le signe "="

                  Bon si cela vous intéresse tout de même : le site

                  Il me reste un petit problème de présentation avec la largeur de la colonne left

                  Amicalement

                  Stéphane
                  Fichiers joints

                  Commentaire


                  • #10
                    Cette fois c'est la désillusion

                    Le module est bien publié dans le menu, mais reste en left.

                    Donc je désactive le module. Il est plus en left, mais plus non plus dans le menu. grrr

                    Bon comment le garder dans le menu et le sortir du left ?

                    Amicalement

                    Stéphane

                    Commentaire


                    • #11
                      Envoyé par sfourre Voir le message
                      Cette fois c'est la désillusion

                      Le module est bien publié dans le menu, mais reste en left.

                      Donc je désactive le module. Il est plus en left, mais plus non plus dans le menu. grrr

                      Bon comment le garder dans le menu et le sortir du left ?

                      Amicalement

                      Stéphane
                      publie ton module de menu en position hornav

                      Commentaire


                      • #12
                        Nickel, je te remercie

                        Amicalement

                        Stéphane

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X