Modifier header principal

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Modifier header principal

    Bonjour à tous,

    Étant nouvel utilisateur de Joomla, j'aurais besoin de votre aide ...
    J'ai consulté plusieurs conversations à ce sujet mais je n'arrive pas à modifier ce header.

    J'utilise le template rhuk_milkyway et je souhaiterai modifier la bannière principale du site (celle en gris où il y a le logo Joomla et le texte ... because open sources matters). Enfin bref, je suis sûr que vous voyez de quoi je parle

    Je souhaiterai y placer une bannière que j'ai réalisée.

    1) Comment puis-je modifier la bannière existante ? (j'ai essayé de remplacer le logo, etc mais je n'ai que des morceaux de bannière...)

    2) La bannière originale fait 765 x 100, je souhaiterai modifier la taille en 765 x 150 (ou 200). Où puis-je modifier cela ? Dans le CSS ? Merci de m'indiquer où.

    D'avance, je vous remercie tous pour votre aide

    Tommy

  • #2
    Bonjour
    regarde par là :
    http://forum.joomla.fr/showthread.ph...taille-du-logo
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Bonjour,

      J'ai moi-meme modifié le template.css du même modèle (rhuk_milkyway) et malgré tout mon image ne s'affiche pas !!
      Quand je remet le nom de l'image de base (mw_joomla_logo.png) celle-ci s'affiche correctement !!
      Y-a-t-il des exigences particulières pour des images perso. à mettre dans le header ? Dans mon cas l'image est de type .png aux même dimensions que l'image standard(mw_joomla_logo.png).

      Cdt.

      Jean-Pierre

      Commentaire


      • #4
        Bonjour,
        non ça doit marcher, au rafraichissement du navigateur près, si tu mets ton image à la place de l'autre.
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Bonjour,

          Voici la modification que j'ai faite... et mon image ne s'affiche toujours pas..
          Je fais un 'rafraichi' d'écran (F5 ou CRTL+F5) et rien ne change.
          L'image se trouve dans le répertoire /images du Template utilisé (comme celle utilisée en standard).

          Cdt,

          Jean-Pierre

          div#logo {
          position: absolute;
          left: 0;
          top: 0;
          float: left;
          width: 298px;
          height: 75px;
          background: url(../images/mw_bandeau1.png) 0 0 no-repeat;
          margin-left: 30px;
          margin-top: 25px;

          Commentaire


          • #6
            Re,
            tu es en local ? Sinon on peut voir ? Peut-être un problème de casse (maj/min dans le nom du fichier) ?
            Installe Firebug sous Firefox clic droit sur ton logo absent et "inspecter un élément". Tu verras ton div logo à gauche et le syle qui s'applique a droite, donc tu sauras si le style est correct si l'image est trouvée derrière etc.
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Bonsoir,

              Je travaille effectivement en local...
              Le résultat de la manip demandée est le suivant pour le div log de gauche:

              div#logo {
              background:url("../images/mw_bandeau1.png") no-repeat scroll 0 0 transparent;
              float:left;
              height:75px;
              left:0;
              margin-left:30px;
              margin-top:25px;
              position:absolute;
              top:0;
              width:298px;
              }


              Jean-Pierre

              Commentaire


              • #8
                Re,
                tu as vérifié la casse ? Ce que tu as copié est ce que monte Firebug ? Quand tu passes le curseur sur "../images/mw_bandeau1.png" tu vois l'image au survol ? Sinon c'est que Firebug ne trouve pas l'image (non plus), donc normal qu'elle ne s'affiche pas...
                Schtroumpfe toi le Schtroumpf t'aidera.
                Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                Commentaire


                • #9
                  Re... bonsoir,

                  Problème résolu... L'image était dans le sous-dossier Images du dossier template que j'utilise mais dans le répertoire Joomla.
                  En fait j'ai déplacé cette image dans le même sous-répertoire du répertoire MovAmp que j'ai installé pour travailler en local.
                  Et cette fois-ci ça fonctionne correctement !

                  Merci pour ton aide.

                  Cdt,

                  Jean-Pierre
                  Dernière édition par chti56 à 29/09/2010, 19h33

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X