Joomladay francophone 2018 à Paris 18 et 19 mai

Pb avec de <div> dans template

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Pb avec de <div> dans template

    Bonjour,

    J'ai retouché un template pour mon site internet par contre bizarrement quand je clique sur les liens appartenant à la rubrique "News du blog Crm" il me rajoute une vilaine <div> en bas à gauche dans le menu.

    Un peu d'aide ne serait pas de refus...voici le site en question: www.fremont.eu

    Merci d'avance
    Dernière édition par sheira31 à 29/05/2009, 13h28

  • #2
    Salut,

    Tu es certaine que c'est un soucis de <div> ??
    Je le vois plutôt comme un module vide, publié et assigné à une page ...

    div.module_menu
    Regarde au niveau de tes modules, si ce n'est pas ça on regardera dans le code

    @+

    Pierre

    Commentaire


    • #3
      Voilà ce que j'ai dans le css concernant le module...mais faut dire que je vois pas trop ce qu'il fait:

      Code:
      /* module control elements */
      table.user1user2 div.moduletable {
      	margin-bottom: 0px;
      }
      
      div.moduletable, div.module {
        margin-bottom: 25px;
      }
      
      div.module_menu, div.module {
      	margin: 0;
      	padding: 0;
      }
      
      div.module_menu div, div.module {
      	background: url(../images/menu_bg.png) top center repeat-y;
      }
      
      div.module_menu div div, div.module div div {
      	margin-bottom: 14px;
      	padding: 0 0 1px 0;
      	background: transparent url(../images/menu_top_out.png) top center no-repeat;
      }
      
      div.module_menu div div div, div.module div div div{
      	width: auto;
      	margin: 0;
      	padding: 0 4px 12px 0;
      	background: url(../images/menu_bottom.png) bottom center no-repeat;
      	text-align: left;
      }
      
      div#newsflash div.module div div {
      	padding: 0 0 1px 0;
      	background: none
      }
      
      div#newsflash div.module div div div{
      	width: auto;
      	margin: 0;
      	padding: 0;
      	text-align: left;
      	background: none
      }
      
      div#newsflash div.module div div  table.contentpaneopen {
      	margin: 0;
      	padding: 0 10px 0 0;
      	background: none
      }
      
      div#newsflash div.module_menu div, div#newsflash div.module  {
      	background: none;
      }
      
      div.module_menu div div div div, div.module div div div div {
      	background: none;
      	padding: 4px 8px;
      }
      
      div.module div div div form {
      	padding: 4px 0 0 0;
      	width: 164px;
      	margin: 0 auto;
      	text-align: left;
      }
      
      
      div.module_menu ul {
      	list-style: none;
      	text-align: left;
      }
      
      div.module_menu ul li{
      	margin: 0;
      	padding: 0;
      }
      
      div.module_menu ul li a:link, div.module_menu ul li a:visited {
      	font-weight: bold;
      	background: transparent url(../images/blue/bullet2.jpg) top left no-repeat;
      	padding: 2px 0 2px 25px;
      	line-height: 24px;
      	text-decoration: none;
      	color: #2EB6F4;
      	font-size: 11px;
      }
      
      div.module_text div div div div  {
      	background: url(../images/menu_bg.png) top center repeat-y;
      	margin:0 auto;
      	
      }

      Commentaire


      • #4
        il répète apparemment plusieurs fois mais là y a pas lieu de répéter je comprends pas

        div.module_menu div, div.module {
        background: url(../images/menu_bg.png) top center repeat-y;
        }

        Commentaire


        • #5
          Tu as un problème au niveau de tes modules, l'un deux (assez vide apparemment) doit être publié et assigné à la position "colonne gauche", seulement pour certaines pages, c'est pour ça qu'il n'apparait pas sur l'accueil par exemple. Trie tes modules par "publié" au lieu de "nom" et tu verras le fautif.

          (enfin normalement)

          Commentaire


          • #6
            Voilà ce que j'ai quand je trie les modules:

            Code:
            div.module_menu div div div, div.module div div div {template.css (ligne 599)
            background:transparent url(../images/menu_bottom.png) no-repeat scroll center bottom;
            margin:0;
            padding:0 4px 12px 0;
            text-align:left;
            width:auto;
            }
            div.module_menu div div, div.module div div {template.css (ligne 593)
            background:transparent url(../images/menu_top_out.png) no-repeat scroll center top;
            margin-bottom:14px;
            padding:0 0 1px;
            }
            Hérité dediv#leftcolumn
            #leftcolumn, #rightcolumn {template.css (ligne 242)
            text-align:left;
            }
            Ça m'aide pas trop parce que ces modules ne se répète pas apparemment.

            Commentaire


            • #7
              C'est pas dans ta css qu'il faut regarder mais dans l'administration de joomla, rubrique modules ....

              Commentaire


              • #8
                OK AUTANT POUR MOI.

                J'ai sélectionné le template en question et l'état "activé".

                filtre: Aller remsie à zéro
                # nom du module activé ordre sauver l'ordre accès position pages type id
                affichage #
                1 recherchez activé public left tous mod_search 17
                2 pied de page personnalisé activé public footer tous mod_custom 20
                3 menu activé déplacer vers le bas public left tous mod_mainmenu 1
                4 nouvelles offres activé déplacer vers le haut déplacer vers le bas public left tous mod_latestnews 18
                5 news du blog crm activé déplacer vers le haut public left tous mod_latestnews 22
                voilà ce que j'obtiens ... ce serait le module de recherche qui poserait problème?
                Dernière édition par sheira31 à 28/05/2009, 15h44

                Commentaire


                • #9
                  Bonjour sheira31

                  Fais nous une capture de la rubrique de gestion des modules (toutes les pages) :
                  Menu Extensions > Gestion des modules

                  On va comme ça voir le nombre de modules qui sont activés pour la position gauche
                  Christophe Malo aka misterMAG-i
                  -> MAC "Addict" USER <-
                  -> Développeur indépendant (App MAC, iPhone, WEB) <-

                  Commentaire


                  • #10
                    Re,

                    Ne pas confondre CSS et gestionnaire de modules (partie admin) !

                    Pierre

                    Commentaire


                    • #11
                      Filtre: Aller Remsie à zéro - Sélectionnez le template -siteground-j15-44- Sélectionnez la position -footerleft- Sélectionnez le type -mod_custommod_latestnewsmod_mainmenumod_searchmod_ syndicate- Sélectionner un état -ActivéDésactivé # Nom du module Activé Ordre Accès Position Pages Type ID Affichage #5101520253050100Tous

                      1 Recherchez Public left Tous mod_search 17 2 Pied de page personnalisé Public footer Tous mod_custom 20 3 Menu Public left Tous mod_mainmenu 1 4 Nouvelles offres Public left Tous mod_latestnews 18 5 News du Blog CRM Public left Tous mod_latestnews 22



                      Oui je sais...c'est pas top...
                      Tous les modules sont positionner à quache sauf le module mod_custom qui comprend le "Pied de page personnalisé".

                      J'espère que ça vous aidera...
                      Dernière édition par sheira31 à 28/05/2009, 15h54 Raison: mauvaise capture

                      Commentaire


                      • #12
                        Attend on va faire plus simple là.

                        Tu vas dans l'admin. Ensuite :
                        > Extensions
                        > Gestion des modules
                        > La tu cliques sur Activé (et non pas Activer). C'est juste au-dessus de la colonne avec des croix rouges et des ticks verts.

                        Tu fais une capture de ça et tu l'envoies.

                        Sinon, si tu veux quand même essayer de faire un truc pour t'aider, tu nous dis à quelle "position" joomla correspond la colonne de gauche de ton site.

                        Commentaire


                        • #13
                          # Nom du module Activé Ordre Accès Position Pages Type ID

                          1 Recherchez Activé 0 Public left Tous mod_search 17
                          2 Pied de page personnalisé Activé 0 Public footer Tous mod_custom 20
                          3 Menu Activé 2 Public left Tous mod_mainmenu 1
                          4 Nouvelles offres Activé 3 Public left Tous mod_latestnews 18
                          5 News du Blog CRM Activé 4 Public left Tous mod_latestnews 22
                          6 RSS Blog CRM Activé 4 Public left Variables mod_syndicate 23

                          Pas sûr que ce soit mieux
                          Dernière édition par sheira31 à 28/05/2009, 16h50

                          Commentaire


                          • #14
                            Ok, ya un truc que je pige pas : tu sais installer joomla, tu sais créer un template, mais tu ne sais pas ce qu'est une capture d'écran ?!!!!


                            Donc une capture d'écran c'est une image, une photo si tu préfères, de ton écran. Ca permet aux autres de voir ce que tu vois.

                            Tu peux en obtenir une, si tu es sous windows, en appuyant sur "Impr écran Syst" sur ton clavier. Ensuite tu vas dans Paint, tu fais édition>coller, puis tu sauve ton image et ainsi tu peux nous l'envoyer sur le forum.

                            Commentaire


                            • #15
                              sur la page qui pose problème :
                              http://www.fremont.eu/2009052671/blo...vee-fonds.html

                              1 Recherchez Activé 0 Public left Tous mod_search 17
                              >> Il semble être là

                              2 Pied de page personnalisé Activé 0 Public footer Tous mod_custom 20
                              >> Lui aussi

                              3 Menu Activé 2 Public left Tous mod_mainmenu 1
                              >> idem

                              4 Nouvelles offres Activé 3 Public left Tous mod_latestnews 18
                              >> itoo

                              5 News du Blog CRM Activé 4 Public left Tous mod_latestnews 22
                              >> yop

                              6 RSS Blog CRM Activé 4 Public left Variables mod_syndicate 23
                              >> Désactive celui là pour tester


                              D'ailleurs tu verras que sur cette page il y le picto RSS : http://www.fremont.eu/blog-crm/
                              Le module RSS doit être mal configuré.
                              Christophe Malo aka misterMAG-i
                              -> MAC "Addict" USER <-
                              -> Développeur indépendant (App MAC, iPhone, WEB) <-

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X