erreur 500 après installation

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] erreur 500 après installation

    Bonjour à toutes et à tous.

    Je reviens vous voir après mes soucis de transfert de bdd, pour d'autres déboires!

    Quelque soit la façon dont je transferts mon site local sur mon serveur ovh, j'ai une belle erreur 500...

    Mon site : http://www.cercle-shorinjikempo-orleans.org/

    Pour le cas présent, j'ai simplement installé Joomla! 1.5.12, après l'avoir décompressé dans un dossier sur mon pc, puis transféré avec FileZilla.

    Je suis chez ovh, j'ai un 60gp.
    Jusqu'à présent (depuis 4 ans) j'avais un simple site statique qui fonctionnait très bien, mais je n'avais pas besoin de ma bdd.

    Plusieurs points étranges :

    Après chargement de Joomla! sur mon serveur, mais avant la procédure d'installation, j'ai déjà une erreur 500, et j'ai dû entrer l'adresse exacte (monsite/installation/) pour lancer la procédure.

    Après installation (et effacement du dossier installation), je peux me connecter à l'interface d'administration, mais pas au site.
    Voyez : http://www.cercle-shorinjikempo-orle...administrator/...

    Le plus bizarre : si je crée un sous-dossier (monsite/dossier/) et que par FileZilla je transfère tout tel que, le site fonctionne, pas d'erreur 500...

    Je n'ai pas fait d'importation de bdd, il n'y a que celle créée durant l'installation.


    Merci d'avance pour vos suggestions!
    Dernière édition par laurent.qn à 06/07/2009, 09h36

  • #2
    Bonjour.

    Les liens ci-dessus ne sont plus valides, j'ai réinstallé mon vieux site html tout plein de cadres!!

    Mais je vous confirme : sans toucher aux chmod et au fichier htaccess.txt, si j'installe Joomla! à la racine j'ai une erreur 500, avant même l'installation, et ensuite seule l'interface d'administration est accessible, mais si je le place dans un sous-dossier, l'installation se lance normalement, et le site est ensuite disponible...

    Commentaire


    • #3
      As-tu mis ton site dans le dossier www ?
      Sinon, ci-joint un tutoriel pour la restauration d'un site chez ovh à partir d'une archive joomlapack
      La procédure est la même pour une intallation (à partir du point B -) Préparation du dossier, 3 -) En distant), si ta base de données est ok
      Fichiers joints
      Dernière édition par gentil_manager à 07/07/2009, 09h19
      La critique est facile mais l'art est difficile
      Quand on cherche on trouve
      http://www.gcsites.fr

      Commentaire


      • #4
        Envoyé par gentil_manager Voir le message
        As-tu mis ton site dans le dossier www ?
        Oui, il y était...
        Envoyé par gentil_manager Voir le message
        Sinon, ci-joint un tutoriel pour la restauration d'un site chez ovh à partir d'une archive joomlapack
        La procédure est la même pour une intallation (à partir du point B -) Préparation du dossier, 3 -) En distant), si ta base de données est ok
        Merci, je tenterai une nouvelle migration avec le joomlapack, en faisant bien attention à importer ma base en UTF8 compatible mysql40...

        Commentaire


        • #5
          Bonsoir tout le monde!

          Je n'ai pas encore essayé la migration avec Joomlapack (ferai ça plus tard) mais mon site marche dans un sous-dossier...

          Mon site : csko, et de même pour la partie d'administration...

          Ma procédure :

          Avec FileZilla : transfert de tout mon site local sur mon serveur ovh.

          En même temps (je l'avais) : avec phpMyAdmin, exportation et importation des tables de ma bdd locale sur ma bdd ovh.

          Après le transfert complet, j'ai édité le fichier configuration.php (le distant, que j'ai mis sur mon pc dans un autre dossier que mon site local, pour éviter de me mélanger les pinceaux) pour modifier les paramètres concernant l'accès aux dossiers logs et tmp, ainisi que ceux de ma bdd ovh et l'accès ftp. Puis re-transfert avec FileZilla sur mon serveur ovh pour remplacer celui qui a été transféré avec le reste de mon site.

          Je n'ai pas touché au htaccess.txt...

          Ça marche.



          Prochaine étape : soit je met une redirection à la racine de mon site (le www d'ovh) et j'arrête de m'arracher le peu de cheveux qui me restent et de me coucher à pas d'heure, soit je réinstalle avec joomlapack (en priant que ça marche) à la racine...

          J'me tate...

          Commentaire


          • #6
            Bonjour.

            Toujours le même problème, même en suivant la procédure avec Joomlapack...

            Commentaire


            • #7
              t'a bien créé un dossier "sessions" à la racine de ton site ?

              Commentaire


              • #8
                Bonjour Skand.

                Oui, il y a un dossier 'sessions' à la racine, au même rang que mon 'www'.

                Commentaire


                • #9
                  moi je le met ds le www

                  Commentaire


                  • #10
                    Je viens de charger via FileZilla la dernière version de Joomla (1.5.14) à la racine (www).

                    J'ai ajouté un dossier 'sessions' à 'www', mais je ne peux toujours pas accéder directement à l'interface d'installation...

                    Par contre si je pointe sur la partie d'administration (www.monsite.org/administrator), j'accède à l'interface d'installation.

                    Je viens de faire l'installation : je peux accéder sans problème à la partie administration, mais j'ai toujours mon erreur 500 pour la partie publique...

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X