Erreur 404 impossible de trouver le module lors dl'accès admin

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Erreur 404 impossible de trouver le module lors dl'accès admin

    Bonjour,

    J'ai développé un site en local et je viens de le mettre online, par transfert de fichiers + dump de la database

    http://s289303339.onlinehome.fr/


    Mais lorsque je veux aller dans la partie administrator, il me donne une erreur 404 impossible de trouver le module.

    J'ai vérifié, en local pas de soucis, et j'ai bien mis tous les fichiers.


    Merci d'avance pour votre aide.

  • #2
    Aide sur ce problème

    Bonsoir,

    personne n'a d'idée sur le sujet, car en regardant les sujet similaires, aucune des solutions proposées ne fonctionne

    Merci !!

    Commentaire


    • #3
      Bonjour

      As tu un acces ftp ?

      @+
      SVP pas de MP pour de l'aide, le forum est l’outil idéal

      Commentaire


      • #4
        Bonjour,

        Oui, de quel type d'accès as-tu besoin ? en terme dr droits et chemin d'accès ?

        Commentaire


        • #5
          pour le ftp , contactes moi sur nightf94@hotmail.fr

          Commentaire


          • #6
            Re

            Je reformule ma question...as tu acces à ton FTP et a ta base de donnée

            @+
            SVP pas de MP pour de l'aide, le forum est l’outil idéal

            Commentaire


            • #7
              Oui, accès aux deux, c'est d'ailleurs avec le ftp et phpmyadmin que j'ai mis en ligne

              Commentaire


              • #8
                Ok donc tu as installé ton site sur distant mais tu na pas fait pointer le fichier config.php sur ton nouveau serveur je pense.

                Par ftp récupère ce fichier et ouvre le afin de paramétrer le bon pointage puis le remettre par ftp

                @+
                SVP pas de MP pour de l'aide, le forum est l’outil idéal

                Commentaire


                • #9
                  Fichier config

                  Il y a deux fichiers config, config.php et config-dist.php qui ont le même contenu


                  Je l'avais maj par rapport aux accès mysql

                  Voilà le contenu


                  <?php
                  class JConfig {
                  /* Site Settings */
                  var $offline = '0';
                  var $offline_message = 'Ce site est en maintenance.<br /> Merci de revenir ultérieurement.';
                  var $sitename = 'Bacly';
                  var $editor = 'tinymce';
                  var $list_limit = '20';
                  var $legacy = '0';
                  /* Debug Settings */
                  var $debug = '0';
                  var $debug_lang = '0';
                  /* Database Settings */
                  var $dbtype = 'mysql';
                  var $host = 'db2049.1and1.fr';
                  var $user = 'dbo295345644';
                  var $password = '****'; / il est bien renseigné
                  var $db = 'db295345644';
                  var $dbprefix = 'jos_';
                  /* Server Settings */
                  var $live_site = '';
                  var $secret = '1z8Ds9SuD6YEnJiE';
                  var $gzip = '0';
                  var $error_reporting = '-1';
                  var $helpurl = 'http://help.joomla.org';
                  var $xmlrpc_server = '0';
                  var $ftp_host = '127.0.0.1';
                  var $ftp_port = '21';
                  var $ftp_user = '';
                  var $ftp_pass = '';
                  var $ftp_root = 'bacly';
                  var $ftp_enable = '0';
                  var $force_ssl = '0';
                  /* Locale Settings */
                  var $offset = '0';
                  var $offset_user = '0';
                  /* Mail Settings */
                  var $mailer = 'mail';
                  var $mailfrom = 'bacly@gmail.com';
                  var $fromname = 'Bacly';
                  var $sendmail = '/usr/sbin/sendmail';
                  var $smtpauth = '0';
                  var $smtpuser = '';
                  var $smtppass = '';
                  var $smtphost = 'localhost';
                  /* Cache Settings */
                  var $caching = '0';
                  var $cachetime = '15';
                  var $cache_handler = 'file';
                  /* Meta Settings */
                  var $MetaDesc = 'Joomla! - le portail dynamique et système de gestion de contenu';
                  var $MetaKeys = 'joomla, Joomla';
                  var $MetaTitle = '1';
                  var $MetaAuthor = '1';
                  /* SEO Settings */
                  var $sef = '0';
                  var $sef_rewrite = '0';
                  var $sef_suffix = '0';
                  /* Feed Settings */
                  var $feed_limit = 10;
                  var $feed_email = 'author';
                  var $log_path = '\bacly\\logs';
                  var $tmp_path = '\tmp';
                  /* Session Setting */
                  var $lifetime = '15';
                  var $session_handler = 'database';
                  }
                  ?>

                  Commentaire


                  • #10
                    var $dbtype = 'mysql';
                    var $host = 'xxxxxxxxxxxxxx';
                    var $user = 'xxxxxxxx';
                    var $db = 'xxxxxxxxxx';
                    var $dbprefix = 'jos_';
                    Ha pas sur mais dis moi il te manque les var de la BDD.

                    Mais question sur ton local tu avais supp le doss installation?

                    Ton installation par ftp c d'avoir fait une installation sur le distant simplement?

                    @+
                    SVP pas de MP pour de l'aide, le forum est l’outil idéal

                    Commentaire


                    • #11
                      Les vars de la bdd sont bien renseignées

                      var $host = 'db2049.1and1.fr';
                      var $user = 'dbo295345644';
                      var $password = '****'; / il est bien renseigné
                      var $db = 'db295345644';

                      L'accès par le front-end marche bien, ce qui le prouve.


                      Ce que j'ai fait de manière plus précise :

                      - Copier le répertoire de mon site vers le site distant en ayant pris soin de modifier les param de la BDD dans le fichier de config
                      - créer les tables de la bdd distante avec les données en utilisant un dump de la base locale

                      Commentaire


                      • #12
                        Une précison,

                        L'adresse du site est http://s289303339.onlinehome.fr/bacly/

                        j'avais oublié le répertoire

                        Commentaire


                        • #13
                          Bonjour

                          Je vois que ton site est correcte en front donc c ok ou pas maintenant?

                          @+
                          SVP pas de MP pour de l'aide, le forum est l’outil idéal

                          Commentaire


                          • #14
                            En fait, je n'ai pas été clair au début, car je n avais pas mis l'adresse complète.


                            Le site public fonctionne bien, mais si tu rajoutes /administrator à la fin, tu obtiens une page d'erreur 404

                            Commentaire


                            • #15
                              Une piste cela ne viendrait-il pas de ton serveur?

                              Une chose est sur c que le site en front est correctement actif avec le back end qui tourne c sur!

                              Ton hébergeur a t-il un wiki pour voir ce k'ils en disent?

                              @+
                              Dernière édition par LeMalouin à 27/09/2009, 11h42
                              SVP pas de MP pour de l'aide, le forum est l’outil idéal

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X