Joomladay francophone 2018 à Paris 18 et 19 mai

Hebergement free : Erreur 404 sur index.php après 10 minutes de fonctionnement

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Hebergement free : Erreur 404 sur index.php après 10 minutes de fonctionnement

    Bonsoir,

    J'ai installé Joomla 1.5.14 chez free. http://xxxxxxx.free.fr/
    J'ai passé l'étape des sessions et du .htaccess (php 1) et mon site était opérationnel

    J'ai pu accéder au site en passant par l'index, je me suis ensuite connecté en admin pour mettre en place mon contenu.

    En voulant vérifier l'avancement, je me suis pris une erreur 404 sur la racine de mon site
    J'ai réessayé plusieurs fois, en vidant le cache, en changeant de navigateur mais y'a rien à faire

    Idem en forçant http://xxxxxxx.free.fr/index.php, alors que si je mets un index.html bidon, je peux y accéder.

    J'ai une légère culture web, et il me semblait que le .htaccess imposait un comportement identique à tous les fichiers contenus dans son répertoire.
    Pourquoi l'index.php ne répond pas?
    Je précise qu'entre le moment où ça marchait et celui où ça n'allait plus, je n'ai rien fait d'autre que de la gestion de contenu (menus, articles).

    Merci à ceux qui me liront et encore plus à ceux qui tenteront de m'aider!
    Dernière édition par aster57 à 30/09/2009, 14h21

  • #2
    Bonjour,

    J'ai un peu avancé: il se trouve que ce n'est pas l'accès à index.php qui pose problème mais plutôt l'accès à un des éléments appelés par index.php.

    J'ai ajouté des echos pour voir où ça n'allait pas et on dirait que c'est cette commande qui pose problème :
    $mainframe->dispatch($option);
    EDIT : la fonction dispatch bloque sur cette commande : $contents = JComponentHelper::renderComponent($component);

    Les echos précédents s'affichent, les suivants non.

    Je continue à creuser, si quelqu'un maitrise la fonctionnement interne de Joomla, ça me serait d'une grande aide car là je tâtonne dans le noir :/
    Dernière édition par aster57 à 30/09/2009, 09h34

    Commentaire


    • #3
      Bonjour,
      il y a deux secondes, coté admin ça marchait
      http://aristote.eis.free.fr/administrator/
      maintenant c'est un gros bazar... préviens quand tu fais des trucs !

      Une question avant que tu ne casses tout : pendant les dix minutes où ça marchait, tu n'aurais pas supprimé le mainmenu sans remettre dans la foulée un élément de menu par défaut ?
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        J'ai tout viré, je reprends une install from scratch car en effet, j'ai viré le contenu exemple, les articles et les menus
        J'ai fini par comprendre que mon erreur 404 était renvoyé par le moteur car il manquait un élément à afficher.

        Merci d'avoir pris le temps d'essayer et d'avoir mis le doigt sur l'erreur exacte!

        Saloperie de menu!

        Questions : dois je flusher ma BDD ou bien joomla le fait tout seul à l'install? EDIT : ca se fait tout seul
        Puis-je conserver mes articles? EDIT : trop tard, j'ai fait le bourrin

        Merci encore
        Dernière édition par aster57 à 30/09/2009, 11h09

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X