Passage de 1.5.8 à 1.5.14

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Passage de 1.5.8 à 1.5.14

    Bonjour suite au passage de la version 1.5.8 à la 1.5.14 le message suivant apparait à la place de ma page d'accueil :

    Warning: include(/homez.xx/xxxxxxxxxxxxx/www/component.php) [function.include]: failed to open stream: No such file or directory in /homez.xx/xxxxxxxxxxxxx/www/index.php on line 2

    Warning: include() [function.include]: Failed opening '/homez.xx/xxxxxxxxxxxxx/www/component.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.xx/xxxxxxxxxxxxx/www/index.php on line 2

    en remplaçant le fichier index.php ce situant à la racine par celui de ma sauvegarde en 1.5.8 le site redevient apparemment fonctionnel.

    Alors que dois-je faire? Y a t-il une réelle influance de ce fichier sur la mise à jour et le bon fonctionnement du site? Les deux fichier on l'air totalement différents entre ces deux versions mais je n'y comprends pas grand chose... Après je ne sais pas si c'est forcement dû à ce fichier index.php, le problème vient peut-être d'ailleur?

    Merci de bien vouloir m'aider.
    Dernière édition par baboulinor à 21/10/2009, 14h42

  • #2
    Bonjour,
    tu as fait ça cf ici :
    Nota: En cas de mise à jour d'un site antérieur à Joomla 1.5.10, il faut impérativement éditer la configuration globale et la re-sauvegarder !!!
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Rep :

      Oui, j'ai edite et sauvegarde la configuration generale a plusieur reprise sans resultat... Je ne sais pas quoi faire d'autre. Est-il possible que se soit lie avec le fichier .htaccess?
      Dernière édition par baboulinor à 10/10/2009, 14h32

      Commentaire


      • #4
        Envoyé par baboulinor Voir le message
        Oui, j'ai edite et sauvegarde la configuration generale a plusieur reprise sans resultat... Je ne sais pas quoi faire d'autre. Est-il possible que se soit lie avec le fichier .htaccess?
        Bonjour, moi je viens aussi de faire la mise à jour ça marche pas !!!! Je n'ai aucun message d'erreur et pourtant après avoir fait plusieur sauvegarde de la configuration générale, je n'obtiens qu'une page blanche sans message quelconque. PLLLEEEAAASSSEEEE HELP !!!!!

        Commentaire


        • #5
          Bonjour a tous,

          Je suis presque dans la meme galére que vous avec la mis a jour : j'etait a 1.5.9 ... et j'ai voulu passer en 1.5.14 et je suis dans le néant !!!

          J'aimerai que quelqu'un m'explique ou plutot nous explique clairement et simplement ce que vous appelez

          éditer la configuration globale et la re-sauvegarder
          Ca je vois pas exatement ce qu'il faut ou plutot fallait faire

          Merci d'avance

          Commentaire


          • #6
            Bonjour,
            il doit y a avoir un ou 2 nouveauc trucs, donc il faut juste aller dans l'admin, configuration globale et enregistrer pour les ajouter.
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Bonjour,

              Visiblement, l'enregistrement de la configuration globale ne change rien au problème...
              Pour moi cela se situe au niveau du fichier index.php de la mise à jour 1.5.x vers 1.5.14 situé à la racine.

              Commentaire


              • #8
                Bonjour,
                je viens de comparer les index.php d'une 1.5.9 avec celui d'une 1.5.12 (c'est ce que j'avais sous la main) : ils sont identiques. Dans ton cas, tu vois quelles différences ?
                Schtroumpfe toi le Schtroumpf t'aidera.
                Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                Commentaire


                • #9
                  Je suis un mec un peut lourd je sais...

                  J'ai galérer comme un chien pour passer de la 9 a la 14 ...

                  J'ai écumer le forum mais personne ne prend le temps d'expliquer as l'air tellement simple pour tout le monde que les quelques débutant dont je fait partie sont a la rame complet ....

                  J'ai tenter de passer la soiré sur le probleme ... j'ai trouver une solution qui doit pouvoir interesser pas mal de monde et qui est aussi simple que longue...

                  J'ai récupere et installer les differents patch de la 9 a la 10 puis de la 10 a la 11 ... ainsi dessuite ...pour arriver a la derniere version...

                  Je tien a signaler que si on serait tous un peut moins laxiste on retrouverez pas avec 5 versions d'ecart comme ce fut mon cas ... donc j'invite tout le monde a faire les mises a jours régulierement

                  En esperant avoir donnée une solution a certain qui etait dans les choux !!!

                  Commentaire


                  • #10
                    Re,
                    J'ai récupere et installer les differents patch de la 9 a la 10 puis de la 10 a la 11 ... ainsi dessuite
                    Tu avais essayé le patch cumulatif ici : http://aide.joomla.fr/telechargement....5.x/index.php ?
                    Schtroumpfe toi le Schtroumpf t'aidera.
                    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                    Commentaire


                    • #11
                      En effet j'ai tenter dans un premier temps de metre le patch cumulatif...

                      Mais j'ai ete confronté au un site VIDE !!! j'ai fait avoir une attaque ... c

                      J'avais une jolie page blanche a la place de mon site ... j'ai batailler toute la soirée .. le mieux que j'ai eu ca as ete un message d'erreur

                      La parti admin ... comme le reste un grand néant blanc !

                      Comme j'ecoute ce que l'on me dit j'avais fait une sauvegarde heursement j'ai rebalancer l'ancienne version avec tout ce qu'il falais de du 1.5.9 ...

                      Et ca as remarcher ... écoutant que mon courage j'ai tenter la mise a jour vers la 1.5.10 ... ca as marcher du coup j'ai fait pas a pas !

                      Du coup : OUF !!!

                      Je suis en train de faire la mise a jour d'un second site avec la meme technique ...

                      Commentaire


                      • #12
                        index.php

                        Envoyé par Grand Schtroumpf Voir le message
                        Bonjour,
                        je viens de comparer les index.php d'une 1.5.9 avec celui d'une 1.5.12 (c'est ce que j'avais sous la main) : ils sont identiques. Dans ton cas, tu vois quelles différences ?
                        Bonjour Grand Schtroumpf,
                        Ba c'est simple, dans la version de la mise à jour 1.5.x vers 1.5.14, il n'y a qu'une ligne :

                        <?phpinclude dirname(__FILE__).DIRECTORY_SEPARATOR.'component.p hp';?>

                        alors que dans la version de ma sauvegarde en 1.5.8 (qui tourne actuellement sur mon site) il y en a une bonne cinquantaine. Et même si la plupart son des commentaires, je vois bien qu'il y a beaucoup de différences...

                        As-tu le même fichier index.php à la racine de ta version 1.5.12?

                        Merci de votre aide.
                        Dernière édition par baboulinor à 21/10/2009, 14h37

                        Commentaire


                        • #13
                          D'ailleurs j'ai aussi essayé avec le fichier index.php de la version 1.5.14 et non pas de la mise à jour et là j'ai le message d'erreur suivant, même après une énième sauvegarde de la configuration générale :

                          Restricted access

                          Ce qui sous entend que ce fichier est aussi différent de celui de la mise à jour...
                          Je ne comprend pas trop la logique de tous ces fichiers différents pour une mise à jour qui ce fait en écrasant les anciens fichiers...

                          Dans tous les cas mon site fonctionne en 1.5.14 avec le fichier index.php de la version 1.5.8 même si je ni comprends toujours rien... (cf. le premier post de ce topic)

                          Sinon on verra bien lors de la prochaine mise à jour!
                          Dernière édition par baboulinor à 21/10/2009, 14h44

                          Commentaire


                          • #14
                            Re,
                            Ba c'est simple, dans la version de la mise à jour 1.5.x vers 1.5.14, il n'y a qu'une ligne :
                            <?phpinclude dirname(__FILE__).DIRECTORY_SEPARATOR.'component.p hp';?>
                            Euh... je viens de recharger le patch 1.5.x vers 1.5.14, le index.php qui est dedans a une tête "normale", ce n'est pas un truc à une seule ligne...
                            Schtroumpfe toi le Schtroumpf t'aidera.
                            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                            Commentaire


                            • #15
                              Merci

                              Envoyé par Grand Schtroumpf Voir le message
                              Re,

                              Euh... je viens de recharger le patch 1.5.x vers 1.5.14, le index.php qui est dedans a une tête "normale", ce n'est pas un truc à une seule ligne...
                              Je viens de trouver la solution à mon problème! Effectivement le fichier index.php ne contient pas qu'une seul ligne...

                              Mais alors là faut qu'on m'explique ; Quand je l'ouvre directement avec IZArc il est bien normal, mais si je le décompresse sur mon bureau, il ne contient plus qu'une seul ligne?!!! Le plus bizarre, c'est que ça me le fait seulement avec ce fichier. Tous les autres ne subissent aucune altération après extraction sur mon bureau...

                              Alors, bug d'IZArc? Protection du fichier? Je n'y comprend rien. L'informatique des fois...

                              En tout cas merci à toi Grand Schtroumpf!!! Tu m'as permis de me rendre compte que le problème venait de moi et non pas d'un oubli dans le patch cumulatif...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X