Problème grave après installation

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème grave après installation

    Bonjour. Je connais Joomla depuis pas mal de temps, et je l'avais déjà utilisé. Mais aujourd'hui, j'ai rien compris. J'ai envoyé les fichiers sur mon serveur, RAS. Tout fonctionne parfaitement. On me demande de supprimer le dossier "installation" pour des raisons de sécurité que je comprend parfaitement. Grosse surprise lorsque que j'accède à mon site, il n'y a pas d'interface, texte noir sur fond blanc...

    Que c'est t-il passé ? En plus j'ai un message d'erreur dans l'administration "Error - No Data".

    J'attend vos réponses.

  • #2
    Bonjour,
    jette un oeil dans les dossiers (par exemple vers /templates...) : le FTP n'aurait pas oublié des bouts en route ?
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      De toute manière, il n'y pas la moindre raison que cela ne fonctionne pas.
      J'ai viré mes anciennes tables SQL, pour laisser la BDD libre (Il existait d'autres tables avant la première installation, provenant d'un autre site). Tout se passait très bien avant, alors je vais tâcher de de faire en sorte que tout se déroule correctement, quitte à se battre un peu avec le CMS. Je vais tout réinstaller et je vous tiens au courant.

      P.S: Si vous chercher un modérateur pour votre forum, vous pouvez compter sur moi!
      Dernière édition par Xaon à 20/11/2009, 20h39

      Commentaire


      • #4
        Ca n'a rien donné. Je n'ai toujours pas d'interface. D'où ça peut venir ?

        Commentaire


        • #5
          pareil pour moi , apres une mise a jour de 1.0.x vers 1.5.7 (derniere version de prend l'hebergeur (ifrancepro)) , je me retrouche avec une page qui me demande de retire le dossier installation et la page install , alors que l'installation ne se fait pas (pas de choix de langue et de configuation ) je voudrai savoir commentresoudre cette affaire

          Commentaire


          • #6
            Xaon: tu prends bien un pack joomla tout neuf sans y avoir touché avant ?

            Julie: il aurait mieux valut créer ton propre sujet... essaie de supprimer ou renommer le fichier configuration.php

            Commentaire


            • #7
              Bonjour,
              apres une mise a jour de 1.0.x vers 1.5.7
              Ça fait peur, écrit comme ça... le passage d'une 1.0 à une 1.5 n'est pas une mise à jour mais une migration : il FAUT lancer des scripts pour transformer les données, upgrader / remplacer/ jeter des extensions, revoir des trucs et des machins... Quand tu auras fini de régler tes problèmes actuels, tu risques tout simplement d'avoir un truc qui ne marche pas...
              (dernière version de prend l'hébergeur (ifrancepro))
              Ça doit vouloir dire je suppose que c'est la version que propose ton hébergeur à l'installation, ce qui prouve que ce n'est du tout son truc puisqu'il a décroché depuis 8 versions, quand même... Dans ces conditions il vaut mieux partir du dernier paquet d'installation disponible sur Joomla.fr
              je me retrouve avec une page qui me demande de retirer le dossier installation et la page install , alors que l'installation ne se fait pas
              Comme tu as copié ton paquet d'installation par dessus ton site existant, ton configuration.php est toujours en place, il est détecté par Joomla qui en conclut que l'installation est terminée. La bonne démarche dans ce cas de figure est de supprimer le fichier configuration.php, MAIS PAS DANS TON CAS : tu risques *en plus* de perdre tes données...

              Donc : si tu n'es pas en train de dérouler une migration planifiée et maîtrisée - ce dont je doute vu la question que tu poses - arrête tout. Recharge ta sauvegarde (ma quoi ?) ou sinon récupère sur Joomla.fr une 1.0.15 et remonte-la par FTP sur ton site, supprime le dossier installation et tu devrais être ramené au cas précédent (avec des fichiers inutiles partout, mais bon).

              Puis : pars d'une installation locale de ton site, étudie, prépare, planifie ta migration...
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                merci en supprimant le fichier configuration j'ai peut faire l'installation, merci

                regler pour moi

                merci

                en esperant pas avoir de bétises par la suite

                Commentaire


                • #9
                  Re,
                  merci en supprimant le fichier configuration j'ai peut faire l'installation, merci
                  Mouais...
                  tu es sûr d'avoir lu ce que j'ai écrit ? Ça veut dire que tu ne voulais pas garder ce que tu avais saisi sur ton site 1.0 ? Ça veut dire aussi que 8 mises à jour de sécurité de retard ça ne te fait pas peur ? Et enfin, il est probable que tu as plein tes dossiers des fichiers de ta feue version 1.0 (comme tu avais le configuration.php) qui dans le meilleur des cas prennent de la place et ne servent à rien, et s'il s'agit d'extensions peuvent bloquer de futures installations. Il est probable également que ta base de données est encombrée de tables bak_, sauvegarde qu'a fait l'installation de ta base 1.0.

                  Bonne chance pour la suite...
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    j'avais vider la base de donnée , car la cliente m'as donnée carte blanche pour refaire son site

                    j'avais enlever aussi tous les fichier du ftp avant d'installer la version 1.5.7

                    j'ai peur que les version suivante de joomla ne soit pas compatible

                    regardes à ce lien
                    https://www.ifrancepro.com/faq.php?id=192#f192

                    ou alors j'ai pas compris
                    mais je pense que le serveur ne supporte pas les mis a jour d'apres

                    ?
                    si non je ferai une mise a jour via le patch si c'est une bonne sollution

                    Commentaire


                    • #11
                      Ben essaie d'installer la dernière version et regarde si ca marche.... vaut mieux essayer que d'hypothèquer pendant des heures.

                      Commentaire


                      • #12
                        C'est vraiment étrange, ça ne fonctionne toujours pas (c'est la nouvelle version de Joomla). Je suis toujours sur le même serveur, je n'ai rien touché avant d'installer le CMS. L'installation se passe bien, je supprime le dossier INSTALLATION, et quand j'arrive sur le page d'accueil, rien, que le texte. En revanche, l'administration comporte une interface, et depuis la réinstallation, je n'ai plus le message rouge (Warning - No Data). J'ai même essayé avec une ancienne version de Joomla, celle que j'avais à l'époque et ça fait pareil! pas d'interface... Alors j'ai essayé d'installer un nouveau thème, même plusieurs à vrai dire, et je n'ai aucun aperçu avant de l'appliquer par défaut. Aucun thème fonctionne...

                        EDIT 16:58

                        Problème résolu pour l'interface. En fait, au lieu de supprimer le dossier Installation, j'ai juste enlever le index.php et maintenent ça refonctionne... Bizarre! Par contre, est-ce que je peux supprimer d'autres fichiers sensibles, dans ce même dossier, sans causer de dommage ? Au pire j'en fais une copie...
                        Dernière édition par Xaon à 25/11/2009, 16h01

                        Commentaire


                        • #13
                          Envoyé par Abriko Voir le message
                          Ben essaie d'installer la dernière version et regarde si ca marche.... vaut mieux essayer que d'hypothèquer pendant des heures.
                          ok , mise a jour faite , pour l'instant ca passe

                          merci

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X