Transfert FTP 1.5.9 vers 1.5.15 défectueux-solution éventuelle 1and1

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Transfert FTP 1.5.9 vers 1.5.15 défectueux-solution éventuelle 1and1

    Bonsoir,

    Après avoir procédé en local à l'installation (avec succès) du patch de mise à jour de 1.5.X vers 1.5.15 (j'étais en 1.5.9), j'ai effectué le transfert en site distant par File Zilla.

    J'ai bien respecté les consignes usuelles (cache vidé, site hors ligne,...).

    Le premier transfert a engendré en back end un message d'erreur ciblant sous le chemin librairies/joomla/application le fichier define.php en ligne 33 (même problème de message d'erreur en front end). Après m'être rendu compte que c'était la dernière ligne, j'ai naturellement pensé à un mauvais transfert FTP.

    J'ai ré-envoyé 3 autres fois tout le paquet du patch, 2 fois globalement et j'ai même tenté une fois de l'envoyer répertoire par répertoire. Résultat identique avec une petite amélioration lors de l'envoi des fichiers répertoire par répertoire où je suis arrivé en back end à retrouver la fenêtre d'accès à l'admin mais avec un message XML Parsing error at 24:36 Error 64 Reserved XML name rendant impossible la connection.

    Après plusieurs heures, j'ai réinstallé la sauvegarde en 1.5.9. Même problème. Pour restaurer le site, j'ai du supprimer complètement tous les fichiers sur le serveur puis remettre la sauvegarde en 1.5.9.

    Je me rends bien compte qu'il y a un problème de transfert, mais là après 4 envois en FTP, je me demande si cela sera satisfaisant un jour...

    Je me pose plusieurs questions:
    - y a t'il un problème sur les fichiers en place sur le serveur posant problème lors du transfert?
    - y a t'il un paramètre de filezilla qui pose problème?
    - faudrait il non pas que je mette le patch 1.5.X vers 1.5.15 mais carrément le pack complet 1.5.15 (sauf bien sur répertoire install et fichier configuration.php)
    - je suis sur 1and1 J'ai bien pensé à utiliser webtransfert au lieu de file zilla mais à ma connaissance sur le pakc de base dont je dispose chez 1and1 l'upload se fait fichier par fichier et ne peut pas se faire en sélectionnant plusieurs dossiers et fichiers en une seule fois.

    Voilà, je vous avoue mon désemparement et recherche bien évidemment une aide pour m'en sortir et arriver à installer proprement cette 1.5.15 qui encore une fois fonctionne bien en local.

    Pour info, je suis en php 5.2.11.
    Dernière édition par aldo62 à 05/12/2009, 15h34

  • #2
    Envoyé par aldo62 Voir le message
    Bonsoir,

    Après avoir procédé en local à l'installation (avec succès) du patch de mise à jour de 1.5.X vers 1.5.15 (j'étais en 1.5.9), j'ai effectué le transfert en site distant par File Zilla.

    J'ai bien respecté les consignes usuelles (cache vidé, site hors ligne,...).

    Le premier transfert a engendré en back end un message d'erreur ciblant sous le chemin librairies/joomla/application le fichier define.php en ligne 33 (même problème de message d'erreur en front end). Après m'être rendu compte que c'était la dernière ligne, j'ai naturellement pensé à un mauvais transfert FTP.

    J'ai ré-envoyé 3 autres fois tout le paquet du patch, 2 fois globalement et j'ai même tenté une fois de l'envoyer répertoire par répertoire. Résultat identique avec une petite amélioration lors de l'envoi des fichiers répertoire par répertoire où je suis arrivé en back end à retrouver la fenêtre d'accès à l'admin mais avec un message XML Parsing error at 24:36 Error 64 Reserved XML name rendant impossible la connection.

    Après plusieurs heures, j'ai réinstallé la sauvegarde en 1.5.9. Même problème. Pour restaurer le site, j'ai du supprimer complètement tous les fichiers sur le serveur puis remettre la sauvegarde en 1.5.9.

    Je me rends bien compte qu'il y a un problème de transfert, mais là après 4 envois en FTP, je me demande si cela sera satisfaisant un jour...

    Je me pose plusieurs questions:
    - y a t'il un problème sur les fichiers en place sur le serveur posant problème lors du transfert?
    - y a t'il un paramètre de filezilla qui pose problème?
    - faudrait il non pas que je mette le patch 1.5.X vers 1.5.15 mais carrément le dossier original 1.5.15 (sauf bien sur répertoire install et fichier configuration.php)
    - je suis sur 1and1 J'ai bien pensé à utiliser webtransfert au lieu de file zilla mais à ma connaissance sur le pakc de base dont je dispose chez 1and1 l'upload se fait fichier par fichier et ne peut pas se faire en sélectionnant plusieurs dossiers et fichiers en une seule fois.

    Voilà, je vous avoue mon désemparement et recherche bien évidemment une aide pour m'en sortir et arriver à installer proprement cette 1.5.15 qui encore une fois fonctionne bien en local.

    Pour info, je suis en php 5.2.11.
    j'ai constaté qu'il y a parfois des problèmes avec filezilla. utilises fireftp de mozilla qui fonctionne à merveille. tu verras bien.

    Commentaire


    • #3
      Envoyé par SCARPIA Voir le message
      j'ai constaté qu'il y a parfois des problèmes avec filezilla. utilises fireftp de mozilla qui fonctionne à merveille. tu verras bien.
      Bonsoir Scarpia,

      Merci du conseil. Je viens d'installer fireftp.

      J'essaie demain... je croise les doigts pour que ça marche

      Commentaire


      • #4
        Envoyé par aldo62 Voir le message
        Bonsoir Scarpia,

        Merci du conseil. Je viens d'installer fireftp.

        J'essaie demain... je croise les doigts pour que ça marche
        je te conseille tout de même de transférer dossier par dossier. ca charge moins le ftp.
        tu peux aussi essayer le composant Joomla update manager. c'est un compo qui que tu installes dans joomla et met à jour ta version depuis ton admin. très simple à utiliser et ultra rapide (rien à voir avec le transfert par ftp.)
        tu le trouves à ce lien
        http://extensions.joomla.org/extensi...nstallers/9332
        je ne fais mes mises à jour qu'avec ce compo.

        Commentaire


        • #5
          Envoyé par SCARPIA Voir le message
          je te conseille tout de même de transférer dossier par dossier. ca charge moins le ftp.
          C'était bien mon intention

          Envoyé par SCARPIA Voir le message
          tu peux aussi essayer le composant Joomla update manager.
          C'est une extension en .tgz, c'est cela? L'installation du composant par le back end échoue (il ne trouve pas de dossier d'installation avec ce .tgz
          Dernière édition par aldo62 à 04/12/2009, 23h35

          Commentaire


          • #6
            Envoyé par aldo62 Voir le message
            C'était bien mon intention



            C'est une extension en .tgz, c'est cela? L'installation du composant par le back end échoue (il ne trouve pas de dossier d'installation avec ce .tgz
            Extension en tgz. je l'ai installé sans problème sans dézipper. une fois installé, tu ouvres le compo depuis le menu composant de joomla, puis tu cliques sur lien en bleu (So lets continue our travels and download the update file >>>). update te proposera de lancer la maj (soit le pack complet, soit le patch. tu valides et il effectue la maj. après il faut aller supprimer le fichier installation comme d'habitude.

            Commentaire


            • #7
              Pour ce qui est de Joomla update manager, je n'ai pas pu l'installer, joomla me disant qu'il ne peut pas "lire" l'archive

              Par contre, j'ai tenté l'upload avec fireftp..... et Yes!!!! ça a fonctionné...

              Enfin, j'ai eu un petit message en front end

              Fatal error: Cannot redeclare modchrome_none() (previously declared in /homepages/0/........./htdocs/templates/system/html/modules.php:20) in /homepages/0/xxxxxxx/htdocs/templates/system/html/modules.php on line 138
              alors que le fichier en question n'a que 116 lignes.... mais après transfert à nouveau de ce fichier.... youpi.... le site est de nouveau de retour

              Mille merci à toi pour cette excellente suggestion

              Je tenterai quand même dans les prochains jours l'install de joomla update car peut être que le problème venait de mon site avec des extensions pas hyper nettes (car j'avais quelques messages étranges parfois).
              Dernière édition par aldo62 à 05/12/2009, 16h12

              Commentaire


              • #8
                Envoyé par aldo62 Voir le message
                Pour ce qui est de Joomla update manager, je n'ai pas pu l'installer, joomla me disant qu'il ne peut pas "lire" l'archive

                Par contre, j'ai tenté l'upload avec fireftp..... et Yes!!!! ça a fonctionné...

                Enfin, j'ai eu un petit message en front end



                alors que le fichier en question n'a que 116 lignes.... mais après transfert à nouveau de ce fichier.... youpi.... le site est de nouveau de retour

                Mille merci à toi pour cette excellente suggestion

                Je tenterai quand même dans les prochains jours l'install de joomla update car peut être que le problème venait de mon site avec des extensions pas hyper nettes (car j'avais quelques messages étranges parfois).
                génial. cherches quand meme pour update manager, tu devrais trouver des réponses sur le forum. le sujet a déjà été traité.

                Commentaire


                • #9
                  Envoyé par SCARPIA Voir le message
                  génial. cherches quand meme pour update manager, tu devrais trouver des réponses sur le forum. le sujet a déjà été traité.
                  Oui, je ferai d'abord des recherches via le moteur du forum.

                  Sinon j'ai eu quelques soucis avec Tiny MCE qui ne permettait pas l'insertion d'images et la mise en forme de texte malgré un paramétrage en mode étendu. En réenvoyant tout le dossier TinyMCE c'est redevenu normal.

                  J'ai vu que tu utilisais JCE. Tu en es satisfait? Quelles sont les différences par rapport à Tiny?

                  Commentaire


                  • #10
                    Envoyé par aldo62 Voir le message
                    Oui, je ferai d'abord des recherches via le moteur du forum.

                    Sinon j'ai eu quelques soucis avec Tiny MCE qui ne permettait pas l'insertion d'images et la mise en forme de texte malgré un paramétrage en mode étendu. En réenvoyant tout le dossier TinyMCE c'est redevenu normal.

                    J'ai vu que tu utilisais JCE. Tu en es satisfait? Quelles sont les différences par rapport à Tiny?
                    Je crois que jce est utilisé par une majorité de joomleurs. il est plus puissant et offre plus de possibilités avec tous ces plugin que tinymce.
                    va sur la page
                    http://extensions.joomla.org/extensi...ion/editors/88
                    et tu trouveras également le tuto.

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X