Mysql Online.net

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Mysql Online.net

    Bonjour,
    J’héberge un site joomla sur le service online.net
    Suite à la migration de leurs serveurs MYSQL j’obtiens l’erreur suivante sur la page d’accueil de mon site

    Code:
    Warning: Invalid argument supplied for foreach() in /components/com_content/models/frontpage.php on line 105
    
    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /libraries/joomla/database/database/mysql.php on line 343
    Il est interessant de noté que seul la page d'accueil est affecté, le reste du site fonctionne normalement. Ce site est hébergé sous joomla 1.5.15, après divers recherche ce problème serais du a MySql et non joomla.
    Le PhpMyAdmin de online.net m’indique bien certaines erreur sur ma base de données :

    Code:
    $cfg['Servers'][$i]['pmadb'] ... 	en erreur [ Documentation ]
    $cfg['Servers'][$i]['relation'] ... 	en erreur [ Documentation ]
    Fonctions relationnelles: désactivé
    $cfg['Servers'][$i]['table_info'] ... 	en erreur [ Documentation ]
    Affichage infobulle: désactivé
    $cfg['Servers'][$i]['table_coords'] ... 	en erreur [ Documentation ]
    $cfg['Servers'][$i]['pdf_pages'] ... 	en erreur [ Documentation ]
    Génération de schémas en PDF: désactivé
    $cfg['Servers'][$i]['column_info'] ... 	en erreur [ Documentation ]
    Commentaires de colonnes: désactivé
    Requêtes en signets: désactivé
    MIME ...	en erreur [ Documentation ]
    $cfg['Servers'][$i]['history'] ... 	en erreur [ Documentation ]
    Historique SQL: désactivé
    $cfg['Servers'][$i]['designer_coords'] ... 	en erreur [ Documentation ]
    Concepteur: désactivé
    A ce jour je n’ai toujours pas trouvé de solution à ce problème.
    Merci de l’aide que vous pourrez m’apporté.
    Dernière édition par galeo27 à 15/03/2010, 21h08

  • #2
    Bonjour,
    ta page d'accueil est vide, i.e. elle est de type "page d'accueil au format blog" et tu n'as coché sur aucun article "Afficher en page d'accueil". Il traine vers l'erreur une boucle sans test préalable pour savoir si la liste est vide, d'où le warning.

    > il serait logique qu'il y ait au moins un article en page d'acceuil ou que la page d'accueil soit d'un autre type.
    > sinon c'est un warning, sans impact sur le bon fonctionnement du script, donc il suffit de mettre le display_errors à off dans le php.ini ou via le .htaccess si tu n'y as pas accès.
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      non, au contraire
      j'ai bien des articles en page d'accueils,
      en fait quand je n''ai pas d'articles dans la page d'accueil, celle-ci est blanche
      elle affiche uniquement le titre de la page et pas de contenu ce qui est normal
      mais quand je met un article, j'ai cette erreur
      Dernière édition par galeo27 à 26/01/2010, 13h12

      Commentaire


      • #4
        personne n'a une idées ???

        Commentaire


        • #5
          Pour info, après désinstallation du composant GMACCESS, tout est rentré dans l'ordre, visiblement c'est ce composant qui posait problème.

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X